Page 1 of 1

Missing symbols in snd.o

Posted: Thu Aug 23, 2007 10:02 am
by Tobermory Womble
I think that the most recent version of alsa may have broken something.

I get the following when trying to modprobe snd_intel8x0 xbox=1
"Warning: /lib/modules/ symbol for parameter major not found
/lib/modules/ symbol for parameter cards_limit not found"

This is a clean build of Home 6.2 on a version 1.2 Xbox.
Following the build, I ran magic and emerged alsa-utils, alsa-tools and alsa-driver-xbox.
I have run etc-update, update-modules and depmod -ae, and everything looks clean.

I have tried rebuilding the kernel, but that didn't help either.

Posted: Sat Sep 22, 2007 5:46 pm
by marcan
Same exact problem here. I didn't even update the system or emerge alsa-driver-xbox, and neither did I run magic. All I emerged was mythtv, ntp, alsa-utils, and a few other random things, none of which should have any effect on the ALSA modules.

Please let me know if you do find a solution.

Posted: Sat Sep 22, 2007 6:16 pm
by marcan
Hmm, I managed to get it to load and work for me. I still get the warnings, but now it loads.

Try update-modules. Grep /etc/modules.conf to make sure there are no references to "snd". Then try to load the modules.

Posted: Sat Sep 22, 2007 10:08 pm
by Tobermory Womble
Well spotted. That did the job nicely, and I've even managed to get optical sound working from mythtv.

All I need to do is work out why there's no video on the HDTV...