rename rootfs

Request new features that might make using Gentoox better.
Post Reply
gate boy
Posts: 1
Joined: Thu Aug 03, 2006 2:14 pm

rename rootfs

Post by gate boy »

This is my first post here so if i do anything wrong please don't get too mad.

i was using the XBOXHDM linux distro to copy the rootfs to my computer. (XBOXHDM is a fatx enabled linux just incase anyone doesn't know.) when i tried to fsck rootfs using XBOXHDM with

Code: Select all

fsck.ext2 /mnt/hdb1/rootfs -vf
(EXT3 was too slow for me so i made it EXT2) i got a "rootfs is mounted R\W may cause damage" error even though it wasn't mounted. anyways i renamed the file to "gentooxfs" and ran

Code: Select all

fsck.ext2 /mnt/hdb1/gentooxfs -vf
it worked fine.

i'm not sure, but i think that certain linux distros refer to "/" as "rootfs"

I dont think this should be too hard to implement: just change something in the initrd. perhaps give an option to rename rootfs after installing and use a kernel command line (like fs=gentooxfs) to specify the file. if you do decide to implement the kernel command line option, it could be used to boot different installations without renaming files.
Gentoox Guru!
Posts: 606
Joined: Sun Oct 24, 2004 8:11 am

Post by orochi »

I would have to object to your theory of some linux distro's thinking "/" as "rootfs".

rootfs is an arbitrary name and it in itself has a root "/" when mounted as a loopback filesystem.
However in your case, unless you
1. mounted the drive you had rootfs on
2. mounted your rootfs as loopback
3. chroot'ed to your rootfs loopback

thats the only way (i can guess) you could get rootfs to appear as "/" in xboxhdm.

I would suggest extracting your rootfs to your hdd, and booting with something like knoppix to tinker with your rootfs. I would say it has a bit more tools do do things like fsck, retrieve data across smb, cross compile?, among others.

Perhaps I should have gone to bed earlier so i wouldnt look so much like a monkey if I am wrong :P
Post Reply