Page 1 of 1

Gentoox Bios video bug

Posted: Thu Jun 09, 2005 9:51 pm
by Cthulhu32
Well recently someone brought their softmodded box to me w/ an eeprom that had been changed by XMPC to use NTSC-J, so I hardmodded it in order to restore it, but I have had absolutely no luck. I'm pretty sure I'm getting a microsoft error and I can't see it.

So anyways, I install GentooX bios on this thing hoping to restore the video and run linux on the box, and when I go to Settings: Video Settings, the video setting says "Unknown" So I see this, try to press X to change the video setting to something known like NTSC-USA, but I get absolutely no response from this menu.

I know this works for switching because I can switch between video settings on my other box, but this box it just stays at Unknown, the bios won't switch it. My thoughts are that Shallax coded it so if its anything but the 3 settings it goes out of the switching while loop (not sure if that's how you did it) and if you get an unknown, it's already out of the while loop.

Is there any way to fix this myself or will I have to wait for Shallax to fix the bug so I can change the video setting from Unknown to NTSC-USA?


edit: oh yeah, the xbox is a 1.0 w/ a conexant video chip and an xecuter 2.6 ce chip installed

Posted: Thu Jun 09, 2005 11:07 pm
by vplayer
can you ssh into it and run xbvset ??

Posted: Fri Jun 10, 2005 12:50 am
by Cthulhu32
hey man, well it runs GentooX using xfce or kde just fine, because they force it to display NTSC, but the problem is I can't find a program in GentooX to physically change the EEPROM, they all just change the settings on the GentooX install, so I can run linux on it, but because the eeprom's video settings are somehow "Unknown" running anything BUT GentooX results in a black screen.

Posted: Fri Jun 10, 2005 6:56 am
by orochi
If Gentoox does anything it changes the software video mode, not the EEPROM code, if you want something like that, check out

Posted: Fri Jun 10, 2005 8:34 pm
by Cthulhu32
well see this is the problem, the only thing I can see running on this thing in linux, whenever I try running config magic w/ the necessary bios it doesn't load correctly so either microsoft is giving me an error code I can't see, or the xbox is confused. I was hoping I could fix the eeprom from the bios, since the GentooX Bios loader actually reads from the eeprom and changes it in the Settings menu, its just it won't change from "Unknown" to NTSC-M :(

Posted: Sun Jun 12, 2005 12:07 am
by ShALLaX
1) No discussing illegal software.
2) This seems to have been a design oversight (I didn't code this part).
3) Expect Gentoox Loader v5.10 in a few seconds.
4) I expect feedback on whether this worked!

Posted: Sun Jun 12, 2005 12:28 am
by Cthulhu32
Hey shallax,
yeah sorry, I was trying to stray the discussion away from anything illegal, just wanted to discuss gentoox, and thanks for the bios fix, I'll test this when I get back to my place. I gain more and more respect for your work, maybe when I get into OS coding next year I'll have some input for the project besides bug fixes :)
-thanks again

Posted: Sun Jun 12, 2005 2:23 am
by ShALLaX
No problem... I needed a little motivation to make some changes to Gentoox Loader... this was the kick I needed!

I'm going to release 5.11 in a minute which will have some cosmetic fixes.

Posted: Sun Jun 12, 2005 7:22 am
by Cthulhu32
sweet man, it worked excellent! Got this guy's xbox back up and running, and after I switched over the eeprom the gentoox bios went from looking like pal to looking normal again! So Shallax, most excellent work, you're a life saver man! Plus this bios can help other people w/ the problem I had if anyone screws up their eeproms :)
- Keep up the good work!

Posted: Sun Jun 12, 2005 4:52 pm
by ShALLaX
Excellent! Thanks for testing :)