dmp's extended f-drive patch not working

Post information here about bugs - please remember to provide an accurate and detailed description and, if possible, steps on how to replicate the issue.
Posts: 1
Joined: Sat Dec 18, 2004 6:39 pm

dmp's extended f-drive patch not working

Post by echostorm »

Just ran magic to update the newest kernel in hopes of moving my rootfs to my f-drive (191 gigs or so)... still no dice. Here's my info:

All magic update installed
uname -a: Linux xbox 2.4.22-xbox-Gentoox #1 Sat Dec 18 00:09:18 PST 2004 i686 Celeron (Coppermine) GenuineIntel GNU/Linux

My f-drive will mount, but the files do not show up... instead I see a bunch of files with no names, which is exactly what happened before I updated the kernel to include the latest patch that is supposed to fix this problem.

My df -h shows the following output for part55:
/dev/hda55 121G 16G 105G 14% /mnt/fatx/f

which is incorrect because the size of the partition is greater than 121g as I mentioned earlier.

Just thought I'd let you know as you requested feedback on the front page.
Posts: 7
Joined: Mon Dec 27, 2004 12:59 pm

For me is a problem

Post by xostia »

I have a 300 Gb HD. I had the F drive and G drive in the standard form of xecuter2 bios .67, exactly 4983.67. All worked ok but now, after the patch I can not read the F and the G (formatted using reiserfs) dissapeared (device /dev/hda56 not found).

the df command shows that:

Filesystem Size Used Avail Use% Mounted on
/dev/loop/0 3.0G 2.1G 871M 71% /
df: `/cdrom': No such file or directory
/dev/loop/0 3.0G 2.1G 871M 71% /
/dev/hda50 4.8G 3.2G 1.6G 67% /mnt/fatx/e
/dev/hda55 272G 257G 16G 95% /mnt/fatx/f

ALL THE DISK APPEARS IN F, and I can not mount my home (the G).

I tryed to use the xbpartitioner, writing a partition table on disk using the xecuter2 4877 patched to read this partition on disk (an standard one with F and G) but gentoox does not recognize the partition table and appears empty, no partition table.

Please, anybody can help me to uninstall the patch? I think that all is ok because I have access to F from evox... but I would like to recover my /home.

I need your help. Thanks
Site Admin
Posts: 1973
Joined: Sun Aug 10, 2003 9:25 pm
Location: England

Post by ShALLaX »

This isnt a bug, its a feature... honest! ;)

[20:22] <dmp> it does one very simple thing:
[20:22] <dmp> it looks at the G partition start.
[20:22] <dmp> if it finds a FATX tag, it assumes you have F->LBA28, and G->end of drive.
[20:22] <dmp> if it doesnt find one, it assumes FATX->end of drive.
[20:22] <dmp> that's all folks.
[20:23] <dmp> so, it looks at the G boundary, and finds a reiserfs start tag, which it ignores, as it has to.
[20:23] <dmp> so it says, okay, F->end of drive.

So your garbled F is because the FatX driver is assuming that your F drive takes up the rest of the drive... because it didn’t find a FatX G drive... do you follow? ;)

What you need to do is wrap the partitions inside PHYSICAL disk partitions. I.e. run fdisk and make partitions to the exact same size as your implicit FatX partitions (one for F and one for G). Then you mount /dev/hda1 as fatx (your F drive) and /dev/hda2 as reiserfs (your G drive).
The original Xbox adaptation of Gentoo