Stopping X compiling under Magic

A place to ask all newbie questions and not get flamed, though you will get beaten down if you post a newbieish question outside of these walls.
Post Reply
smarty5927
Newbie
Posts: 9
Joined: Thu Sep 30, 2004 6:03 pm
Location: Huddersfield

Stopping X compiling under Magic

Post by smarty5927 » Mon Oct 25, 2004 6:15 pm

I installed a copy of Pro, edited the USE variable in /etc/make.conf as follows:

Code: Select all

USE="-ipv6 -X -gtk -gnome -kde mmx alsa aalib dvd gpm mpeg oggvorbis perl png -qt quicktime samba sse truetype usb xmms
and then ran Magic, confirmed I didn't want Xfree and pressed GO.

It failed while installing 'modutils' so I 'emerge unmerged modutils' and ran Magic again, this time modutils installed ok and the process carried on.

The next time I looked it was installing all the X11 stuff.

I've had a search around the forums, which is why I edited the USE variable above hoping that would sort it out. I must have forgotton to change a flag or something but I can't find out which one.

Can anyone point me in the right direction ?

I'm only looking to use the machine to run a web server, ftp server and news reader so I don't need any sound or graphical interfaces if that makes any difference.

Thanks

User avatar
ShALLaX
Site Admin
Posts: 1973
Joined: Sun Aug 10, 2003 9:25 pm
Location: England
Contact:

Post by ShALLaX » Wed Oct 27, 2004 3:43 pm

Which stuff DID you tell magic to do?
The original Xbox adaptation of Gentoo

smarty5927
Newbie
Posts: 9
Joined: Thu Sep 30, 2004 6:03 pm
Location: Huddersfield

Post by smarty5927 » Wed Oct 27, 2004 6:50 pm

I just edited the USE variable then typed

Magic

(no parameters)

said No to Xfree, Yes to Sync, and then I let it do its stuff.


I sense from your question that there is more to Magic than I thought, more trawling around the forum for me I think. Although some pointers would be much appreciated. :)

I've learnt more about configuring and installing software on linux since using Gentoox than the last couple of years or so occasional playing around with Mandrake etc. This is not in any way a criticism of Gentoox, quite the opposite actually.

BTW Is there a way in which I can change the default I/P address in the Stardust iso from 192.168.1.13 to something in the 192.168.7.xx range ? This would save me having to go throught the rigmarole of changing the i/p address of a pc rebooting, logging onto the xbox, changing its' i/p address, restoring the i/p address on the pc, rebooting etc.

Thanks

User avatar
ShALLaX
Site Admin
Posts: 1973
Joined: Sun Aug 10, 2003 9:25 pm
Location: England
Contact:

Post by ShALLaX » Wed Oct 27, 2004 9:17 pm

In which patch does it start downloading Xfree stuff?

To change the IP in stardust would require rebuilding the whole CD... and im way too tired to go through that, sorry.
The original Xbox adaptation of Gentoo

smarty5927
Newbie
Posts: 9
Joined: Thu Sep 30, 2004 6:03 pm
Location: Huddersfield

Post by smarty5927 » Fri Oct 29, 2004 6:17 pm

To change the IP in stardust would require rebuilding the whole CD... and im way too tired to go through that, sorry.
Don't be sorry, I think you're doing a pretty damn good job as it is. I didn't really think there would be an easy way to change the ip address, but thought I would ask on the off chance.

I can't remember at what point Magic started compiling the Xfree stuff. If I get chance over the weekend I'll have another go, this time piping the output to a file so I can get a better idea of whats going on. Once I've done that I'll report back.

Cheers

smarty5927
Newbie
Posts: 9
Joined: Thu Sep 30, 2004 6:03 pm
Location: Huddersfield

Post by smarty5927 » Sun Nov 07, 2004 8:41 pm

Ok, Got chance to do a reload over the weekend.

Booted off the Stardust Pro1.4 disc.
Said no to format disc,
selected native install, and let it do its stuff.

Changed the I/P and gateway addresses as per the 'Network' tutorial

typed magic
replied yes to sync and no to xfree

the emerge failed during Displaytools:
!!! Error: the sys-apps/modutils package conflicts with another package.
!!! both can't be installed on the same system together.
!!! Please use 'emerge --pretend' to determine blockers.
did an emerge -C virtual/modutils

and when completed, re ran magic as above.

I logged the output to a file and have extracted the emerge entries:
>>> emerge (1 of 34) media-libs/svgalib-1.9.19-r1 to /
>>> emerge (2 of 34) media-libs/freetype-2.1.5-r1 to /
>>> emerge (3 of 34) x11-misc/ttmkfdir-3.0.9-r2 to /
>>> emerge (4 of 34) x11-base/opengl-update-1.7.2 to /
>>> emerge (5 of 34) x11-base/xorg-x11-6.8.0-r1 to /
>>> emerge (6 of 34) media-libs/aalib-1.4_rc4-r2 to /
>>> emerge (7 of 34) app-arch/rpm2targz-9.0-r2 to /
>>> emerge (8 of 34) sys-apps/utempter-0.5.5.5 to /
>>> emerge (9 of 34) x11-terms/xterm-196 to /
>>> emerge (10 of 34) dev-lang/nasm-0.98.38 to /
>>> emerge (11 of 34) media-libs/audiofile-0.2.6-r1 to /
>>> emerge (12 of 34) media-sound/alsa-headers-1.0.6a to /
>>> emerge (13 of 34) sys-apps/module-init-tools-3.0-r2 to /
>>> emerge (14 of 34) sys-kernel/gentoo-sources-2.4.26-r9 to /
>>> emerge (15 of 34) media-sound/alsa-driver-1.0.6a to /
>>> emerge (16 of 34) media-libs/alsa-lib-1.0.5-r3 to /
>>> emerge (17 of 34) media-libs/libmad-0.15.1b to /
>>> emerge (18 of 34) dev-util/pkgconfig-0.15.0 to /
>>> emerge (19 of 34) dev-libs/glib-2.4.6 to /
>>> emerge (20 of 34) media-libs/libogg-1.1.2 to /
>>> emerge (21 of 34) kde-base/kde-env-3-r3 to /
>>> emerge (22 of 34) media-libs/libvorbis-1.1.0 to /
>>> emerge (23 of 34) media-libs/libid3tag-0.15.1b to /
>>> emerge (24 of 34) media-libs/jpeg-6b-r3 to /
>>> emerge (25 of 34) media-libs/lcms-1.12 to /
>>> emerge (26 of 34) media-libs/libmng-1.0.4 to /
>>> emerge (27 of 34) media-libs/tiff-3.6.1-r2 to /
>>> emerge (28 of 34) net-print/cups-1.1.20-r5 to /
>>> emerge (29 of 34) media-libs/giflib-4.1.0-r3 to /
>>> emerge (30 of 34) media-libs/libungif-4.1.0.1b to /
>>> emerge (31 of 34) x11-libs/qt-3.3.3 to /
>>> emerge (32 of 34) kde-base/arts-1.3.1 to /
>>> emerge (33 of 34) media-libs/libsdl-1.2.7-r2 to /
>>> emerge (34 of 34) sys-libs/lib-compat-1.4 to /
As you can see, X11, KDE, Qt seem to have been installed.

Thanks

User avatar
nobspangle
Gentoox Guru!
Posts: 1681
Joined: Sun Sep 28, 2003 11:59 am
Location: Manchester, UK

Post by nobspangle » Wed Nov 10, 2004 8:58 am

I don't understand what magic is doing here.

Most of these packages are being installed as part of kde-base/arts but I don't know why.
If you keep an open mind, will your brain fall out?

roly
Newbie
Posts: 2
Joined: Sun Nov 14, 2004 6:14 pm

Post by roly » Sun Nov 14, 2004 6:23 pm

/bump
i did exactly the same and it happened to me too - i'm a complete linux noob so any help in stopping x being installed would be appreciated :)

smarty5927
Newbie
Posts: 9
Joined: Thu Sep 30, 2004 6:03 pm
Location: Huddersfield

Post by smarty5927 » Mon Nov 15, 2004 7:31 pm

Looks like we have out-foxed the experts :)

(No offence meant, I would never knowingly make fun of people who help others)


Roly

Did you get the sys-apps/modutils conflict error ?

I just have this niggling feeling in the back of my mine that it might be something to do with the xFree issue.

roly
Newbie
Posts: 2
Joined: Sun Nov 14, 2004 6:14 pm

Post by roly » Mon Nov 15, 2004 10:28 pm

i did get the modutils error - which i fixed by running

Code: Select all

$ emerge -C virtual/modutils 
(from the F.A.Q)

i seem to have solved this problem though by just modifying my USE='blah -blah....' variable in /etc/make.conf - from a standard install of Pro v1.4 i added -arts to it. This seemed to stop magic from compiling any X stuff at all :)[/code]

smarty5927
Newbie
Posts: 9
Joined: Thu Sep 30, 2004 6:03 pm
Location: Huddersfield

Post by smarty5927 » Tue Nov 16, 2004 8:09 pm

from a standard install of Pro v1.4 i added -arts to it.
Ok Roly, I've made a note of that and put it in my USE vairable.

If I need to do a re-install at some point in the future I'll include then as well.

Thanks

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests