emerge problem

A place to ask all newbie questions and not get flamed, though you will get beaten down if you post a newbieish question outside of these walls.
Post Reply
angelburn
Newbie
Posts: 9
Joined: Wed Apr 18, 2007 5:44 am

emerge problem

Post by angelburn » Thu Apr 19, 2007 6:05 am

i have one more question: emerge
its not working or something when i try to download a package it says error the above package contains pacakages which cannot be installed on the same system at the same time? huh.... anything i can do about this?

angelburn
Newbie
Posts: 9
Joined: Wed Apr 18, 2007 5:44 am

Post by angelburn » Thu Apr 19, 2007 6:06 am

sorry i think i posted this twice

angelburn
Newbie
Posts: 9
Joined: Wed Apr 18, 2007 5:44 am

Post by angelburn » Thu Apr 19, 2007 8:00 am

anyways what the problem is is that im trying to install a p2p and im getting an error (from the java files i think ,could be wrong though) and its blocking files and wont let me download anything is there anything i can do about this?

angelburn
Newbie
Posts: 9
Joined: Wed Apr 18, 2007 5:44 am

ok im sorry for dumb questions

Post by angelburn » Fri Apr 20, 2007 3:41 am

ok im relly sorry about the dumb questions im not looking for a spoon fed diagram or anything i kinda figured out what the problem was with emerge there, java was already installed so i unmerged it and then tried again but i now get the message that it has an error still in the new java when it merges it (trying to download limewire) is there any way someone could tell me what im doing wrong here so i can get this going im sure that once i have a clear idea of how to install once app i should be ok....

orochi
Gentoox Guru!
Posts: 606
Joined: Sun Oct 24, 2004 8:11 am

Post by orochi » Fri Apr 20, 2007 8:04 pm

Have a look at

http://www.gentoo.org/doc/en/handbook/h ... #doc_chap4


you will most likely have to

Code: Select all

emerge -C <package name>
to remove the Blocking package to install whatever it is you are having a problem with

paste what it says when your getting the error, but i think you are having some packages blocking others

angelburn
Newbie
Posts: 9
Joined: Wed Apr 18, 2007 5:44 am

Post by angelburn » Fri Apr 20, 2007 11:05 pm

ok i think i fixed the blocked package problem but i get this when i do emerge limewire (even when trying to do emerge world)

>>> cfg-update-1.8.0-r6: No new packages have been
emerged, checksum index OK!
Calculating dependencies... done!

>>> Emerging (1 of 18) dev-java/ant-core-1.6.5-r14 to
/
* apache-ant-1.6.5-src.tar.bz2 RMD160 ;-) ...
[ ok ]
* apache-ant-1.6.5-src.tar.bz2 SHA1 ;-) ...
[ ok ]
* apache-ant-1.6.5-src.tar.bz2 SHA256 ;-) ...
[ ok ]
* apache-ant-1.6.5-src.tar.bz2 size ;-) ...
[ ok ]
* checking ebuild checksums ;-) ...
[ ok ]
* checking auxfile checksums ;-) ...
[ ok ]
* checking miscfile checksums ;-) ...
[ ok ]
* checking apache-ant-1.6.5-src.tar.bz2 ;-) ...
[ ok ]
Traceback (most recent call last):
File "/usr/bin/depend-java-query", line 85, in ?
(options, args) = parser.parse_args()
File "/usr/lib/python2.4/optparse.py", line 1275, in
parse_args
stop = self._process_args(largs, rargs, values)
File "/usr/lib/python2.4/optparse.py", line 1315, in
_process_args
self._process_long_opt(rargs, values)
File "/usr/lib/python2.4/optparse.py", line 1390, in
_process_long_opt
option.process(opt, value, values, self)
File "/usr/lib/python2.4/optparse.py", line 707, in
process
return self.take_action(
File "/usr/lib/python2.4/optparse.py", line 726, in
take_action
self.callback(self, opt, value, parser, *args,
**kwargs)
File "/usr/bin/depend-java-query", line 49, in
get_vm
vm = verman.get_vm(value)
File
"/usr/share/java-config-2/pym/java_config/VersionManager.py",
line 151, in get_vm
raise Exception("Couldn't find suitable VM.
Possible invalid dependency string.")
Exception: Couldn't find suitable VM. Possible invalid
dependency string.
* Unable to determine VM for building from
dependencies:
NV_DEPEND: source? ( app-arch/zip )
>=virtual/jdk-1.4
!<dev-java/ant-tasks-1.6.5
!dev-java/ant-optional
>=dev-java/java-config-2.0.31
>=sys-apps/portage-2.1_pre1
>=dev-java/javatoolkit-0.2.0-r1
>=sys-apps/portage-2.1_pre1
VNEED:

!!! ERROR: dev-java/ant-core-1.6.5-r14 failed.
Call stack:
ebuild.sh, line 1630: Called dyn_setup
ebuild.sh, line 701: Called qa_call
'pre_pkg_setup'
ebuild.sh, line 38: Called pre_pkg_setup
java-pkg-2.eclass, line 101: Called
java-pkg-2_pkg_setup
java-pkg-2.eclass, line 55: Called java-pkg_init
java-utils-2.eclass, line 1852: Called
java-pkg_switch-vm
java-utils-2.eclass, line 2240: Called die

!!! Failed to determine VM for building.
!!! If you need support, post the topmost build error,
and the call stack if relevant.
!!! A complete build log is located at
'/var/tmp/portage/dev-java/ant-core-1.6.5-r14/temp/build.log'.

!!! When you file a bug report, please include the
following information:
GENTOO_VM= CLASSPATH="." JAVA_HOME=""
JAVACFLAGS="" COMPILER=""
and of course, the output of emerge --info

Fede93
Newbie
Posts: 6
Joined: Thu Aug 30, 2007 2:49 pm

Post by Fede93 » Fri Aug 31, 2007 5:11 pm

orochi wrote:
you will most likely have to

Code: Select all

emerge -C <package name>
to remove the Blocking package to install whatever it is you are having a problem with
so, wat do i haveto put instead of pakage name? the name of the package i want to install? or, the blocking package?

orochi
Gentoox Guru!
Posts: 606
Joined: Sun Oct 24, 2004 8:11 am

Post by orochi » Mon Sep 03, 2007 11:50 pm

the blocking package; if you type


emerge -pv <package to install>


you should see a "B" next to the blocking package on the list of packages to install

User avatar
clpalmer
Power user
Posts: 288
Joined: Sat Jan 29, 2005 6:38 pm

Post by clpalmer » Tue Sep 04, 2007 3:23 pm

ok i think i fixed the blocked package problem
What did you do to fix it? Did you remove a package that might have been required?

It looks like you're trying to build apache2-ant, but it requires java and you don't have any java environment installed. Google the requirements for the ant-core package you're emerging and see what else you need to get first.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest