Page 1 of 1

May have put my xbox beyond repair....

Posted: Mon Sep 05, 2005 10:46 pm
by mibot
I'm not sure whether this post is more appropriate in this forum or something like xbox-scene. After deliberating, I have decided to start here. The problem started after my gentoox experiments and I think questions about the boot process may help me.

I have recently modded my xbox with an Xecuter (soldered 2.6 on a 1.1...I think!).

My interest is not in cloning games, the Xbox was a work gift as was the chip. My kids play the games far more than I do but are too young to be interested in "warez" etc. I really wanted a decent browser and email on the telly, media centre seemed a bonus and it was a chance for a jaded MC$E to have a play with installing linux for the first time.

After a little reading, I used OzX to flash it with EvoX. Next step was I installed Xebian. I had everything working: Browsing, freevo,I'd made some evox skins. I even played about with SSH while waiting for my usb cable and looked at the config. I've VERY limited experience of using UNIX and everything seemed familiar.

I was getting confident and thought I'd give Gentoox a shot as I liked the look of KDE....too confident sadly. Next steps were as follows:
I attempted to install with stardust and the xbox booted straight into xebian. I then flashed the bios with the loader but it still loaded xebian even though the disk was in. It carried on even when I removed the debian folder on the E: drive. It also only gave the option "Native".
Every time it indicated that it was loading /boot/vmlinuz. I puttyed (SSH) in the next time xebian loaded and deleted it. I now realise I have deleted the kernel. Now, of course, I can see many of the errors I have made...especially since reading the instructions I should have read before...doh!
I can no longer connect and have no idea what to do next, short of buying another pre-flashed chip and starting again. All I get now is the blue loader screen with three red plings in place of the green OK after ...vmlinuz that I was getting before.

Sorry for the long winded post but it should save a few questions if there is anybody out there that can help.

All and any help is much appreciated.

Posted: Tue Sep 06, 2005 1:56 am
by ShALLaX
You dont see a CD/DVD icon in Gentoox loader (far left)?

Re: May have put my xbox beyond repair....

Posted: Tue Sep 06, 2005 2:54 am
by Krazy
mibot wrote:The problem started after my gentoox experiments and I think questions about the boot process may help me.
Hmm... you've done well, haven't you :wink:

Don't need to send it back for repair, you should be able to get out of your situation with a little help...

Ok the booting process is started by executing "Loader.bios" (flashed in your mod-chip), or via executing "gentooxx.xbe", which is an unsigned xbox executable version of Loader.bios. The later is useful for starting Gentoox via a dashboard etc

When the bios/xbe loads it looks for a file 'linuxboot.cfg' in certain places on E. This file instructs the loader where to find the kernel, what parameters to feed it, whether to use an initrd (initial ram disk) etc.

Now xbox-linux and gentoox have different kernels, and install in different places. Gentoox also has fatx and native versions; can't speak for xbox-linux variants as I haven't used them.

For Native installs, bootloader check order is: /boot/linuxboot.cfg, then /linuxboot.cfg
For Fatx installs: /linuxboot.cfg, then /debian/linuxboot.cfg

I'm guessing that you haven't totally cleaned up from your xebian install, so that's causing you grief, with the bootloader getting confused, as the contents of 'linuxboot.cfg' will be different for each distribution. Running the gentoox installer detects a previous install(?) so only offers you a native install option?? [on F drive, BTW]

My suggestion would be to remove all traces of linux from you hard-disk, and then start again.

Clean out any of the following (if present):

- E:\boot\* [remove directory too]
- E:\debian\* [remove directory too]

Gentoox files [if present]
- E:\linuxboot.cfg
- E:\rootfs
- E:\vmlinux
- E:\initrd.gz
- E:\sprkrd.gz
- E:\swap

Option 1:

I'd suggest doing this via FTP, via evox dashboard.

Alternatively, you could attempt to do this via 'live config' dashboard (xecuter x3 has this, not sure about x2), but...
I've found X3 bios ftp server to be a big pile of steaming ...., well you get the idea!! You can't seem to transfer in binary mode, but it may let you delete files correctly?!?

Option 2: (probably quicker if you don't have a third party dash handy)

Create Gentoox "Resctoox" rescue CD [Download and burn to CD]. Boot from this (need to select the CD icon from the menu using the xpad before it auto-selects the default), control-c at prompt, then remove assorted files (see above)

Now, start again with your gentoox install.

Hope this helps :)

Great.....thank you :)

Posted: Tue Sep 06, 2005 8:22 am
by mibot
Shallax - I'm honoured the organ grinder in chief could pop in for this one ;) ....The native option is all that is available. It all happened so fast!

The first time I used the loader, there seemed to be 3 icons on screen: DVD, Native and (from memory) something that looked like a joystick. I moved both sticks and the pad, pressed x, b, hell I pressed everything (picture me bashing 2 joypads shouting "change, change") but nothing moved and the other icons remained grayed out. It would boot straight into xebian in about 5 seconds. I still can't change the selection though the icons are now DVD, Native and Tux next to a PCI card (network?...I could have imagined the earlier joystick icon btw.)

On re-reading this, I realise there is always the possibility that the sparkle image I burned is corrupt. I'll try again....if you have an idea as to why I can't select anything, let me know. If you think it could be bug, tell me how I can help with debugging and I gladly far I've only deleted vmlinuz from the Xebian install so if there are any logfiles created by the boot process, they should still be there. If I fix this beast, I'll send anything across you need :lol:

Krazy - Ha ha...yeah you could say that! Well...I always say "best way to learn is to dive straight in"....I'm sure I'll understand gentoox/linux a lot better in the end than someone who had a faultless installation!
Thank you for your very full response which has helped me to understand a lot.
One thing I messed up was trying to put more than one bios on the chip. I will need to read up a few Xecuter posts to be sure. I thought I had loaded Evox onto bank 1 so I flipped the flash protect switch and the bank select switch and loaded the gentoox bios. Now Gentoox is all that is available, regardless of switch position. This means I can't ftp in any more.

From what you have told me, the problem looks to be as follows:
  • Loader starts up in bios
  • It searches for linuxboot.cfg and finds the old xebian installation.
  • It tries to load the missing kernel
The root of all this seems to be the inability to change boot selection. One possibility is the use of non-microsoft controllers. Anybody else here that lets a three year old near their xbox will understand why...we get through them! The one I am using is made by MadKatz and was recognised as a controller by Xebian. I would have thought this meant it would work with Gentoox but I am going to plug an old ms one with a broken left joystick to see if I can get any thing. One brand we have only worked with Evox and games but wasn't recognised by Xebian.

In conclusion, it would seem that until I can change the boot selection, I'm stuffed. A rescue disk wouldn't load at the moment.

I'll keep you posted....thanks again both of you.


Posted: Tue Sep 06, 2005 9:05 am
by mibot
Sometimes you talk it over with people and read your own post and the answer is staring you in the face. The gentoox loader does not support non ms controllers (not mine anyway). I couldn't find the old original but I do have the dvd ir kit and this does the trick.....I have also now discovered the advanced icon submenu and can now reflash with Evox, ftp in and delete the old xebian installation, as well as all the other wonderful things I can do to stuff it up good and proper :lol:

Are there any nonM$ brands that have been tested? Also, is there a list compiled anywhere of compatible controllers? If not, where should I start one?


Posted: Tue Sep 06, 2005 4:12 pm
by ShALLaX
Plug only one controller into your Xbox and see if you can move the icon. If not, try borrowing a friends controller. If that doesnt work, try plugging in a keyboard (using a USB->Gameport adaptor) then use the arrow keys. If that doesnt work try using an Xbox remote control. If that doesnt work then it may be time to get a modchip so you can flash a new BIOS.

I suspect the problem is that you're using an unsupported Xbox controller (the latest S-controller has a new manufacturer ID ... no idea why).

Posted: Sun Sep 11, 2005 3:25 am
by Krazy
mibot wrote:The gentoox loader does not support non ms controllers (not mine anyway).
Hmm... I notice that xpad.c which defines Vendor IDs (VID) and product IDs (PID) for usb devices has been updated in the cromwell repository(*) since GentooX Loader 5.11 was released.
[*this is the base source for gentoox loader bios/xbe]

So your controller may be supported in the future(#), but to guarantee that you'd have to figure out your controller's details (VID, PID) and ensure the repository is updated.

(#) you could help yourself by rebuilding the gentoox loader for yourself, if you're so inclined :wink:

Posted: Sun Sep 11, 2005 7:20 pm
by mibot
Krazy - Thanks for the tips. I've got my head around it now and am set up exactly as I want to be incl. USB keyboard & mouse. The IR controller from the DVD kit suits my needs well and is enough to get media centre working, which is the main thing. Interestingly, all controllers work with Gentoox itsef so it could be something to do with the version of Cromwell being used. What do I know? :lol:

As for the inclination to tinker with code: I'm a techie and can just about read code but am too ill disciplined to have ever learnt to compile any apart from basic html etc.
I'm lazy and rely on your good selves to create what I, as an end user, am looking for. In that capacity, I'd like to say I'm very happy with Gentoox.
xbox-linux. org seem to push Xebian and I tried that first but, though the difference is slight, I prefer Gentoox for usability.

To anyone considering Gentoox: If you want a PC, buy one. I'm not looking for a full desktop PC as I'm sure everyone would agree that any machine with 64mb of RAM that is very awkward to upgrade is a poor substitute for a PC, even one of equivalent value.
If you want your games console with restricted region DVD to play/show any media format you have on any PC in your home, if you want to check your mail without going too far from the sofa and TV and if you want to play all the games that you used to play in an arcade/on an atari when you were a kid (which turned you into the sort of person that doesn't like leaving sofas now) then:

Gentoox is the dogs bolloox! :D

P.S. Wishlist:
Sharper text display (or an HDTV from Santa)
A legal bios that serves FTP...not sure if that is an oxymoron

Posted: Mon Sep 12, 2005 1:27 am
by Krazy
mibot wrote:I've got my head around it now and am set up exactly as I want to be...
Excellent! Another happy gentoox user :)
mibot wrote:A legal bios that serves FTP
Well cromwell/gentoox_loader is legal, but doesn't support FTP access - so we are 1/2 way there. I'm guessing cromwell developers would frown on adding FTP access, for space, time, or other (ethical?) reasons.
mibot wrote:[Xbox] very awkward to upgrade is a poor substitute for a PC, even one of equivalent value.
As a desktop replacement they are undoubtedly underpowered. However as a server for personal use, they are great.
Just remember, every Xbox you buy costs Microsoft money :P
Just avoid changing the balance in their favour by not buying games :!:

Oh, and one final thing... and no, its not a dig at you specifically, but IMHO we would be all better off if each poster replies back to their topic saying that they have figured things out, fixed issues, etc. Then other people reading their topics would know the solution proposed works etc

Cheers :D

in the forum spirit:

Posted: Mon Sep 12, 2005 9:11 am
by mibot
Good point Krazy....a brief synopsis of "what worked for me" follows...this won't include time spent on resoldering messy joints and reading instructions after things go wrong (perhaps it should be "what would have worked for me") . The only real problem addressed in this thread is the use of unsupported controllers:

I have a version 1.1 xbox....I began by installing a mod chip and flashing with EvolutionX (or evox). Evox is an illegal bios that was built using code illegally obtained from Microhardasnails (Mods...I am unaware of forum etiquette here so please delete Evox refs if inappropriate).
The only reason I like it is that it comes with a built in FTP server. As stated in earlier posts, I'm not up to much more than changing a few values in a file; I find dragging files off into my existing text editor and then replacing them easier than SSH and a command prompt. You can also easily delete failed installations or corrupted files.
I downloaded Gentoox Home v4.0 following the links in this forum. The trick is, basically, to follow the instructions to the letter....very concise and even come with a useful video.

Next was Media Centre and, again, just install as directed.

Internet: I tried plugging a usb wireless card (netgear wg121) in through a usb adapter (commonly bought on ebay for £5/$10) but after a bit of reading suspected that this would probably involve a driver installation that, at the moment, is beyond my capabilities. It didn't "plug and pray" as hoped so I swapped it with a wireless router and connected that to the ethernet card on the xbox. You'll need a crossover cable to do this but if you already own a router, you'll probably have one and know what one is. If not, ask away...setting up a network is a little off topic. I used internet connection sharing on a windows machine with a broadband connection and the xbox (using DHCP) did the rest.

Lessons learned throughout the whole modding process:

Use decent quality solder and flux...that old coil of lead that you've been using to solder guitar leads with since the 80s won't work and your xbox will FRAG (Flashing Red And Green eject button....indicates bios failure) almost every other boot.

As with everything, read the instructions carefully. The people who have written them have gone to every possible effort to ensure that every shortcut is in won't discover any new ones and, even if you have been doing PC installations regularly since DOS, you'll not understand everything involved without reading.

Finally, if most of what you are reading sounds like a different language and/or you don't want/need to know what is going on inside your xbox as long as it plays divx and mp3 and browses the internet: Pay someone to do it, whether that is in cash through a commercial site or in chocolate to someone in the community (such a scheme really does exist :) ).
It will be far quicker and far less trouble but I suspect those kind of people won't be reading this and will probably ask a mate (you or I) to do it for them :lol:
I'd also like to add my voice to the many giving praise to the linux community who seem to work far more efficiently than any software houses, even though they have a fraction of the money the big companies pay their janitors. I'm particularly impressed in light of the fact that many of the project coordinators have to mentor the inexperienced and the incapable (though well intentioned) contributions in a way they'd never have to in a coroporate environment (....then again?!?)

All the best fellow's to these geniuses finding a way around the 360 in the near future and a nifty method of turning my PAL TV into a 28" ultra sharp monitor!