Page 1 of 1

Cromwell bios will not load

Posted: Tue Jul 22, 2008 4:06 am
by bdejong11129
OK, I got to the point where i need to use raincoat to load the new bios in and every time I try to flash the bios it reports "File is too large for available space" it WILL flash the original I created before trying to load the new bios. I am assuming that I have the proper pads shorted since it would read the old bios and re-program it in.

I have tried all the versions on the wiki 2.3 and 2.4 as well as loader.bin and others included in resctoox and the home package.

What does this error mean? I am using the 256k version of the file since I have a 1.3 version xbox.

Re: Cromwell bios will not load

Posted: Tue Jul 22, 2008 4:07 pm
by clpalmer
The size of the original bios file and the new file you're trying to load are the same, I assume? If so, then I'm not sure. I've never seen that problem before and I've used 1MB and 256k bios chips and raincoat does a good job of detecting what the size is and flashing it multiple times if needed...

Re: Cromwell bios will not load

Posted: Tue Jul 22, 2008 4:49 pm
by bdejong11129
It was very strange to me as well.

I ran raincoat with -r to dump my existing bio and it reported success. I ran raincoat with -p to program it back in and I got all three status's of Erasing with the little stars and Writing and verifying(?), no error messages at all, and everything still works after re-booting the box.

But, If I attempt with any of the Cromwell bios or any of the ones included with the disto's I get the same "File is too large for available space" error message. Now I am assuming that if I got the shorting of the write enable lines wrong I would get an error back when I attempted to program back my original bios file.

This is killing me, I want to install this as native with a front end, I am no where near capable enough with linux to run it as a command line install.

Now what does happen is that raincoat reports the size of the Cromwell bias file in bytes as being larger than the size in bytes of my original bios dump. I cant remember the exact number but they were not the same.

Re: Cromwell bios will not load

Posted: Tue Jul 22, 2008 11:50 pm
by bdejong11129
Go figure, retied tonight with similar results.

Changed to the Dust directory and attempted to program the bios Loader.bin and it worked. I dont know why, but it did, all is well I get a very fast boot right into the linux bios. I am setting it all up now using the Native tut.