Page 1 of 3

strange connection problems

Posted: Wed Feb 21, 2007 3:25 pm
by pugsx
Hi just recently installed latest version of home and cant get the network working i followed the guide on the main site and that didn't help i've reinstalled that didn't help

this is the problem

I have complete network access (ssh,webmin,vnc) but i cant get emerge sync, magic or internet apps to connect (firefox just says contacted waiting for reply and i can ping from terminal with no packets lost

my set up
router -
pc -
xbox -

subnet mask -
gateway -
dns -
dns -

any ideas?

Posted: Wed Feb 21, 2007 7:23 pm
by Timmo
Sounds like your dns is broken. Try changing your dns server to that of you router in /etc/resolv.conf

Posted: Wed Feb 21, 2007 8:32 pm
by pugsx
i tried that already still the same result

Posted: Wed Feb 21, 2007 10:12 pm
by ShALLaX
Sounds like you're on NTL?

Your setup looks right. Open /etc/resolv.conf and make sure it contains the following:


If it already contains that, change it to:


Sorry if you've already tried this... you said you'd played around with DNS, but gave no details ;)

Posted: Wed Feb 21, 2007 10:41 pm
by pugsx
i'll try that when i get back from work 2moz thanks

do you think it would be caused by

a) a missing file some where?


b) following the sticky for a fully native install but using home and not pro?

Posted: Wed Feb 21, 2007 10:53 pm
by ShALLaX
Its just a very small network config glitch that you have. Are you sure those are YOUR DNS servers... and not just mine? ;)

Posted: Thu Feb 22, 2007 8:06 am
by pugsx
ok just had a quick mess before work and still no go

tried changing resolv.conf to


no change

checked my net file and saw broadcast was so tried changing it to still no difference

and still no idea what the prob is

Dont know if this helps but here is the output from route

Code: Select all

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface     *        U     0      0        0 eth0
loopback        *            U     0      0        0 lo
default         UG    0      0        0 eth0

Posted: Thu Feb 22, 2007 5:46 pm
by Timmo
Just to make sure are you executing the following lines after changing the resolv.conf file to update the current setup of your network?

sudo /etc/init.d/net.eth0 restart

Posted: Thu Feb 22, 2007 6:38 pm
by pugsx
i have used a command like that cant be sure will check if its same when i get it setup


near same just without the sudo.

Think im just gonna format and do a basic native install from the disk no chance of messing up while copying files over, will that use all of the f drive or just the normal 4gb?

LOL fresh install did it straight from disk and still same result i'm beginning to think its my router

Same problem.

Posted: Sun Feb 25, 2007 6:14 am
by Nightwing
Hey Everyone, first post, w00t!

Sorry to hijack the thread, but I am having the same identical problem as well. I installed GentooX just the other night for the first time, via the FTPing of distro.rar's contents to the root of E:\ and had no problem getting to KDE, and since re-did it all to use XFCE again since. Either instance didn't fix the problem for me, but essentially I can't seem to resolve the DNS either.

I have tried searching on the forums already. Have double checked and tried a few different settings in both /etc/conf.d/net and /etc/resolv.conf.

Router is a LinkSys WRT54GP2 VoIP model.

All Pings too and from the Xbox are 100% successful. Firefox on the Xbox can even log into the router's html based config pages.

/etc/conf.d/net =
config_eth0=( "dhcp" )
#config_eth0=( " netmask broadcast" )
[[[[Have attempted un-commenting the specified IP and commented dhcp, no change either way]]]]
fallback_eth0=( " netmask broadcast" )
fallback_route_eth0=( "default via" )

and /etc/resolv.conf =
# Generated by dhcpcd for interface eth0

[[[[Yes I have tried removing the shown 3 name servers and placed just the router's IP there, as well as adding the router's first in order with the shown other 3 nameservers. Yes all IP's are correct. Yes Nameserver 3 is the same as nameserver 1.]]]]

And I had not tried the sudo /etc/conf.d/net.eth0 restart command before hand but have since just discovering this particular thread. before hand I would SSH with PuTTy which is what I use to edit the conf files, sudo ifconfig eth0 down, then before executing, pre-type it in over VNC on terminal window in xfce, get ready with focus for xvkbd, so all I had to do was hit A while hovering over Enter with the Xpad to run sudo ifconfig eth0 up.

Defenitley liking the net.eth0 restart command better though, LOL.

Any suggestions as to what else to try?

If it is a problem with the router as last suggested, any guesses as to what the problem might be exactly? I've ran most flavours of Linux on my other machines with no DHCP problems and both Linux and Windows alike can get the DNS IP's and such from the sure what else to try other then maybe adding the Xbox to the router's DMZ.

My Router itself is set to obtain the IP settings automatically from my cable modem/ISP, so not too sure where else the problem could be.. If I find a solution meanwhile I'll post back. Thanks, and so sorry for the long/detailed post, repeated info I realize, but I've on the other hand have always been one for details. That and you never know when one finds something they didn't already know even after reading it the first 500 times around in a thread. lol.


Posted: Sun Feb 25, 2007 1:04 pm
by ShALLaX
Run "route" as root and paste the results here.

Don't ever be sorry for a long post, you've given plenty of information which is ALWAYS useful for debugging. It's far better to make a long post than to just say "HELP MY NETWERKZ ISNT WORKINGZ!!!"

Posted: Sun Feb 25, 2007 10:30 pm
by Nightwing
gentoox@Xbox ~ $ sudo route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface * U 0 0 0 eth0
loopback * U 0 0 0 lo
default UG 0 0 0 eth0

Thanks for tollerating the long post and words of encouragement regarding so. There's route's output for you. I've attempted two other idea's so far to eliminate possible problems. One was turning off DHCP and the NIC altogether in UnleashX V0.39 so that the IP would be not already in use prior to a power cycle and booting up of GentooX, no change there. And the second thing I did was rip my hair out for a half-hour while looking for a binary of LinksBoks for Xbox to see if the Xbox could even just get to google through UnleashX, and I'm happy to say it suceeded. Thus indicating that the problem is client side and not router based I would presume.

I was gonna try setting up ICS from XP on the machine I've mostly been ssh/vncing from to the Xbox, but I guess possibly due to VMware being installed, ICS only wants to let me share to the Vmware LAN connections, and not an 'in-general share to the lan itself' type ICS so... so much for that idea. Have yet to try enabling ICS on other machines.

I thought about adding USB1.1 ports to the Xbox itself and testing out a 802.11B/G USB dongle I have, a D-Link DWL-G122 RevC1, but I'm not in a hurry to hack up and splice controller cords or even USB cords to sodder to the motherboard just yet.

Are there any currently known live-cd based Linux/BSD distro's for Xbox at present to see if any other distro has this networking problem? I'm really enjoying GentooX thus far and prefer to stay with it yes even if they made a fully supported Ubuntu port, lol, consider that high praise.

Only other thing semi-worth mentioning is that I checked out XCHAT, GAIM and XFCE's native web browser [forget the name and it dosn't want to open right now; go figure] just to verify they were failing to get online access as well.

Let me know if any other output's are required. I'll be late in reply's today for a few hours once it is 3:30PM PST as it's my Daughter's 1 year old birthday today. How 365 days can fly so fast from the night they are born 'eh?

Thanks again!



Posted: Mon Feb 26, 2007 8:58 am
by Nightwing
Router WAS the problem. I re-wired my network so instead of going from cable modem to wireless voip router [branches to voip/phoneline] then to a gigabit switch which all machines xbox included where connected via. I changed it to as following:

1) Gateway/Cable Modem
2) LinkSys BEFSR41 4-port + WAN/Uplink broadband router [known to be good]
3a) Branch out to wireless Voip to supply internet to laptop [802.11g] and to Vonage/VoIP
3b) Also branch from LinkSys BEFSR41 to the Gigabyte switch.
4) Switch to all machines.

I suggest anyone having this problem who has looked through out the forum to double check all settings in there router's configuration pages, any problems that seem not related such as drop packets could very well be quite related. In my instance, I was doing great to be able to download 150megs of a 700meg file WITH it then stalling guarenteed. That applied to all machines on my network. Note this problem didn't start till I purchased the gigabyte router and wired the wireless router to take the former place of the known good router, and the gigabyte replaced the wireless in regards to how things were previously all wiered up.

In short, everything is ALL good, thus far, and I still highly recommend GentooX to anyone not yet using it on there Xbox! :)

Posted: Mon Feb 26, 2007 7:11 pm
by ShALLaX
Yay! Glad you got it sorted out :)


Posted: Tue Feb 27, 2007 9:46 pm
by Nightwing
Well... I DID have it How I had it wired actually disabled my VoIP Router from being able to work properly, ie I could recieve calls but not place calls even to voice mail services. After many various attempts I determined it was a wiring issue. No matter how I tried to wire it, I could only get either just VoIP to work, or else no VoIP and Internet works and Xbox can get on. For some reason the only way that permits it to be able to have both working at the same time also prohibits the Xbox from getting online, same problem, can still ping google and the what not from Xbox and can ping the Xbox from the rest of the LAN. The VoIP LinkSys router is a WRT54GP2 ver 1.0. I tried resetting the router back to factory defaults, no change. LinksBoks can get online though...Strange that GentooX can't... Can anyone explain this with a theory at all? The UnleashX yes, Gentoo no, part?