FTP files from gentoox to PC

Ask questions regarding Gentoox, Gentoo and Linux in general in these forums and we'll do our best to help you!
Post Reply
Posts: 25
Joined: Tue Jan 09, 2007 11:33 pm

FTP files from gentoox to PC

Post by ManReal » Tue Jan 09, 2007 11:40 pm

I've already installed Gentoox on my Xbox. The problem that I'm having is that I'm not able to access my xbox via ftp anymore .

When I first got gentoox installed I created a user acount with 'useradd' and 'passwd' and then I was able to login to ftp via that username and password (because logging in as root wouldn't work). So I was able to transfer file to gentoox with flash fxp on my PC.

Now I did something to my xbox (I believe it happened when I installed apache) and I can't get into ftp. I can however, log in to my xbox using (ssh) or secure shell (like telnet I guess).

So I tried...

unmerging apache on gentoox and merging again. it so happens that the ftp still doesn't work. Any ideas why I can't get this bloody ftp to work?

What do you guys need to see to help me out with this madness?

any help would be really appreciated.

Posts: 25
Joined: Tue Jan 09, 2007 11:33 pm

Post by ManReal » Wed Jan 10, 2007 1:43 am

For the record I'm using a static IP, ( I've also searched the forums and didn't find any useful solutions, except to "check you '/etc/hosts' file. So here it is:
# /etc/hosts: This file describes a number of hostname-to-address
# mappings for the TCP/IP subsystem. It is mostly
# used at boot time, when no name servers are running.
# On small systems, this file can be used instead of a
# "named" name server. Just add the names, addresses
# and any aliases to this file...
# $Header: /home/cvsroot/gentoo-src/rc-scripts/etc/hosts,v 1.7 2002/11/18 19:39:22 azarah Exp $
# localhost testing.org crow Xbox

User avatar
Posts: 44
Joined: Sun Nov 09, 2003 9:35 am
Location: Midlands UK

Post by Timmo » Sat Jan 13, 2007 7:49 pm

Just a couple of ideas for you to look into!

Firstly in gentoox open up a terminal window and check your gentoox's networking by using the command ifconfig, check the ip address etc

restart the ftp server to make sure it is running fine

Code: Select all

sudo /etc/init.d/proftpd stop
sudo /etc/init.d/proftpd start
Now login to your webmin interface and check the users for the ftp server

also try logging in through a command prompt on your PC to see if it gets as far as asking for authentication

Code: Select all

ftp xbox_ip
I wrote this!

User avatar
Posts: 32
Joined: Sat Jul 24, 2004 1:31 pm

Post by R0Bzombie » Wed Mar 07, 2007 3:44 pm

Why you're not using samba to transfer your files ?
You can map the drives with this, would be easier.
My linux only Xbox:
160gig hdd
128mb Ram

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest