Page 11 of 13

Posted: Mon Mar 05, 2007 9:41 pm
by ShALLaX
I wasn't aware that would limit the size, heh. I guess thats not acceptable then.

I've spent a couple of hours debugging the reiserfs driver. It can mount the partition find, it just doesn't seem to be able to find the file :/ I guess thats my next weekend gone then :/

Posted: Mon Mar 05, 2007 10:15 pm
by cheesyboofs
I wouldn't spend too long on it. If a re-partition and re-format is the answer then so be it. It's just good to finally know why 6.x wouldn't boot, and now we know.
I think a small ext2 boot partition is a more professional approach anyway. If you've given it a look into and you can see no way to go to 6.x without a reformat then that's just what we'll have to do.
Cheers for having a look in to it.

Posted: Tue Mar 06, 2007 4:57 pm
by Ianh
I'd put money on shALLaX's curiosity getting the better of him at the weekend !!!

Posted: Tue Mar 06, 2007 8:52 pm
by ShALLaX
Curiosity/ boredom/ loneliness :(

Posted: Thu Mar 08, 2007 5:20 pm
by Ianh
Curiosity, I hope

Got 6.05 to work using ext3 /boot

Posted: Wed Mar 14, 2007 5:57 am
by BlkLotus
Ok I followed the tut but made the small changes needed to have an ext3 boot partition and it's up and running with native as the boot option in the 6.05 loader :D. I created the 20mb partition and copied the linuxboot.cfg and vmlinuz to it then just substitued the right partition number where needed, put in the extra fstab entry and it works great. Now I'm off to setup the AMP part of LAMP and SAMBA.

For those interested here's the various configs for my system


title Gentoox
kernel vmlinuz
initrd no
append init=/linuxrc root=/dev/hda3 kbd-reset video=xbox:640x480,nohwcursor,hoc=13,voc=13 dontdeleteme


# /etc/fstab: static file system information.
# <file system> <mount point> <type> <options> <dump> <pass>
/dev/hda2 none swap sw 0 0
/dev/hda3 / reiserfs notail 0 1
/dev/hda1 /boot ext3 defaults 0 1
proc /proc proc defaults 0 0

fdisk partition table
Disk /dev/hda: 8004 MB, 8004132864 bytes
16 heads, 63 sectors/track, 15509 cylinders
Units = cylinders of 1008 * 512 = 516096 bytes

Device Boot Start End Blocks Id System
/dev/hda1 * 1 40 20128+ 83 Linux
/dev/hda2 41 537 250488 82 Linux swap / Solaris
/dev/hda3 538 15509 7545888 83 Linux

mount output
/dev/hda3 on / type reiserfs (rw,notail)
none on /dev type devfs (rw)
proc on /proc type proc (rw)
/dev/hda1 on /boot type ext3 (rw)
usbfs on /proc/bus/usb type usbfs (rw,noexec,nosuid,devmode=0664,devgid=85)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)

Posted: Wed Mar 14, 2007 8:02 pm
by ShALLaX
I don't think I'm going to try fixing the ReiserFS issue. Its a fairly poor choice for a filesystem anyway.

If you want native support, you'll have to go with Ext3.

Posted: Wed May 09, 2007 6:43 pm
by blighty
Decided to run the latest gentoox
( 6.2? ) on my latest xbox using
this thread as a base.

after i've ftp'd into the xbox & uploaded rootfs I run the next
line of the tut ( bit where you
wait for ages ) & eventually It
throws a screen full of errors,

(sorry, I never wrote it all down,
there was reems of it both times
I try'd )

& when I get to the bit where
you reboot the xbox, I get tons
of errors & one saying something
about a kernal bug?

Has anyone got the new gentoox
up & running as a native install?

I downloaded it twice now, unpacked
it all twice & run the instal
twice getting exactly the same
results both times.

I can try & get the errors for
you somehow if anyone wants to
see them ( might have to
photo it though )

BTW I'm trying to install on a
stock 10gb hdd.

( does ext3 give less usable space
than reiserfs? )


Posted: Wed May 09, 2007 7:46 pm
by ShALLaX
Please, for my sanity, don't insert your own line-breaks! You'll have to describe _exactly_ what part of the HOWTO fails and exactly how it fails. Also please say exactly where you FTP'ed the files to.

Posted: Thu May 10, 2007 11:17 am
by blighty
ShALLaX wrote:Please, for my sanity, don't insert your own line-breaks! You'll have to describe _exactly_ what part of the HOWTO fails and exactly how it fails. Also please say exactly where you FTP'ed the files to.
sorry, have been using linksboks & It gets hard to see what your writing
if I don`t add the line breaks,

Was wondering if anyone else had the same problem, that`s why I posted it here & not in the bugs forum.

Will have another go at it later this evening & post the errors I get,

I ftp`d the rootfs file to where ever this tutorial tells you too ( off the top of my head, I really can`t remember exactly where )

Talk to you later, Cheers ShALLaX.


Posted: Tue May 15, 2007 5:05 pm
by chrisb
@ cheesyboofs
Any peogress on updating the tut??
I have a 500GB disk I want to get startet on.. :) (My 40GB died)
Hope to hear from you soon..

Posted: Thu May 17, 2007 9:30 am
by cheesyboofs
DONE! I have removed reiserfs support for now, but will add the work around soon. Also I had intended to go down the netboot method of install but I was having trouble at the loader getting an ip address? anyone else seen this?

Posted: Thu May 17, 2007 9:44 pm
by clpalmer
Just did the native install on a new (old =) box I bought. Cheers cheesyboofs, worked like a charm after I made the ext3 changes =)

I noticed the problem with loader getting an IP addy as well. Seems other dashes and gentoox once it's loaded had no issues, but the Loader couldn't get one.

Another thing I noticed is that when I boot, it says my mac addy is all 0's and assigns a random one. Not sure if that's normal or if it has anything to do with the issue with Loader's IP.

Was a bit stuck there cuz my drive was a bit bitchy about accepting a burnt CD/DVD but I got one to work so I forgot about the netboot issues for now.

*EDIT* Posted already about the issue a few days ago in Q&A titled "DHCP failing with loader" but no response on it either.

Posted: Fri May 18, 2007 8:05 am
by cheesyboofs
I mailed Shallax about the loader problem, but he said there is no problem perhaps we need to make a little more noise :wink:
I do get an IP from my IPCop firewall but I cant ping/browse to it, and as you say when Genttox/CD comes up all is well with the Network!

Posted: Sun May 20, 2007 12:38 am
by clpalmer
*push ShALLaX* *poke ShALLaX* *noise*