unable to boot after upgrading bootloader through magic

Ask questions regarding Gentoox, Gentoo and Linux in general in these forums and we'll do our best to help you!
Post Reply
lumpmonkey
Linux User
Posts: 13
Joined: Mon Sep 13, 2004 8:16 pm

unable to boot after upgrading bootloader through magic

Post by lumpmonkey » Sat Jan 08, 2005 3:41 pm

Really puzzled about this, maybe someone can point me in the right direction as to how to fix it.
Magic seemed to run fine, although I didnt pay too much attention to the progress which may be my downfall!
Upon rebooting, i could only select the DVD boot icon, seems like the loader won't detect anything on the hard drive. I tried using a stardust cd just so i could get back in Gentooz but it failed at reading the initrd.gz file (dont think its a problem with the media though )

Currently messing with rescootx, have tried reflashing the bootloader back to a previous version but has no effect. Incidentally the main screen has always shown v4.7 regardless of what bootloader image i flash. Is this normal or am I making a stupid mistake with the flash process?

If someone could give me some pointers as to how to get back into Gentoox I'd be grateful. Currently looking at the linuxboot.cfg file and the syntax looks the same as the new format thats been implemented ie "
title Gentoox
kernel vmlinuz
initrd initrd.g
z"

Does this need to be "downgraded" so I can get back in?
:wink:

Thanks in advance for any advice given

User avatar
ShALLaX
Site Admin
Posts: 1973
Joined: Sun Aug 10, 2003 9:25 pm
Location: England
Contact:

Post by ShALLaX » Sat Jan 08, 2005 3:52 pm

Sounds like you're making a stupid mistake flashing. The old bootloaders WILL NOT WORK with the new fileformat... so yes, until you can figure out how to flash, youll need to downgrade your linuxboot.cfg. To do this, delete all the sparkle section, then delete the "title Gentoox" line.
The original Xbox adaptation of Gentoo

lumpmonkey
Linux User
Posts: 13
Joined: Mon Sep 13, 2004 8:16 pm

cheers

Post by lumpmonkey » Sat Jan 08, 2005 3:56 pm

thanks for that!
Will do what you suggest, incidentally anyone using the xecutor 2.6 variety of modchip take note it might not upgrade properly with the normal procedure, unless im doing something completely brainless of course!

User avatar
ShALLaX
Site Admin
Posts: 1973
Joined: Sun Aug 10, 2003 9:25 pm
Location: England
Contact:

Post by ShALLaX » Sat Jan 08, 2005 3:58 pm

You need to double up the BIOS since that modchip only has 512k banks. cat ./loader.bin ./loader.bin > ./512k.bin

or to make a full 1024k bios... cat ./loader.bin ./loader.bin ./loader.bin ./loader.bin > 1024k.bin

Be warned, this will wipe over EVERYTHING on your chip.
The original Xbox adaptation of Gentoo

lumpmonkey
Linux User
Posts: 13
Joined: Mon Sep 13, 2004 8:16 pm

Post by lumpmonkey » Sat Jan 08, 2005 4:03 pm

ah yeah thats right :oops:
remember seeing that on the xecuter website a while back but now the instructions have been replaced in favour of the X3

lumpmonkey
Linux User
Posts: 13
Joined: Mon Sep 13, 2004 8:16 pm

that did it!

Post by lumpmonkey » Sat Jan 08, 2005 4:17 pm

Cheers for that Shallax

Doubled it up as you said and no probs, its flying now :D

BasketCase
Newbie
Posts: 2
Joined: Mon Jan 10, 2005 2:29 am
Location: Maitland, FL
Contact:

Post by BasketCase » Mon Jan 10, 2005 2:37 am

I am stuck with the same problem and need help...
I downloaded and burned Resctoox but after several tries it just comes up with:

Code: Select all

PCI: Failed to allocate resource 2(f8000000--f7ffffff) for 01:00.0
xpad.c: device 0x0c6f/0x2038 not recognized
and then it just hangs.

How do I get in to re-flash the bios and/or downgrade my linuxboot.cfg file?

I am an experienced Gentoo user but my knowledge of GentooX is pretty limited as I cheated and bought an XBox that already had GentooX installed. :oops:

--
BasketCase

User avatar
ShALLaX
Site Admin
Posts: 1973
Joined: Sun Aug 10, 2003 9:25 pm
Location: England
Contact:

Post by ShALLaX » Mon Jan 10, 2005 8:00 am

Try unplugging your xpad then booting again.
The original Xbox adaptation of Gentoo

BasketCase
Newbie
Posts: 2
Joined: Mon Jan 10, 2005 2:29 am
Location: Maitland, FL
Contact:

Post by BasketCase » Mon Jan 10, 2005 3:58 pm

OK, I am getting a little bit farther...
Now in addition to the previous output I get:

Code: Select all

host/usb-ohci.c: USB HC TakeOver failed!
Trying to vfree() a nonexistent vm area (c5fc4000)
<repeat>
Then it still hangs :(

It also hangs with the Stardust.iso image.

--
Kevin

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest