dropped frames in Mythtv video playback

Talk about anything related to Gentoox or Gentoo.
Post Reply
Snoop244
Newbie
Posts: 4
Joined: Thu Oct 30, 2003 7:44 pm

dropped frames in Mythtv video playback

Post by Snoop244 » Thu Oct 30, 2003 9:07 pm

I have Mythtv PVR frontend running on my Gentoox box. The Master Server (which has the tv capture card runs on a Gentoo machine elsewhere on my network). It all works great (pause live tv, etc..); unfortunately, I'm not getting full framerates. I am running a version of Gentoox that I installed about 6 months ago (I'm at work and can't remember the version number). I'm running KDE as well.

Will the new native install of Gentoox along with XFCE reduce the framedropping? Any kind of guess from forum members in this direction would be helpful as I don't want to gas my current Gentoox for the new one unless I can get a reasonable assurance that Myth will run a bit better.

Also, Myth depends on a new version of QT, which requires an unmerge of the KDE libraries. Can I do this (emerge qt and unmerge kde-libs) and still have XFCE work? I don't care if I ever get KDE going again.

S.

User avatar
fuz
Power user
Posts: 228
Joined: Wed Oct 22, 2003 6:03 am
Location: sunshine coast, Australia
Contact:

Post by fuz » Thu Oct 30, 2003 10:26 pm

the framedrop is as you already are hinting, due to RAM the xbox has 64meg which (after you load xserver) not much.. installing xfce will help to recover some of the ram but the best way to do it (providing all you are using it for in that session is Mythtv) is to load an Xsession (no fancy gui just bare minimum) it can be selected from the Xserver logon screen (click the drop box)..

i dont understand how QT would require k-libs to NOT be present.. thats just funky but if what you say is true you can just remove them (there is a switch under emerge from memory) that will probably kill dependancies for other programs though so be careful!

good luck
127.0.0.1, wherever you go.. there you are!

Snoop244
Newbie
Posts: 4
Joined: Thu Oct 30, 2003 7:44 pm

Post by Snoop244 » Fri Oct 31, 2003 1:23 am

Thanks, I'll give it a try.

For some reason Portage blocks me from emerging the latest version of QT because of some conflict with KDE libs. No big deal. Sounds like the XFCE will give me a bit of a boost.

RalfoX
Newbie
Posts: 8
Joined: Fri Nov 14, 2003 5:08 pm

Post by RalfoX » Fri Nov 14, 2003 5:22 pm

Hi, I'm new to the forum. But I've been playing with GentooX for a couple weeks now. I have mythTV running on it.
I found out that if you run the last command from your /etc/conf.d/xbvinit while mythtv is playing (I run it from an ssh session) the screen will "reset" and sometimes the playback becomes smooth..
Could it be that xbv is not setting the chipset nicely every time?
Can someone else try this and post their findings..
Thanks

Ralfo

User avatar
Sniper Fox
Adept
Posts: 73
Joined: Thu Sep 04, 2003 9:11 pm
Location: Cincinnati, OH
Contact:

Post by Sniper Fox » Fri Nov 14, 2003 7:00 pm

For minimum RAM usage, check out my tutorial on how to install and configure IceWM. It uses half the RAM that XFCE uses (the proof is in my post).

Like fuz said, you can try running without a WM at all. Simply modify your /home/gentoox/.xinitrd. Put a # in front of all of the lines that don't currently have one, then at the bottom put:
exec /path/to/mythtv

RalfoX
Newbie
Posts: 8
Joined: Fri Nov 14, 2003 5:08 pm

Post by RalfoX » Sat Nov 15, 2003 3:13 am

I understand that, and in fact, I use black box WM not XFCE. But RAM is not the problem I'm talking about. You can notice a lack of RAM problem when going from watching Live TV back to the menu, as sometimes it has to swap memory and the redrawing of the screen is terribly slow. I'm talking about the video being shown sluggishly, not smooth ALL THE TIME. You can notice the effect in news channel with a ticker bar like fox news. Try running xbv while watching that channel and see how sometimes it make it run smooth..

Raf.

RalfoX
Newbie
Posts: 8
Joined: Fri Nov 14, 2003 5:08 pm

SOLUTION

Post by RalfoX » Sat Nov 15, 2003 4:23 am

I was just reading the manual and faq for Ogle and came across the following paragraph:

38. I have an nVidia card and (a fast computer) the video jerks/judders/jumps forwards/backwards

There seems to be some problems with Xv and nVidia cards (GeForce...).
Setting the attribute XV_DOUBLE_BUFFER to 0 should make the video smooth. You can use 'xvattr' to do this. xvattr is available for download here.

(http://www.dtek.chalmers.se/groups/dvd/faq.shtml)

So I emerged xvattr and executed the following while watching fox news with the ticker going (and jumping):

xvattr -a XV_DOUBLE_BUFFER -v 0

The video became smooth immediately!!

trying -v 1 took it back to sluggish!!

Post your results people! Does it affect adversely something else?? If not: ShallaX, maybe you can consider making this command part of the default .xinitrc or something.

Ralfo.

(PS Note that disabling the double buffering will make it so that can actually see the screen being painted, so try it and see if you like it. I think it is MUCH better this way).

donald
Newbie
Posts: 6
Joined: Tue Nov 18, 2003 7:09 pm

Post by donald » Wed Nov 19, 2003 4:10 pm

I used to have the jerky newsfeed when I ran MythTV frontend on my xbox. But a couple of months ago I ran magic xbv (or xbv2, I forgot which) and that fixed my problem

donald

bruor
Newbie
Posts: 2
Joined: Wed Sep 24, 2003 5:02 am

Post by bruor » Sun Feb 29, 2004 4:48 pm

great post, this saved my setup!!!!
using xvattr to set double buffer to 0 made things very responsive again.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest