Large hard drive LBA48 users Beware

Talk about anything related to Gentoox or Gentoo.
Post Reply

What size was your F partition?

< 137GB
12
46%
= 137GB
2
8%
> 137GB
11
42%
What F (/dev/hda55) partition are you talking about?
1
4%
 
Total votes: 26

User avatar
Terra
Novice
Posts: 23
Joined: Fri Oct 03, 2003 7:45 am

Large hard drive LBA48 users Beware

Post by Terra » Wed Nov 05, 2003 8:26 pm

If you were using a F: drive (/dev/hda55) that was greater than 137GB, then you will find it no longer works correctly in GentooX 3.0. :evil:

There was a change in the Linux kernel between:
Linux 2.4.20 - used for GentooX 2.x series
Linux 2.4.22 - used for GentooX 3.x series

Actually the change occurred between: 2.4.20 and 2.4.21

The change can be viewed here:
http://cvs.sourceforge.net/viewcvs.py/x ... 11&r2=1.12

Basically, this change will only allow a maximum 'F:' (/dev/hda55) partition of 137GB, maintaining lba28 compatibility and forcing all remaining sectors to the 'G:' (/dev/hda56) partition.

Overall, this has worked out nicely for me since I was a bit frustrated with the overhead of running the root partition from a loopback in GentooX 2.1. This opened up the avenue to place the 'rootfs' onto a native reiserfs partitioned '/dev/hda56' with minimal effort with resulted in a very nice performance boost.

The only thing you will have to do is adjust your bios with xbtool + lba48 + 'Partition 6 Takes up to 137GB / Partition 7 Takes Rest'. I am personally using X2-4977 bios, since it is 256KB in size and works perfectly well with my Matrix modchip. If you use EvoX, just set 'UseGDrive No', since EvoX won't understand a reiserfs formatted partition anyhow.

So if anyone was wondering what happened to their 'F:' (/dev/hda55) partition, and why it wasn't working correctly - the above kernel change is why.

Putting the 'rootfs', on /dev/hda56, was a snap with only minor changes to the following files:
1) linuxboot
kernel vmlinuz
append root=/dev/hda56 pci=biosirq kbd-reset video=xbox:800x600,nohwcursor,hoc=X,voc=Y

and
2) fstab
Change the '/dev/loop/0' line to:
/dev/hda56 / reiserfs defaults,errors=remount-ro 0 1

Also, make sure you have properly copied over your mounted 'rootfs' loopback to the /dev/hda56 partition before attempting to reboot with the new settings. I personally used 'mc' to do the copy, while manually creating the '/mnt' tree and '/proc' directory, but you can also use 'rsync', 'tar', 'cpio', etc. to do the rootfs image copy.

Hope this helps someone out that is using a large /dev/hda55 partition.

~
Terra
~

SpiderSense
Newbie
Posts: 5
Joined: Tue Oct 07, 2003 11:29 pm

Post by SpiderSense » Thu Nov 06, 2003 1:45 am

Terra, thank very much for the info!!

I posted this problem, but got no help.
viewtopic.php?t=394

My X2 bios uses the rest of the drive for F. I fear adding drive G will kill all data off F. I guess I'll just live with Gentoox on E.

Wish I can just xbtool cromwell.

Thanks for the post!

User avatar
ShALLaX
Site Admin
Posts: 1973
Joined: Sun Aug 10, 2003 9:25 pm
Location: England
Contact:

Post by ShALLaX » Thu Nov 06, 2003 9:12 am

Welldone, someone actually went to the trouble of investigating a problem themselves!

*stuck*
The original Xbox adaptation of Gentoo

Thanos
Linux User
Posts: 15
Joined: Tue Nov 11, 2003 9:16 pm

Post by Thanos » Tue Nov 11, 2003 9:22 pm

Are these instructions for when you want to use the G partition within Gentoox, or just to resolve any issues with the F partition when using a hard drive >137gb? I have a 160Gb hard drive, and I am getting odd behavior when trying to save data to the F drive. I have my bios set to use 137GB partition 6 and partition 7 for the rest.

I really don't care much about the G drive through linux. I don't know how to troubleshoot this type of error. Also, I'm not sure if it is a limitation of Gentoox, but I can't set permissions for the gentoox user to access the F partition. I've tried modifying fstab and CHMOD.
Thanos

User avatar
Terra
Novice
Posts: 23
Joined: Fri Oct 03, 2003 7:45 am

Post by Terra » Tue Nov 11, 2003 10:06 pm

Are these instructions for when you want to use the G partition within Gentoox, or just to resolve any issues with the F partition when using a hard drive >137gb?
It covers both cases in an either/or fashion.

You are not required to use the supplemental "run GentooX from G partition", it just means you have the capability to do so if desired.

To save yourself some grief, you should go ahead and backup your F partition, then reformat it via EvoX - or via GentooX if you are still running GentooX on the E partition.

Most likely, the F partition was originally formatted for "Partition 6 takes rest", however there is no allusion to that fact - only speculation.
I don't know how to troubleshoot this type of error.
Well - that would take a utility, such as dumpe2fs, that could grok the partition structures and determine exactly what it was formatted for. The actual partition table itself is embedded in the BIOS which is why utils like fdisk, cfdisk, sfdisk won't display any valid partition tables. You just have to 'know' how the disk was formatted and to which partitioning scheme was active at that time within the BIOS.
I'm not sure if it is a limitation of Gentoox
It is not a limitation of GentooX, per se. It was a change made to the Linux Kernel during the 2.4.20 to 2.4.21 transition. GentooX is indirectly affected by this, but is by no means the cause of the limitation. Most likely, the Xbox kernel hackers chose to play it safe since many newbies were doing a Pac Man on their drives via the raw power of XBtool and friends. Also it would be difficult to determine exactly what partitioning scheme was used as accorded to earlier.

~
Terra
~

Thanos
Linux User
Posts: 15
Joined: Tue Nov 11, 2003 9:16 pm

Post by Thanos » Wed Nov 12, 2003 2:57 am

To tell you the truth, I changed the bios information, then I formatted the system using Slayer's latest release. This allowed me to view/use drive G. I then installed Gentoox, and I'm at the point where I'm at right now.

I'd hate to reformat the box again if I'm going to run into the same problems. Is there something I'm looking for from the dumpe2fs that would help explain the errors? I'm not familiar with this command or its usage, so your help is appreciated.

The only thing I can think of is that I have a Cromwell bios on one of my bios configurations without the proper partitioning, but there would be no way for me to have formatted the drive since it wouldn't have booted the Slayer CD with that bios.
Thanos

Thanos
Linux User
Posts: 15
Joined: Tue Nov 11, 2003 9:16 pm

Post by Thanos » Fri Nov 14, 2003 9:01 pm

I broke down and decided to reformat the whole unit. What I don't get is when I boot off the Gentoox install CD, I get a funny message. It says that LBA48 is supported, however a few lines lower after it shows my hard drive information, it says that LBA28 Support Only or something in those lines.

I was wondering if anyone knew if this was an indication that my drive will not work properly with Gentoox. I am using Evox M7 with LBA48 support and Partition 7 taking the rest of a 160Gb drive.
Thanos

Thanos
Linux User
Posts: 15
Joined: Tue Nov 11, 2003 9:16 pm

Post by Thanos » Fri Nov 14, 2003 9:04 pm

Also, when trying to install Gentoox to the F drive right off the bat, it gives me an odd error:

Preparing Xbox:
* Formatting filesystems... [ ok ]
* Mounting filesystems... [ ok ]
* Testing filesystems...-sh: cannot create /mnt/f/test: Read-only file system
An error occurred, halting
[Error writing to install device]

It works just fine if I try to install it to the e drive.
Thanos

Thanos
Linux User
Posts: 15
Joined: Tue Nov 11, 2003 9:16 pm

Post by Thanos » Thu Nov 20, 2003 10:33 pm

Has anyone experienced such a problem with their hard drive?
Thanos

crom
Newbie
Posts: 1
Joined: Sun Jan 11, 2004 8:33 am

Post by crom » Sun Jan 11, 2004 8:35 am

I get the exact same thing, but with an 80gig hdd.

Bucko
Power user
Posts: 229
Joined: Mon Aug 11, 2003 4:14 pm
Location: England
Contact:

Post by Bucko » Tue Jan 13, 2004 7:53 pm

Putting the 'rootfs', on /dev/hda56, was a snap with only minor changes to the following files:
1) linuxboot
kernel vmlinuz
append root=/dev/hda56 pci=biosirq kbd-reset video=xbox:800x600,nohwcursor,hoc=X,voc=Y

and
2) fstab
Change the '/dev/loop/0' line to:
/dev/hda56 / reiserfs defaults,errors=remount-ro 0 1

Also, make sure you have properly copied over your mounted 'rootfs' loopback to the /dev/hda56 partition before attempting to reboot with the new settings. I personally used 'mc' to do the copy, while manually creating the '/mnt' tree and '/proc' directory, but you can also use 'rsync', 'tar', 'cpio', etc. to do the rootfs image copy.

Hope this helps someone out that is using a large /dev/hda55 partition.
Hiya, I used to install Gentoox to E:\ but now I can't even install it because I've run out of space there lol. Well anyway I was thinking like I don't use my 20GB G Drive or so and I don't mind formating it to Gentoox.

I just edit steps 1 and 2 in say a text editor on my pc don't I to boot from G but what is all that about 'your mounted rootfs' I'm kinda of new to all this mount stuff. Thanks if you can help, bucko.

User avatar
nobspangle
Gentoox Guru!
Posts: 1681
Joined: Sun Sep 28, 2003 11:59 am
Location: Manchester, UK

Post by nobspangle » Tue Jan 13, 2004 9:33 pm

make the changes to /etc/fstab and linuxboot.cfg
then load up your stardust cd and hit ctrl+c to get out of the installer this will drop you at prompt then proceed as follows

Code: Select all

yes | mkreiserfs /dev/hda56
mkdir /mnt/rootfs
mkdir /mnt/hda56
mount -t reiserfs -o loop /mnt/e/rootfs /mnt/rootfs
mount /dev/hda56 /mnt/hda56
cp -avx /dev/rootfs/* /mnt/hda56/
cd /
umount /mnt/hda56
umount /mnt/rootfs
reboot
Then remove the stardust CD and boot from your harddrive as normal, check that you are working from hda56 with df or mount if you are you can safely delete your rootfs file, you must keep the other files in place
If you keep an open mind, will your brain fall out?

Bucko
Power user
Posts: 229
Joined: Mon Aug 11, 2003 4:14 pm
Location: England
Contact:

Post by Bucko » Wed Jan 14, 2004 2:18 pm

Also, make sure you have properly copied over your mounted 'rootfs' loopback to the /dev/hda56 partition before attempting to reboot with the new settings. I personally used 'mc' to do the copy, while manually creating the '/mnt' tree and '/proc' directory, but you can also use 'rsync', 'tar', 'cpio', etc. to do the rootfs image copy.

Hope this helps someone out that is using a large /dev/hda55 partition.
Hum copy over my mounted rootfs? How do I do that. Rsync, tar what? Basicaly what the full commands. Thanks for the other info nobspangle. Just a little confused about the above.

Oh is the cp the copy command for the rootfs image to hda56? Not sure guess it is.

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests