tightvnc keyboard input in other language than english?

Ask questions regarding Gentoox, Gentoo and Linux in general in these forums and we'll do our best to help you!
Post Reply
klippan
Newbie
Posts: 2
Joined: Sat Jul 29, 2006 10:38 am

tightvnc keyboard input in other language than english?

Post by klippan » Sat Jul 29, 2006 10:50 am

Hello there!

Im trying to get tightvnc to accept keyboard input of non-english characters (i want to be able to use Swedish characters).

Im running KDE and have changed both KDE and keyboard input in KDE to Swedish and that works fine (LINGUAS="sv" emerge kde-i18n).

However, whenever i remote control my xbox via tightvnc i cannot use Swedish characters, any suggestions?

klippan
Newbie
Posts: 2
Joined: Sat Jul 29, 2006 10:38 am

Post by klippan » Sat Jul 29, 2006 4:34 pm

Ok, half the problem is now solved.

I can now type foreign/Swedish characters while using tightvnc.
Solved by:
"pico -w /etc/X11/xorg.conf" then a simple change under section "InputDevice" to
"Option "XkbLayout" "se""
and a reboot.

However, there are some characters that still are impossible to type while using tightvnc (like "at"/"@"). The "@" character can be typed with no problem when controlling the xbox locally via usb-keyboard.
Ive got a Swedish "Microsoft Natural Keyboard".
Ive tried the following changes to "xorg.conf" under section "InputDevice" (on change at a time and then reboot):

Option "XkbModel" "pc102"
Option "XkbModel" "pc105"
Option "XkbModel" "microsoft"
Option "XkbVariant" "nodeadkeys"
Option "LeftAlt" "Meta"
Option "RightAlt" "ModeShift"

Not being able to use the @/at character is very disturbing. This can surely be solved, the question is how...

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests