Manually change display resolution in xfce

Ask questions regarding Gentoox, Gentoo and Linux in general in these forums and we'll do our best to help you!
Post Reply
ee.biker
Newbie
Posts: 6
Joined: Sat Mar 19, 2005 2:54 pm

Manually change display resolution in xfce

Post by ee.biker » Sat Mar 19, 2005 3:06 pm

Hello. In Gentoox Home, is there a file equivalent to XF86Config that I can place Modeline commands (or equivalent) in for XFCE?
The XF86Config does exist, however making Modeline changes here does not have any effect.
I realize I can use xbvset, however I need finer control of the resolution changes.
Thanks

User avatar
ShALLaX
Site Admin
Posts: 1973
Joined: Sun Aug 10, 2003 9:25 pm
Location: England
Contact:

Post by ShALLaX » Sat Mar 19, 2005 11:03 pm

All changes go in XF86Config (or xorg.conf depending on how up to date you are). They should all work fine.
The original Xbox adaptation of Gentoo

ee.biker
Newbie
Posts: 6
Joined: Sat Mar 19, 2005 2:54 pm

Post by ee.biker » Sat Mar 19, 2005 11:43 pm

Thanks.
Let me be a bit more specific:
I am using VGA with internal syncs. VGA is very stable and works fine in Xebian and I have full control of the resolutions with XF86Config.
When I run your xbvset there is no VGA choice. Therefore I choose X2VGA (I have tried them all just this one is most recent), 720p, 1024x768 (if I remember correctly). After reboot is does great, the mode is just as it is in XF86Config. Now I change that mode to something I want. Reboot. Xfce seems to default to some hard coded resolution of 1155x768 (not sure), definitely not what I asked for.
I can detail this exactly if you like. I just wanted to give you some more info while you were here (maybe).

ee.biker
Newbie
Posts: 6
Joined: Sat Mar 19, 2005 2:54 pm

Post by ee.biker » Sat Mar 19, 2005 11:58 pm

Here is exactly what I tried:
xbvset
X2VGA
720p
1024x768
reboot
fbset –i
mode "1024x768-57"
# D: 62.504 MHz, H: 45.824 kHz, V: 57.424 Hz
geometry 1024 768 1024 768 32
timings 15999 220 40 22 3 80 5
rgba 8/16,8/8,8/0,0/0
endmode
fbset –x
Mode "1024x768"
# D: 62.504 MHz, H: 45.824 kHz, V: 57.424 Hz
DotClock 62.505
HTimings 1024 1064 1144 1364
VTimings 768 771 776 798
Flags "-HSync" "-VSync"
current XF86Config:
Modeline "xbox" 62.501 1024 1064 1144 1364 768 771 776 798 -hsync -vsync
Great! Everything matches.
My change:
Modeline "xbox" 45.456 800 820 870 980 600 610 615 630 -hsync -vsync
Reboot
fbset –i
mode "1152x768-55"
# D: 64.998 MHz, H: 44.157 kHz, V: 54.785 Hz
geometry 1152 768 1152 768 32
timings 15385 158 26 29 3 136 6
hsync high
vsync high
rgba 8/16,8/8,8/0,0/0
endmode
fbset –x
Mode "1152x768"
# D: 64.998 MHz, H: 44.157 kHz, V: 54.785 Hz
DotClock 64.999
HTimings 1152 1178 1314 1472
VTimings 768 771 777 806
Flags "+HSync" "+VSync"
EndMode

It seems to get angry and default to some setting that I cannot find anywhere.

ee.biker
Newbie
Posts: 6
Joined: Sat Mar 19, 2005 2:54 pm

Post by ee.biker » Sun Mar 20, 2005 3:11 am

My fault!
A newbie mistake. The sync rates I was entering were > monitors defined limits.
It works now.

User avatar
ShALLaX
Site Admin
Posts: 1973
Joined: Sun Aug 10, 2003 9:25 pm
Location: England
Contact:

Post by ShALLaX » Sun Mar 20, 2005 7:37 pm

:)
The original Xbox adaptation of Gentoo

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests