Magic X.Org Upgrade failing at XServer Path

Talk about anything related to Gentoox or Gentoo.
Post Reply
faser
Newbie
Posts: 8
Joined: Sun Jan 30, 2005 8:00 am

Magic X.Org Upgrade failing at XServer Path

Post by faser » Sun Jan 30, 2005 8:06 am

Hi All,

I tried to update my system with magic. But afer libtool is emerged the script fails with the following message

*************
Emerge failed.
xserver patch failed.
Check your network settings and try again.
*************

Network Settings are OK, emerge sync has been done today, Clock is set by NTP.

Any idea, is there a log I can check?

Cheers

Faser

honukele
Novice
Posts: 32
Joined: Sun Jan 09, 2005 1:30 am

Post by honukele » Sun Jan 30, 2005 11:25 am

Xorg patch failed for me, too. So I completely deleted/ uninstalled Gentoox and reinstalled from the beginning. The Xorg patch worked then. Fortunately I had taken notes on most of my settings, network settings, etc.

I don't know if there is a way to make the patch work without re-installing, as nobody responded to my earlier post, and I don't have the time to devote to becoming a Linux expert.

User avatar
winterborne
Pro
Posts: 93
Joined: Mon Nov 17, 2003 9:45 am
Location: Canada

Post by winterborne » Wed Feb 02, 2005 3:47 am

Did either of you check for harddrive space? Xorg failed for me too, then I ran df and saw that magic had eaten up all my space :\
I'ts been running two hours now (running magic a third time) and it's already used up 160mb. I've only got 130 left :\ How long did it take you to emerge it, honukele?

User avatar
ShALLaX
Site Admin
Posts: 1973
Joined: Sun Aug 10, 2003 9:25 pm
Location: England
Contact:

Post by ShALLaX » Wed Feb 02, 2005 4:16 am

It takes 3-4 hours.
The original Xbox adaptation of Gentoo

faser
Newbie
Posts: 8
Joined: Sun Jan 30, 2005 8:00 am

Post by faser » Wed Feb 02, 2005 4:20 am

The harddisk can not be the problem have 10GB free on /

Shallax any hint how I can monitor at which point magic fails?????

vplayer
1337
Posts: 442
Joined: Thu Oct 07, 2004 11:06 pm
Location: USA

Post by vplayer » Wed Feb 02, 2005 12:59 pm

It would help if you told us what kind of Gentoox installation you have there.

Your internet connectivity could have died for a few minutes :)
Box: XBOX ver 1.1
Mod: Xecutor 2.3 lite+
Hdd: WD 80GB
Dash: Evox, Ava, XBMC
Linux: Gentoox Pro 4.2

faser
Newbie
Posts: 8
Joined: Sun Jan 30, 2005 8:00 am

Post by faser » Wed Feb 02, 2005 2:59 pm

Hi Vplayer,

thanks for help to find reasons. My Internet Connectivity could not have died as I access the internet via my firewall which had an IPSEC tunnel which haven't reloaded.

I am not sure how I can tell you what kind of Gentoox Installation I have.

dmesg shows: Linux version 2.4.22-xbox (root@Xbox) (gcc version 3.2.3 20030422 (Gentoo Linux 1.4 3.2.3-r2, propolice))

/dev/hda2 is mounted to / and has 29GB free

Magic tells
You are running Gentoox Home 3.0
--------------------------------------------------------------------

Gentoox is distributed under the GNU General Public License.

Patch serial: 20050201008
wget: wget -T 30 -t 5

+ Gentoox Loader v5.4.
+ Xorg support.
+ magic f-drive and magic e-drive removed. See website.


I say
sync: no (already synced before starting magic)
xserver: yes
kde: no

Magic then does an emerge libtool (which if I do it by hand works smoothly)

And then after libtool is installed I get

Emerge failed.
xserver patch failed.
Check your network settings and try again.

Magic encountered the above error, please try again later.



I hope that gives you an idea what I have.

Cheers

Frederik

john betonschaar
Newbie
Posts: 3
Joined: Sun Feb 06, 2005 3:13 pm

Xorg patch fails

Post by john betonschaar » Sun Feb 06, 2005 4:07 pm

Hi,

I have the same problem emerging xorg-x11, either by running magic or emerging manually. 'emerge xorg-x11' fails with the following error:

Code: Select all

 * Failed Patch: 9990_x86_6.8.0-xbox-20041024.patch!
 * 
 * Include in your bugreport the contents of:
 * 
 *   /var/tmp/portage/xorg-x11-6.8.0-r4/temp/9990_x86_6.8.0-xbox-20041024.patch-29379.out
In the .out file it says:

Code: Select all

patching file xc/config/cf/xorg.cf
Hunk #7 FAILED at 512.
Hunk #8 succeeded at 563 (offset 4 lines).
Hunk #9 succeeded at 590 (offset 4 lines).
Hunk #10 succeeded at 622 (offset 4 lines).
Hunk #11 succeeded at 651 (offset 4 lines).
Hunk #12 succeeded at 1584 (offset 4 lines).
1 out of 12 hunks FAILED -- saving rejects to file xc/config/cf/xorg.cf.rej
Since I have no idea where portage leaves the rejects (they where gone) I did a 'ebuild xorg-x11-... fetch unpack' and applied the patches myself, and the patch failed again, with the following rejects:

Code: Select all

***************
*** 608,617 ****

  #endif

- #ifndef DevelDRIDrivers
- #define DevelDRIDrivers mach64
- #endif
- 
  /* Sparc64 Drivers */
  #if defined(OpenBSDArchitecture) && defined(Sparc64Architecture)
  /* Amiga framebuffer module */
--- 512,517 ----

  #endif

  /* Sparc64 Drivers */
  #if defined(OpenBSDArchitecture) && defined(Sparc64Architecture)
  /* Amiga framebuffer module */
The mach64 lines are missing :-(

Strange, because it worked yesterday on the very same xbox? As a side node, that was *before* 'emerge -u world' completely borked my beautiful gentoox installation by 'downgrading' almost every package on my system, effectively removing binutils, bash etc. Still not sure how that happened, probably because I switched a fully loaded system to the default-linux/x86/xbox profile...

Anyway, I'm off trying to run magic again, editing the patch before it gets applied, and if that works we have a fix ;-)

John Betonschaar

john betonschaar
Newbie
Posts: 3
Joined: Sun Feb 06, 2005 3:13 pm

Xorg patch fails - fixed

Post by john betonschaar » Sun Feb 06, 2005 4:26 pm

Yup this solves it for me: in the 9990-xbox-.. patch file remove the following lines:

Code: Select all

@@ -608,10 +512,6 @@

 #endif

-#ifndef DevelDRIDrivers
-#define DevelDRIDrivers mach64
-#endif
-
 /* Sparc64 Drivers */
 #if defined(OpenBSDArchitecture) && defined(Sparc64Architecture)
 /* Amiga framebuffer module */
They're at lines 245 to 255 in the patch file I got when magic emerges xorg-x11-6.8.0-r4.

I copied the modified patch file to a temporary directory, ran magic again, waited until it started applying the xorg patches and before it got to the xbox patch I copied the modified patch over the one in /var/tmp/portage/xorg-x11-6.8.0-r4/work/patch. Emerging xorg as we speak... :-)

Maybe the patch needs fixing?

l8er,

John Betonschaar

User avatar
ShALLaX
Site Admin
Posts: 1973
Joined: Sun Aug 10, 2003 9:25 pm
Location: England
Contact:

Post by ShALLaX » Sun Feb 06, 2005 8:22 pm

Unfortunately, thats nothing to do with me.. thats another one of Gentoo's blunders which they will hopefully fix.

Great work, though!
The original Xbox adaptation of Gentoo

faser
Newbie
Posts: 8
Joined: Sun Jan 30, 2005 8:00 am

Post by faser » Wed Feb 16, 2005 3:14 pm

Thanks for all your help, worked like a charme!

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests