VideoLan Client (VLC)

Ask questions regarding Gentoox, Gentoo and Linux in general in these forums and we'll do our best to help you!
Post Reply
AnA-l
Newbie
Posts: 2
Joined: Sun Nov 14, 2004 6:59 pm

VideoLan Client (VLC)

Post by AnA-l » Sun Nov 14, 2004 7:11 pm

Ok, i'm trying to run my box as a router, but also as a video frontend.
I tried mythtv, and freevo, not what i want.
I'm now trying to use VLC to stream media from my winXP :( computer to a VLC running on my xbox.

oki, to be honnest, it doesn't work AT ALL.

so, i got somes questions, for you, gurus :D

Is anyone having installed, run, or tried to do it under gentoox ?
Have anyone encoutered problems installing VLC or running it ?
Does anyone knows why emerge vlc need to install mozilla 1.7.3 ?
and anyone knows how to configure or/and setup VCL under gentoox ?

ok, thx for reading, and answering.

User avatar
nobspangle
Gentoox Guru!
Posts: 1681
Joined: Sun Sep 28, 2003 11:59 am
Location: Manchester, UK

Post by nobspangle » Sun Nov 14, 2004 10:17 pm

You can stop it compiling mozilla by doing

Code: Select all

mkdir /etc/portage
echo media-video/vlc\ -mozilla >> /etc/portage/package.use
emerge vlc
If you keep an open mind, will your brain fall out?

AnA-l
Newbie
Posts: 2
Joined: Sun Nov 14, 2004 6:59 pm

Post by AnA-l » Sun Nov 14, 2004 10:41 pm

it's ok for mozilla, thanks, but it's too late
(3days compiling, but done!)

my question where more about vlc, and it's plugins,
do i need more library, like qt, or wxwindows, etc...
because vlc is installed fine, but erroneous when running:

Code: Select all

Xbox vlc-0.8.0 # vlc
VLC media player 0.8.0 Janus
[00000419] skins2 interface error: Cannot open display
[00000419] skins2 interface error: Cannot initialize OSFactory
[00000419] skins2 interface error: Cannot open display
[00000419] skins2 interface error: Cannot initialize OSFactory
Remote control interface initialized, `h' for help

------ FIXED i was running this from screen
etc... :D, everything runs fine, finally !

Gottfridsson
Newbie
Posts: 1
Joined: Wed Aug 03, 2005 8:24 pm
Contact:

Post by Gottfridsson » Wed Aug 03, 2005 8:42 pm

I'm trying to get my xbox to play most media files and most importantly I want it to play .iso and .img dvd images. XBMC claims to do this but it doesn't. I've been running Gentoo on my proliant server for ages, so I've installed GentooX mainly coz I know vlc plays the files I want to play, wxwindows is sort of needed since I'd like an interface a bit more user friendly than the console interface.

The first emerge failed miserably so I installed Gentoox home 4 and set the USE flags I wanted:

Code: Select all

USE="X gtk -gnome kde mmx alsa aalib dvd gpm mpeg oggvorbis perl png qt quicktime samba sse tcltk truetype usb xmms a52 aac bidi cdda cddb cdio dts dvb ffmpeg freetype ggi gnutls httpd joystick libcaca live matroska stream svg theora unicode v4l vcd vlm wxwindows xosd"
wxwindows didn't emerge so to be sure everything was up to date:

Code: Select all

emerge --deep --update --newuse world
etc-update
magic uhoh
Confident that this would work I started a "emerge wxGTK" with the same error I got days ago before updating world:

Code: Select all

i686-pc-linux-gnu-g++ -c   -I./lib/wx/include/gtk2u-2.4 -I../include -DXTHREADS -D_REENTRANT -DXUSE_MTSAFE_API -pthread -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/pango-1.0 -I/usr/include/freetype2 -I/usr/include/freetype2/config -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES    -D__WXGTK__ -DGTK_NO_CHECK_CASTS -O2 -MMD -march=pentium3 -O2 -fomit-frame-pointer -pipe -I/usr/include/pango-1.0 -I/usr/include/freetype2 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -pthread -Wall -fPIC -o imagbmp.o ../src/common/imagbmp.cpp
i686-pc-linux-gnu-g++ -c   -I./lib/wx/include/gtk2u-2.4 -I../include -DXTHREADS -D_REENTRANT -DXUSE_MTSAFE_API -pthread -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/pango-1.0 -I/usr/include/freetype2 -I/usr/include/freetype2/config -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES    -D__WXGTK__ -DGTK_NO_CHECK_CASTS -O2 -MMD -march=pentium3 -O2 -fomit-frame-pointer -pipe -I/usr/include/pango-1.0 -I/usr/include/freetype2 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -pthread -Wall -fPIC -o image.o ../src/common/image.cpp
{standard input}: Assembler messages:
{standard input}:419: Error: symbol `.L23' is already defined
make: *** [image.o] Error 1

!!! ERROR: x11-libs/wxGTK-2.4.2-r3 failed.
!!! Function src_compile, Line 114, Exitcode 2
!!! make unicode failed
!!! If you need support, post the topmost build error, NOT this status message.
This is the end of my attention span if I don't get any input on how to adress this.

Any Ideas on a userfriendly software to play most media files and mainly .iso .ima dvd image files other than vlc?

Any ideas on how to emerge wxGTK?

Post Reply

Who is online

Users browsing this forum: No registered users and 15 guests