external usb drive

Ask questions regarding Gentoox, Gentoo and Linux in general in these forums and we'll do our best to help you!
Post Reply
detroit
Novice
Posts: 39
Joined: Mon Aug 11, 2003 10:37 pm
Location: Stafford, UK

external usb drive

Post by detroit » Mon Aug 11, 2003 10:41 pm

Has anyone been able to connect an external usb drive to the xbox with gentoox v2? If so what were the exact steps that you took to mount the drive, and what custom configuration (if any) did you do to the default setup?

detroit
Novice
Posts: 39
Joined: Mon Aug 11, 2003 10:37 pm
Location: Stafford, UK

Post by detroit » Mon Aug 25, 2003 7:47 pm

anyone tried this in 2.1?
It's amazing that one of the most seemingly useful features has been impossible for so long. Mounting a USB drive seems like it should pretty basic-- has no one in the history of xbox development really never succeeded at this?

detroit
Novice
Posts: 39
Joined: Mon Aug 11, 2003 10:37 pm
Location: Stafford, UK

Post by detroit » Fri Sep 19, 2003 8:05 am

still hasn't been done.
it's possible to record to usb cdrom, but not to actually mount a usb drive.

User avatar
ShALLaX
Site Admin
Posts: 1973
Joined: Sun Aug 10, 2003 9:25 pm
Location: England
Contact:

Post by ShALLaX » Fri Sep 19, 2003 10:38 pm

If you actually read the news, youd see i did this a few weeks ago... theres even a post in this forum about it... use your eyes before posting needlessly.

detroit
Novice
Posts: 39
Joined: Mon Aug 11, 2003 10:37 pm
Location: Stafford, UK

Post by detroit » Sun Sep 21, 2003 4:22 am

if you bothered to read my post, you would see that I wasn't talking about cd burning, but mounting an external usb drive, which has still not been acheived or demonstated.

detroit
Novice
Posts: 39
Joined: Mon Aug 11, 2003 10:37 pm
Location: Stafford, UK

Post by detroit » Sun Sep 21, 2003 6:49 am

i finally got this to work on 2.1:

modprobe usb-storage
modprobe scsi_mod
modprobe ide-scsi
modprobe sg
modprobe sr_mod
mkdir /mnt/usb
mount /dev/sda1 /mnt/usb

User avatar
ShALLaX
Site Admin
Posts: 1973
Joined: Sun Aug 10, 2003 9:25 pm
Location: England
Contact:

Post by ShALLaX » Sun Sep 21, 2003 1:36 pm

I read your post, and you dont have the technical ability to explain yourself properly. You stated "USB drive". That means ANY type of drive. Dont argue the point that "mounting" makes any difference because you still have to mount cd drives, besides... I HAD done this, the access speeds were so slow it was barely worth posting about. If you read the news page youd have seen that i posted the necessary kernel configuration to achieve this.

For your reference:

http://gentoox.shallax.com/modules.php? ... cle&sid=53
http://gentoox.shallax.com/modules.php? ... cle&sid=55

detroit
Novice
Posts: 39
Joined: Mon Aug 11, 2003 10:37 pm
Location: Stafford, UK

Post by detroit » Mon Sep 22, 2003 3:35 am

thanks, glad to see you've made some progress on this too,

britishseapower
Novice
Posts: 30
Joined: Sun Feb 27, 2005 9:03 am

Post by britishseapower » Fri Mar 18, 2005 9:09 pm

detroits instructions got my external hard disk working! It was a little slow but certainly useable. Be nice if the xbox had usb2 ports! Biggest problem was all the debug messages i got in dmesg output and in the log files. I got read of the debug optionsin the kernel .config and reinstalled. I STILL got the annoying messages though.

I would REALLY like to plug my usb drive back in, anyone solved this one?

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests