gcc-4 problem

Ask questions regarding Gentoox, Gentoo and Linux in general in these forums and we'll do our best to help you!
Post Reply
keyz182
Newbie
Posts: 1
Joined: Mon May 21, 2007 5:05 pm
Location: Wales

gcc-4 problem

Post by keyz182 » Mon May 21, 2007 5:20 pm

i've been looking through the forum and cant find an answer to my question, so here goes.. i'm trying to emerge the rt2570 module to use my usb wireless adapter, but emerge says that modules can't be compiled against the 2.4 kernel using gcc4 or greater.. my questions are as follows
a) is gcc-3.4 already on the home 6.2 default install, and if so, how do i get emerge to use it? (i had a look at gcc-config, but it only has a profile for gcc-4.1.1)
b) if gcc-3.4 isn't already there; i know from experience that gcc takes ages to compile, so would it be easier to install a 2.6 kernel than compiling old gcc.. and how would i go about getting everything for a 2.6 kernel? (i've compiled kernels before, but is it available via emerge or magic...?)

any help is much appreciated!

and gentoox rawks! (tried xUbuntu x-dsl and xebian.. didnt like them though...)

User avatar
ShALLaX
Site Admin
Posts: 1973
Joined: Sun Aug 10, 2003 9:25 pm
Location: England
Contact:

Post by ShALLaX » Tue May 29, 2007 11:16 am

2.6 wont run properly with FatX... your best bet is to install GCC3, I'm afraid (it'll take about 2-3 hours).
The original Xbox adaptation of Gentoo

Post Reply

Who is online

Users browsing this forum: No registered users and 7 guests