USE flag 'sharedmem' conflicts w/ these USE flag(s): threads

A place to ask all newbie questions and not get flamed, though you will get beaten down if you post a newbieish question outside of these walls.
Post Reply
satur9
Newbie
Posts: 3
Joined: Mon Jun 19, 2006 4:21 pm

USE flag 'sharedmem' conflicts w/ these USE flag(s): threads

Post by satur9 » Tue Jul 11, 2006 12:14 pm

When I try to emerge php I get this error. I tried to put "USE="dev-lang/php-5.1.4 -threads"" in the package.use file like emerge tells me but I must be putting it it wrong.

What is the correct syntax to shut off threads to stop the "sharedmem" error and install php?

I followed the tutorial on the main gentoox site. I am running the newest version of gentoox home v5. I've updated portage, ran magic, and ran emerge sync (not necessarily in that order)

any help is appreciated, thanks
mike
--- Invalid atom in /etc/portage/package.use: USE="dev-lang/php-5.1.4
Calculating dependencies... done!
>>> Emerging (1 of 1) dev-lang/php-5.1.4 to /
>>> checking ebuild checksums ;-)
>>> checking auxfile checksums ;-)
>>> checking miscfile checksums ;-)
>>> checking php-5.1.4.tar.bz2 ;-)
>>> checking php-patchset-5.1.4-r1.tar.bz2 ;-)
* Determining SAPI(s) to build
* Enabled SAPI: cli
* Disabled SAPI: cgi
* Disabled SAPI: apache
* Enabled SAPI: apache2
*
* If this package fails with a fatal error about Apache2 not having
* been compiled with a compatible MPM, this is normally because you
* need to toggle the 'threads' USE flag.
*
* If 'threads' is off, try switching it on.
* If 'threads' is on, try switching it off.
*
*
* USE flag 'truetype' needs one of these additional flag(s) set:
* gd gd-external
*
* 'gd' was automatically selected and enabled.
* You can change that by enabling/disabling those flags accordingly
* in /etc/portage/package.use.
*
*
* USE flag 'sharedmem' conflicts with these USE flag(s):
* threads
*
* You must disable these conflicting flags before you can emerge this package.
* You can do this by disabling these flags in /etc/portage/package.use:
* =dev-lang/php-5.1.4 -threads
*

!!! ERROR: dev-lang/php-5.1.4 failed.
Call stack:
ebuild.sh, line 1555: Called dyn_setup
ebuild.sh, line 668: Called pkg_setup
php-5.1.4.ebuild, line 79: Called php5_1-sapi_pkg_setup
php5_1-sapi.eclass, line 252: Called php5_1-sapi_check_use_flags
php5_1-sapi.eclass, line 190: Called phpconfutils_use_conflict 'sharedmem' 'threads'
phpconfutils.eclass, line 167: Called die

!!! Conflicting USE flags found
!!! If you need support, post the topmost build error, and the call stack if relevant.
[/quote]

User avatar
s717ch3s
Linux User
Posts: 10
Joined: Mon Jun 19, 2006 10:12 pm
Location: Florida
Contact:

-threads

Post by s717ch3s » Tue Jul 11, 2006 9:51 pm

[/code]pico -w /etc/make.conf

ensure that the Use="whatever" line has the word "threads" and it looks like "-threads" with the "-" symbol and without the quotes.
no animals were harmed in sending this message, although trillions of electrons were horribly inconvenienced...

satur9
Newbie
Posts: 3
Joined: Mon Jun 19, 2006 4:21 pm

Solved

Post by satur9 » Wed Jul 12, 2006 12:36 pm

I got it to work with:

$ USE="-threads" apache dev-lang/php

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests