"Service Xbox" Errors...

A place to ask all newbie questions and not get flamed, though you will get beaten down if you post a newbieish question outside of these walls.
Post Reply
Linux User
Posts: 11
Joined: Mon Jul 10, 2006 2:02 am

"Service Xbox" Errors...

Post by b8zs » Sat Jul 15, 2006 6:21 am

My friend sold me his xbox. I know nothing about modchips but he told me he flashed his with cromwell cause I told him I wanted to put linux on it. So If i wanted to play xbox games I could just hit the power button for a sec and if I wanted to boot to cromwell i would hold the power button for 2 secs.

I burned home 4.0 and booted off it, and the installation went fine. Then I ran magic right after home 5.0 was released,and it compiled some things that broke some functionality i needed. I then decided to just upgrade to home 5.0, instead of fixing all the broken apps.

I booted off the home 5.0 CD and it went through the install script. I selected the "F" parition as an installation destination, and the script said not enough room on F. I had thought it would just wipe it, but it didnt. So i rebooted it and this time opted to "initialise" my hardrive. I thought this would just delete all non-vital partitions. After this, the option to install on F disappeared and only E and Native were left. I tried E and it said not enough room, so finally I just choose native and it chugged away.

Unfortunatly now I cant boot into Microsofsts bios, because it says "You need to service your xbox"

Am I completely hosed or is there something I can do?

thanks for your help,


User avatar
Site Admin
Posts: 1973
Joined: Sun Aug 10, 2003 9:25 pm
Location: England

Post by ShALLaX » Sun Jul 16, 2006 1:48 am

Depends on the BIOS its booting. If you cant boot from a CD at all, you're pretty much screwed (have you tried holding the power button down as suggested by your friend?)... was it a soft mod? Worst comes to worst, you can always put a modchip in and externally flash it with Gentoox Loader.


Code: Select all

   echo "     Would you like to initialise your hard drive?  This will format"
   echo "     all partitions to FatX, you will lose all of your data.  Only use"
   echo "     this if your Xbox hard drive has become corrupt or you are upgrading"
   echo "     your hard drive."


   if [ $prepare = "yes" ]; then
      echo ""
      echo "       Are you sure?  ALL DATA WILL BE TOTALLY LOST ON YOUR HARD DRIVE."
      echo ""
      echo "       sure"
      echo "       cancel"
      echo ""
      echo -n "       Answer: "
I think that warning was pretty sufficient!
The original Xbox adaptation of Gentoo

Linux User
Posts: 11
Joined: Mon Jul 10, 2006 2:02 am

Post by b8zs » Mon Jul 17, 2006 1:15 am

well I can still boot into linux(thankfully)

I should have put more thought into the warning prompt that the initialse script gave me. What would have been a better way to just delete the F partition, and not the entire disk? A linux live-cd?

User avatar
Posts: 41
Joined: Sun Nov 06, 2005 7:57 pm
Location: United States

Post by roofus » Tue Jul 25, 2006 11:52 am

All these are found in the usual places:

PC tools for the xbox hard drive
http://www.xbox-scene.com/tools/tools.p ... =harddrive

There is a way to restore your dashboard for the Xbox but you might want to go looking in the xbox-scene forums for that. I do beleive it's one (or a few) of the softmod installers that do that. With only cromwell and the normal bios installed you may want to look into gamesave exploits, unless your friend can flash another bios on there for you.

Here's the place to start on xbox-scene:
http://forums.xbox-scene.com/index.php? ... owforum=18
If this is your first day and you're making your first post, you haven't spent enough time reading.

We were all noobs, once.

Post Reply

Who is online

Users browsing this forum: No registered users and 11 guests