did i kill my gentoox install ?

A place to ask all newbie questions and not get flamed, though you will get beaten down if you post a newbieish question outside of these walls.
Post Reply
shedt
Adept
Posts: 53
Joined: Mon Aug 02, 2004 7:20 pm

did i kill my gentoox install ?

Post by shedt » Tue Aug 03, 2004 4:37 am

I tried magic f-drive

everything seemed cool except for when it went to reboot.

it starts up and says it can't create some files, then says something like:

kernal panic: init failed

i can unrar the distro file back to my e, but i need to get this on f, i don't have any space for all my saves etc on my e, i had to transfer my tdata and udata.

can i restore this ? i got the feeling it is no...

where did i fail ?

shedt
Adept
Posts: 53
Joined: Mon Aug 02, 2004 7:20 pm

Post by shedt » Tue Aug 03, 2004 4:44 am

I did not login as root when i ran magic f-drive


i hope this is not a lesson that i will have to learn harshly....

i have a feeling i should start unrar'ing and getting ready for a night of magic

shedt
Adept
Posts: 53
Joined: Mon Aug 02, 2004 7:20 pm

Post by shedt » Tue Aug 03, 2004 4:58 am

it looks like it is trying to mount a rootfs file of the cdrom... i'll put my gentoox cd stardust in...

i doubt that will work.

this is some of the lines i am reading:


the last two lines:
/linuxxrc: cannot open dev/console: no such file or directory
kernal panic attempted to kill itit !

:(

shedt
Adept
Posts: 53
Joined: Mon Aug 02, 2004 7:20 pm

Post by shedt » Tue Aug 03, 2004 6:18 am

ok well i seem to have fixed it.

I renamed all of my files on e: that had "old" and took out the old, and changed the names of the other files so they are ***.broke

and then i changed my linuxboot.cfg file too this:

append init=/linuxrc root=/dev/ram0 kbd-reset video=xbox:800x600,nohwcursor,hoc=0mvoc=0


this is what i found when i searched the forums for linuxboot.cfg

the screen size is kinda messed up when its starting up, i can't see the green ok's, and when i move my onscreen keyboard around its kinda wierd...


i had to re-set my fonts in xfce...

I'm going to compare the linuxboot.cfg with the one magic was using to transfer over rootfs to my f:

is there a way to get back my old one, or get it as close too it as it should be?

I feel a bit uneasy, but everything else seems fine...

i still have to find out how to magic f-drive, but i feel better knowing i did not screw up that bad...

as far as i know

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests