Page 1 of 1

nvxbox Problem

Posted: Fri May 15, 2009 4:22 am
by Wrostek
I installed pro 5.1, and emerged something that required x as a dependency. It installed xorg-x11-7.2 and xorg-server-1.5.3-r5. After the emerge was completed, I ran magic and attempted to install xfce4. When I run startxfce4, at the point where it loads, it gives the error

dlopen: /usr/lib/xorg/modules/drivers// undefined symbol: xf86errno .

I believe the reason for this is that ( which I believe is a pre-compiled binary from the magic repository 553091 bytes ) is for an earlier version of xorg-server. I have been trying to find out what version of xorg-server I should have installed to get it to work, is it xorg-server-1.4 or something even earlier?

Any help is appreciated!

Re: nvxbox Problem

Posted: Tue May 26, 2009 5:25 am
by Wrostek
Excellent, I ended up downloading the home 7.1 cd, just to mount the file system and check out the version of xorg-server Shallax is using.
It was xorg-server- So to all those Pro 5.1 users like me, that run magic and expect to be able to emerge xserver, you must add the line


to /etc/portage/package.mask before doing so, to ensure that the xserver will run with the provided . Amazing, so X is working, I managed to get mythtv-0.21 emerged, and im trying to get it running as a front end, but im having big video problems. Anyone know if its possible to get xbox to decode xvmc? Or what decoder is the best suited to xbox?

Re: nvxbox Problem

Posted: Sat May 30, 2009 5:20 pm
by ShALLaX
Weird, I'd had no nvxbox driver issues with Pro. Well done for sorting it out, though!