Problems emerging gcc-4.1.2

Ask questions regarding Gentoox, Gentoo and Linux in general in these forums and we'll do our best to help you!
Post Reply
User avatar
clpalmer
Power user
Posts: 288
Joined: Sat Jan 29, 2005 6:38 pm

Problems emerging gcc-4.1.2

Post by clpalmer » Wed May 23, 2007 3:01 am

Anyone else have issues with it freezing when emerging gcc-4.1.2? It seems to start compiling fine and then just hangs at:

Code: Select all

  transformation: 0.040000, building DFA: 44.130000
  DFA minimization: 1.630000, making insn equivalence: 0.000000
 all automaton generation: 46.350000, output: 0.300000
/bin/sh /var/tmp/portage/sys-devel/gcc-4.1.2/work/gcc-4.1.2/gcc/../move-if-change tmp-attrtab.c insn-attrtab.c
insn-attrtab.c is unchanged
echo timestamp > s-attrtab
stage1/xgcc -Bstage1/ -B/usr/i686-pc-linux-gnu/bin/   -march=pentium3 -O2 -pipe -fprofile-generate -DIN_GCC   -W -Wall -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes -pedantic -Wno-long-long -Wno-variadic-macros -Wold-style-definition -Wmissing-format-attribute     -DHAVE_CONFIG_H -I. -I. -I/var/tmp/portage/sys-devel/gcc-4.1.2/work/gcc-4.1.2/gcc -I/var/tmp/portage/sys-devel/gcc-4.1.2/work/gcc-4.1.2/gcc/. -I/var/tmp/portage/sys-devel/gcc-4.1.2/work/gcc-4.1.2/gcc/../include -I/var/tmp/portage/sys-devel/gcc-4.1.2/work/gcc-4.1.2/gcc/../libcpp/include     -c insn-attrtab.c \
          -o insn-attrtab.o
It's been sitting there for a solid hour or so, but the ccl process still shows using 0-5% of CPU. Dunno if it just takes forever to finish that step or what. Gonna try leaving it overnight. Just wondered if anyone else saw similar issues or knows if that's normal.

User avatar
ShALLaX
Site Admin
Posts: 1973
Joined: Sun Aug 10, 2003 9:25 pm
Location: England
Contact:

Post by ShALLaX » Tue May 29, 2007 11:16 am

How much RAM usage is there? Is your swap working?
The original Xbox adaptation of Gentoo

User avatar
clpalmer
Power user
Posts: 288
Joined: Sat Jan 29, 2005 6:38 pm

Post by clpalmer » Tue May 29, 2007 2:57 pm

I was getting that a lot on my pro install. I only had 64MB on that box and it seemed to freeze a lot when compiling. The process would show like 70+% of memory usage and just stall there for ages. Sometimes it'd get past it and sometimes after hours and hours or waiting I'd kill it and start again with --resume. Occasionally it'd work, sometimes it'd fail again. Sometimes emerging an earlier version and then the new version worked.

If I recall, gcc was one of the culprits and I had to leave it overnight to get past one spot (which it did). Zsnes was another one that never did complete until I emerged a previous version first (tried the latest one many times and left it for many hours). MythTV never did emerge for me.

I've since given up and left gentoox to my main server and went with xbmc on the front end. I know, I know, flame away. It's not linux and it's not legal, but it's way faster, performs better, is geared to the xpad better and things like the emulators are actually playable, which they weren't in X (at least not with 64MB RAM)

Post Reply

Who is online

Users browsing this forum: No registered users and 7 guests