Page 1 of 1

Getting error.

Posted: Tue May 15, 2007 7:25 pm
by chrisb
When Im follow the native guide, and after I have copyed the rootfs to the box, and mounted it, Ill start copying the content.

# cp -a /mnt/loopback/* /mnt/hda2

I get this error aften some time (on the Xbox screen)
_alloc_pages: 0-order allocation failed (gfp=0x92/0)

What is it? Is my HD dead?
What can I do?

Posted: Thu May 17, 2007 9:46 pm
by clpalmer
I also noticed this issue. It ended up crashing my box every time I went to copy. The way I solved it is to go into the loopback file system and copy directory by directory. Start with the high level ones and maybe several at a time or you'll go crazy typing the copy command too much =)

If it crashes, remember which directories you were copying, reboot, delete them from the new partition and restart the copy. I found that I narrowed it down to a couple problematic directories at a lower level, but once I tried to copy them individually at a deep enough level they worked fine.

Dunno what caused it, but I ended up getting the whole file system on there ok so I didn't look into it.

Posted: Fri May 18, 2007 9:32 am
by chrisb
Well, On a little 20GB disk I didt not had that error.
But this time I did the installarion on wire, means that all the maskine was hooked up with LAN cable. Normaly I didt it with the box and wire, and my Laptop on Wlan..

Maybe there is something there..

Posted: Tue May 22, 2007 3:24 am
by clpalmer
Getting the same problems when I try to do it with Home on my 2nd box (the other time was with Pro on my 1st box). When it freezes, I get this in ps:

Resctoox:> ps auxw
PID Uid VmSize Stat Command
1 root 40 S init
2 root SW [keventd]
4 root SWN [ksoftirqd_CPU0]
3 root SW [xbox_extsmi]
5 root SW [kswapd]
6 root SW [bdflush]
7 root Z [kupdated]
9 root SW [xbox_extsmi]
10 root SW [khubd]
13 root SW< [mdrecoveryd]
17 root SW [krfcommd]
20 root 40 S init
21 root 128 S /bin/sh /etc/rc.d/rc.S
24 root 168 S /sbin/syslogd
27 root 212 S /sbin/klogd -c 3
332 root 72 S /usr/sbin/sshd
335 root Z [oftpd]
338 root 96 S /bin/oftpd -p 21 root /
339 root 96 S /bin/oftpd -p 21 root /
340 root 96 S /bin/oftpd -p 21 root /
341 root 96 S /bin/oftpd -p 21 root /
342 root 408 S /usr/sbin/sshd
345 root 48 S /bin/joymouse -d -i /dev/input/js0 -t joystick
348 root 52 S /usr/sbin/gpm -m /dev/input/mice -t ps2
350 root 408 S /usr/sbin/sshd
390 root 404 S -sh
407 root 256 S -sh
421 root SW [kjournald]
423 root SW [kjournald]
487 root Z [loop0]
488 root Z [loop0]
489 root Z [loop0]
490 root Z [loop0]
491 root Z [loop0]
492 root Z [loop0]
493 root Z [loop0]
494 root Z [loop0]
495 root Z [loop0]
496 root Z [loop0]
497 root SW [loop0]
498 root SW [kreiserfsd]
507 root 628 D cp -a libexec ../../hda2/usr/
509 root 192 S sleep 100
510 root 656 R ps auxw

Dunno what the "sleep 100" is... It's a pain in the ass, though. Have to copy a tiny bit till it freezes, reboot, copy a bit more, reboot, etc.

Posted: Tue May 22, 2007 4:23 am
by clpalmer
cheeseboofs: You done a native install on one of the latest releases of pro/home and seen any issues like this?

Posted: Tue May 22, 2007 9:26 pm
by cheesyboofs
Just done a pro 4.2 install prior to updating the TUT on a 6.7 bios all was fine but I'm not happy with the 6.7 BIOS looks buggy to me (probably not a result of what your seeing) so I asked shallax if he could send me 6.6 so I could see if the problems where there but he told me to copile it myself, but I don't know how!

Posted: Wed May 23, 2007 1:16 am
by clpalmer
I assume you can just download the sources and compile the project on your box. There's a makefile in there so have a go at "make all" and see what happens =)