I broke emerge

Ask questions regarding Gentoox, Gentoo and Linux in general in these forums and we'll do our best to help you!
Post Reply
Movax
Newbie
Posts: 1
Joined: Sat Sep 16, 2006 1:51 pm

I broke emerge

Post by Movax » Sat Sep 16, 2006 1:54 pm

Any ideas? I tried my friend google and came up with nothing:

Code: Select all

Traceback (most recent call last):
  File "/usr/bin/emerge", line 12, in ?
    import portage
  File "/usr/lib/portage/pym/portage.py", line 7235, in ?
    init_legacy_globals()
  File "/usr/lib/portage/pym/portage.py", line 7201, in init_legacy_globals
    mtimedb = load_mtimedb(f)
  File "/usr/lib/portage/pym/portage.py", line 7126, in load_mtimedb
    d = mypickle.load()
cPickle.UnpicklingError: invalid load key, 'A'.
I can type emerge <anything I want here, doesn't matter> and I get the same thing after a delay of about 2-3 seconds.

Should I just reinstall gentoox?

orochi
Gentoox Guru!
Posts: 606
Joined: Sun Oct 24, 2004 8:11 am

Post by orochi » Sun Sep 17, 2006 5:53 am

run magic, say yes to run emerge --sync, and try again

dopey
Novice
Posts: 47
Joined: Tue Apr 18, 2006 11:24 pm

Post by dopey » Tue Sep 19, 2006 4:16 am

Did you resolve this?

If emerge --sync doesn't work, you could try to use a protage snapshot instead (see install handbook).

What did you do that broke emerge? I'm not judging (believe me I broke things more than I can count), I just need some background information before I can give a solid solution.

Post Reply

Who is online

Users browsing this forum: No registered users and 15 guests