Samba shares not complying with the access rights.

Ask questions regarding Gentoox, Gentoo and Linux in general in these forums and we'll do our best to help you!
Post Reply
000g
Novice
Posts: 20
Joined: Sun Oct 02, 2005 2:15 pm

Samba shares not complying with the access rights.

Post by 000g » Sun Aug 06, 2006 1:19 am

I have numerous shares within my Samba server.

I had them all set so that only I had read/write access, everyone else only had read access.

Now I have 2 roomates, and I'd like to give them access to their own folders on the server. So they can put whatever they want on the thing.

However, when I do this, and I grant them read/write access, they're still not able to write to the given folders.

I'm stumped.

Usernames:
Me = Root
They = Gentoox

Here's a screenshot of what I'm dealing with.
Image

User avatar
ShALLaX
Site Admin
Posts: 1973
Joined: Sun Aug 10, 2003 9:25 pm
Location: England
Contact:

Post by ShALLaX » Sun Aug 06, 2006 1:34 pm

Is /mnt/fatx/g mounted with umask=0000 ?
The original Xbox adaptation of Gentoo

000g
Novice
Posts: 20
Joined: Sun Oct 02, 2005 2:15 pm

Post by 000g » Sun Aug 06, 2006 3:13 pm

ShALLaX wrote:Is /mnt/fatx/g mounted with umask=0000 ?
I have no idea. I'm at work right now. I'll check that when I get home tonight.

However, not all of the shares are on the G drive. In fact, if my memory serves me correctly, I think the "Craig" and "Jeremy" shares are on the F drive.

(thanks for the reply)

User avatar
ShALLaX
Site Admin
Posts: 1973
Joined: Sun Aug 10, 2003 9:25 pm
Location: England
Contact:

Post by ShALLaX » Sun Aug 06, 2006 3:56 pm

Theyre on "g" according to your screenshot. If theyre not, then you have your shares setup to point to the wrong path... hence your error.
The original Xbox adaptation of Gentoo

000g
Novice
Posts: 20
Joined: Sun Oct 02, 2005 2:15 pm

Post by 000g » Sun Aug 06, 2006 4:07 pm

ShALLaX wrote:Theyre on "g" according to your screenshot. If theyre not, then you have your shares setup to point to the wrong path... hence your error.
lol. A guy here at work just called me out on the fact that the folders are on the G drive (as per the screenshot).

I guess my memory didn't serve me correctly.

The share paths are correct. I was just wrong as to which drive the folders were located on.

000g
Novice
Posts: 20
Joined: Sun Oct 02, 2005 2:15 pm

Post by 000g » Sun Aug 06, 2006 6:26 pm

ShALLaX wrote:Is /mnt/fatx/g mounted with umask=0000 ?
Ok. You got me. I have no idea how to check this.

I tried looking in hardware tab, and then into "Partitions on local disks". But it didn't show me this info.

Where should I be looking?

On a side note. I just attempted to give the usernames "Gentoox", and "root", read/write capabilities to the "My Programs" folder (which is located on the F drive), and I got the same results. I can read/write with the "root" username, but not the "Gentoox" username.

User avatar
ShALLaX
Site Admin
Posts: 1973
Joined: Sun Aug 10, 2003 9:25 pm
Location: England
Contact:

Post by ShALLaX » Mon Aug 07, 2006 5:07 pm

You should be looking in /etc/fstab for the umask options.

Have you restarted samba since configuring it? Id stop using Webmin, if I were you. Configure it through SSH.
The original Xbox adaptation of Gentoo

000g
Novice
Posts: 20
Joined: Sun Oct 02, 2005 2:15 pm

Post by 000g » Mon Aug 07, 2006 7:27 pm

ShALLaX wrote:You should be looking in /etc/fstab for the umask options.

Have you restarted samba since configuring it? Id stop using Webmin, if I were you. Configure it through SSH.
Yes. I've restarted the Samba server. I do that after every change.

I don't have a TV hooked up to this Xbox. Everything I've ever done to it, as far as settings and what-not, has been done through the WebMin.

This is what my ect/fstab file looks like.

Code: Select all

# /etc/fstab: static file system information.
#
# <file system>         <mount point>   <type>          <options>                               <dump>  <pass>
/dev/hda2             /               reiserfs        defaults,errors=remount-ro              0    1
proc                    /proc           proc            defaults                                0    0
/dev/cdrom              /mnt/cdrom      iso9660         defaults,ro,user,noauto                 0    0
/dev/hda1        none            swap            sw                                      0    0

/dev/hda51		/mnt/fatx/c 	fatx 		defaults,noauto,umask=022 		0 	0
/dev/hda50		/mnt/fatx/e 	fatx 		defaults,umask=0000	 		0 	0
/dev/ide/host0/bus0/target1/lun0/part1  /mnt/fatx/g  ext2  suid,dev,exec  0  0

User avatar
ShALLaX
Site Admin
Posts: 1973
Joined: Sun Aug 10, 2003 9:25 pm
Location: England
Contact:

Post by ShALLaX » Mon Aug 07, 2006 9:32 pm

SSH is a remote access protocol (google.com)

Why in gods name have you mounted a second hdd under "fatx/g". Its NOT g drive and it is certainly NOT fatx - its ext2 from the looks (why are you using ext2?!). You've been misleading me by suggesting it is a fatx partition. Your problem is probably just that you havent chmod'ed or chown'ed the appropriate directories on your secondary hdd.
The original Xbox adaptation of Gentoo

000g
Novice
Posts: 20
Joined: Sun Oct 02, 2005 2:15 pm

Post by 000g » Tue Aug 08, 2006 5:04 am

The why question can only be answered by saying, "Becuase it works that way". I have no idea what I clicked when I first installed the second HDD.

And forgive my ignorance, but how is the second HDD not a "G" drive?

C: MS
D: DVD
E: MS
F: Linux
G: 2nd HDD

I do see how it shouldn't be a FatX partition. However, neither should the "F" drive. This was a native install.

And if the reason the access rights aren't working properly is because of the way I mounted the second HDD, then why aren't the shares on the "F" drive complying? Because I had this same problem when I had only 1 HDD.

Here's a screenshot of my "partition manager".
Image

User avatar
ShALLaX
Site Admin
Posts: 1973
Joined: Sun Aug 10, 2003 9:25 pm
Location: England
Contact:

Post by ShALLaX » Tue Aug 08, 2006 8:11 am

Its not a G drive because there is no concept of drive lettering in Linux.

The problem isnt with how youre mounting the drive. The problem is more likely to be permissions on the individual folders (like I already said).
The original Xbox adaptation of Gentoo

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests