Xorg 7 and xbox

Ask questions regarding Gentoox, Gentoo and Linux in general in these forums and we'll do our best to help you!
Post Reply
dopey
Novice
Posts: 47
Joined: Tue Apr 18, 2006 11:24 pm

Xorg 7 and xbox

Post by dopey » Mon Jul 10, 2006 2:49 am

I know this isn't really a gentoox bug, but it affects it. . .

Has anyone tried syncing lately? Xorg 7 has went stable for x86, including the xbox. However, the xbox video driver patch hasn't made it over (I learned that the hard way). Does anyone know how to get this working on th xbox?

In the mean time I just backed out of the upgrade by replacing portage with a really old snapshot I had. First I tried to just mask Xorg 7.0, but that doens't seem possible as once that went stable everything else seems to depend on it (including some system packages) and masking those isn't an option as they deleted the packages that don't require it.

Now that I got my system back in a semi-stable state, I re-synced back to current portage snapshot, so I can try to upgrade what I can without upgrading Xorg, but it seems the way the tree is now even that is daunting.

Can anyone shed some light on this? It's extremely annoying. . .

dopey
Novice
Posts: 47
Joined: Tue Apr 18, 2006 11:24 pm

Post by dopey » Sun Jul 23, 2006 9:34 pm

Wow, almost 2 weeks without a reply. Am I the only one with this problem? Am I doing something wrong?

User avatar
ShALLaX
Site Admin
Posts: 1973
Joined: Sun Aug 10, 2003 9:25 pm
Location: England
Contact:

Post by ShALLaX » Thu Jul 27, 2006 3:01 pm

Checking the website frequently is a good idea. This was put to rest on the 19th of July.

Its also not a "bug".
The original Xbox adaptation of Gentoo

dopey
Novice
Posts: 47
Joined: Tue Apr 18, 2006 11:24 pm

Post by dopey » Fri Jul 28, 2006 7:16 am

I was hesitant to put it in as a "bug" as I it really wasn't a gentoox problem, but it did cause some rather serioys issues. . . my bad.

Thanks for the patches. Sorry I missed the news updated; I guess I just assumed this thread would have gotten more attention if others were experiencing the problem.

BTW, how did you get the driver to compile? I see the patch is to include the already compiled driver. Is it compiled against a seperate version of X or did you update the xbox patches?

Thanks again.

User avatar
ShALLaX
Site Admin
Posts: 1973
Joined: Sun Aug 10, 2003 9:25 pm
Location: England
Contact:

Post by ShALLaX » Fri Jul 28, 2006 12:48 pm

Its a special driver written for the Xbox. Its on the Xbox-Linux CVS written by Ed.
The original Xbox adaptation of Gentoo

dopey
Novice
Posts: 47
Joined: Tue Apr 18, 2006 11:24 pm

Post by dopey » Sat Jul 29, 2006 5:38 am

Cool, thanks again. Now I know where to look when this happens again.

dopey
Novice
Posts: 47
Joined: Tue Apr 18, 2006 11:24 pm

Post by dopey » Mon Oct 16, 2006 2:30 am

Ok, I tried and I tried, but I could not compile the CVS version of the driver against the new Xorg. I did manage to build the driver, but it's ended up only being 76K and would not work.

Right now I just masked the following packages to keep the old version of Xorg. Hopefully, we can get an updated nvxbox driver soon.

=x11-base/xorg-server-1.1.1-r1
=x11-base/xorg-x11-7.1
=x11-drivers/xf86-input-keyboard-1.1.0
=x11-drivers/xf86-input-joystick-1.1.0
=x11-drivers/xf86-input-mouse-1.1.1

gnif
Novice
Posts: 42
Joined: Wed Sep 13, 2006 2:07 pm

Post by gnif » Thu Nov 16, 2006 1:02 am

I have built the nvxbox driver for xorg without issues...

It was a while ago, but it does compile and work... I think I wrote some doco somewhere on how to do it (check the xboxlinux wiki)

The size seems about right, you just have to make sure you replace the old driver completly.

dopey
Novice
Posts: 47
Joined: Tue Apr 18, 2006 11:24 pm

Post by dopey » Thu Nov 23, 2006 7:04 am

I couldn't find that howto. I'm pretty sure I compiled it correctly and fully installed it though. Xorg did report the nvxbox driver as the new version compiled against the new version of Xorg.

Did you compile it against 7.1, as that was what I was having trouble with?

It could be that I just grabed the CVS copy at the wrong point in time...

User avatar
ShALLaX
Site Admin
Posts: 1973
Joined: Sun Aug 10, 2003 9:25 pm
Location: England
Contact:

Post by ShALLaX » Thu Nov 23, 2006 7:30 am

I'm pretty certain all the drivers are in magic. You should only need to run magic, then emerge xorg.
The original Xbox adaptation of Gentoo

gnif
Novice
Posts: 42
Joined: Wed Sep 13, 2006 2:07 pm

Post by gnif » Sat Nov 25, 2006 11:04 am

dopey: Yes, was against 7.1. I have a feeling I had to modify a line or two in the driver to make it work... nothing major though.

Attach the output of the compile attempt, I will see if I can figure it out for you.

dopey
Novice
Posts: 47
Joined: Tue Apr 18, 2006 11:24 pm

Post by dopey » Mon Nov 27, 2006 3:49 am

ShALLaX, I havent' really tried in a while so you might be right. At the time 7.1 drivers weren't available. I'll see if I can upgade X again and use the drivers in the magic repository.

gnif, if that doesn't work I'll try to recompile, but there weren't any compile time errors when I tried the first time; it just didn't work once compiled...

Please note that I'm aswering this at the end of a holiday weekend so I'm probably not going to be able to get to this during the week; it'll will probably have to wait untill next weekend...

dopey
Novice
Posts: 47
Joined: Tue Apr 18, 2006 11:24 pm

Post by dopey » Sat Dec 02, 2006 1:36 pm

ShALLaX, the nvxbox driver in the magic repository is for Xorg 7.0 and as such doesn't work with the currently stable Xorg 7.1.

gnif, I'm not sure why, but when I tried again it compiled perfectly fine. It works like a charm! I'm now running Xorg 7.1 on my Xbox!

For those of you who can't get Xorg 7.1 going I hosted the compiled driver for you to use. Once you compile Xorg 7.1 (it finishes upgrading) delete the file /usr/lib/xorg/modules/drivers/nvxbox_drv.o, download nvxbox_drv.so.bz2, then extract that file to /usr/lib/xorg/modules/drivers/. You should be good to go after that.

ShALLaX, I know you are rather busy these days, but is there any chance of you updating the Magic repository with the updated driver? I realize this one isn't as easy as copying the new driver over; since the naming convension is slightly different I think you'll also have to update some box files as well... I think...

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests