Upgrading to Kernel 2.6xx on a loopback install?

Ask questions regarding Gentoox, Gentoo and Linux in general in these forums and we'll do our best to help you!
Post Reply
raid517
Novice
Posts: 40
Joined: Fri Jul 02, 2004 6:00 am

Upgrading to Kernel 2.6xx on a loopback install?

Post by raid517 » Sat May 13, 2006 7:07 am

Hi, is it possible to upgrade to a 2.6xx kernel when Gentoox has been installed on my E partition as a loopback install?

If so, how can this be achieved? Does anyone have any tips or instructions for doing this? (i can handle the kernel compile - it's how to install the kernel on a loppback install that is confusing me.

GJ

orochi
Gentoox Guru!
Posts: 606
Joined: Sun Oct 24, 2004 8:11 am

Post by orochi » Sat May 13, 2006 7:50 am

use the search function

raid517
Novice
Posts: 40
Joined: Fri Jul 02, 2004 6:00 am

Post by raid517 » Sat May 13, 2006 2:18 pm

Oh you are real helpful you are.

I did. I found nothing specific. Clearly you 'l33t' searching skills are better than mine.

Why waste your energy hitting the reply button if you couldn't be bothered replying?

GJ

raid517
Novice
Posts: 40
Joined: Fri Jul 02, 2004 6:00 am

Post by raid517 » Mon May 15, 2006 5:47 am

OK I know people are going to tell me I haven't searched, but I have searched my butt off.

Here Is the first search i did:

search.php?mode=results

search.php?mode=results

http://gentoox.shallax.com/

http://shallax.com:2000/

http://gentoox.shallax.com/modules.php? ... es&secid=3

http://gentoox.shallax.com/modules.php? ... es&secid=2

My searching skills must really, really suck or something, but please can anyone point me to anywhere in that list where it discusses how to specifically upgrade to a 2.6x kernel on a loopback install?

I have no problem with compiling the kernel, that isn't an issue for me. I just need to know what is required to sucessfully upgrade to 2.6x kernel wbhen Gentoox is installed on my e:drive as a loopback file.

As for not searching - I have pretty much been searching solidly for the last 3 days - but have had no luck at all. There was some vague talk about upgrading to 2.6x via Magic - but it seems 2.6 was pulled from Magic a long time ago. (Yes I know there was some fatx issues - but the Xbox Linux developers have had a lot of time to work on this issue since then).

GJ

orochi
Gentoox Guru!
Posts: 606
Joined: Sun Oct 24, 2004 8:11 am

Post by orochi » Mon May 15, 2006 8:31 am

Wow, your rather rude for someone who is asking for help.


Upgrading to 2.6 is not reliable at this point. The fatx driver is quite buggy for the newer kernels. But if you want to still upgrade here would be some info to look at


viewtopic.php?t=2791

http://gentoox.shallax.com/modules.php? ... le&sid=411

http://cvs.xbox-linux.org/viewcvs.py/xb ... 6&view=log

And to the best of my knowledge the script that was run to do this automatically was

http://shallax.com:2000/b0x/kernel-patch2611000.b0x


And no im not "leet", and I dont have a "root user" complex, I frequent this forum to learn more about Linux and Linux on the xbox and in turn to try and help others with their problems. My apologies if my response was harsh but the information I found was from the very links you posted.

If you still wish to try the 2.6 kernel, please backup your data the fatx driver is undeveloped for almost a year and is still rather buggy.

raid517
Novice
Posts: 40
Joined: Fri Jul 02, 2004 6:00 am

Post by raid517 » Tue May 16, 2006 12:38 am

Lol sorry. Although I don't think it's rude when it is easy enough to post a link if you are going to expend the time and energy posting anyway?

In any case as I said, thanks very much for the tip.

Unfortunately that script is very old - if I ran this it would probably try to install a 2.6.11x kernel - which isn't useful for a lot of things (such as UDEV and inotify) which a lot of modern apps depend on.

However I do have an officially patched 2.6.16.5 kernel from the xbox linux project - and I rather wondered what the best way to impliment this would be?

I also wondered if in all of the time that had passed if the Xbox Linux team had had the chance to fix the fatx driver on the 2.6xx kernel - and whether or not any improvements had been made?

GJ
Last edited by raid517 on Fri May 19, 2006 8:12 am, edited 1 time in total.

orochi
Gentoox Guru!
Posts: 606
Joined: Sun Oct 24, 2004 8:11 am

Post by orochi » Tue May 16, 2006 5:16 am

I dont think there is anyone activly maintianing fatx driver for 2.6(maybe 2.4)


I had tried magic in the past (when it would force you to upgrade to 2.6) it did it with no problem, so although it is old you should still be able to follow it (with the exception of compiling your own kernel) and it should do. But eh, 2.4 is good enough for me :P

raid517
Novice
Posts: 40
Joined: Fri Jul 02, 2004 6:00 am

Post by raid517 » Tue May 16, 2006 11:03 pm

OK, thanks. Maybe I will just knock 2.6x on the head and forget about it. What about 2.4.32? Can Magic handle installing this in a loopback install - or is there something else I must do? I still seem to be booting a 2.4.2x kernel even after doing a magic update.

Again if there is a tutirial covering what i need to do, I would be happy to read it.

GJ

cliusn76
Newbie
Posts: 1
Joined: Sat May 13, 2006 12:20 pm
Contact:

Post by cliusn76 » Wed May 17, 2006 2:37 am

oh,very good. thanks!
i have searched anything about upgrading to kernel 2.6 several days.

orochi
Gentoox Guru!
Posts: 606
Joined: Sun Oct 24, 2004 8:11 am

Post by orochi » Wed May 17, 2006 8:35 am

magic will update to 2.4something when running magic which is kinda a pain, but what do you need that comes with 2.4.32 that the current installed kernel doesnt have?

raid517
Novice
Posts: 40
Joined: Fri Jul 02, 2004 6:00 am

Post by raid517 » Fri May 19, 2006 8:07 am

Some major security fixes for a start.

2.4.22 is so full of holes you could fit a jumbo jet through it.

Anyway apparently we are back to the same old question... It doesn't seem that magic does update to anything higher than 2.4.22 on a loopback install - it might do it on a native install - but it doesn't appear to work on a loopback install.

GJ

orochi
Gentoox Guru!
Posts: 606
Joined: Sun Oct 24, 2004 8:11 am

Post by orochi » Fri May 19, 2006 9:22 am

if you patch in fatx drivers you can use whatever kernel you want

raid517
Novice
Posts: 40
Joined: Fri Jul 02, 2004 6:00 am

Post by raid517 » Fri May 19, 2006 10:22 am

...

NM...

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests