Magic X-Server with Gentoox Pro

Ask questions regarding Gentoox, Gentoo and Linux in general in these forums and we'll do our best to help you!
Post Reply
tt67s
Newbie
Posts: 3
Joined: Sat Feb 25, 2006 10:15 pm

Magic X-Server with Gentoox Pro

Post by tt67s » Sat Feb 25, 2006 10:29 pm

Hello,
I Magic' ed and decide to install X-Server on my brand new Gentoox Pro Installation.
But How to disable the X-Server Start on boot?
I want to start the X-Server Manually by typing "startx" after a login.

Why i wanted to do that?
Because i discovered my old PC feeling with Gentoox.
Thats why a Linux Beginner like me uses Gentoox Pro.
I want to know the System, where the Gui is screwed in.

Like in good old Windows for Workgroups days with my Dos Knowledge.

I started to use Lftp and IRSSI and........... I loveit.

The Console is great but the beginning is very hard.
There is no autoexec.bat or config.sys :-)
As you see i couldnt find the surely simple "startx" in Boot Config files. Am I right?

And by the way, thanks for that nice Ported Distro.

vplayer
1337
Posts: 442
Joined: Thu Oct 07, 2004 11:06 pm
Location: USA

Post by vplayer » Sun Feb 26, 2006 12:04 am

there is no autoexec.bat or config.sys cause this is linux.

But you always have a search button on this forums that is more helpful than autoexec.

Just do a search for startx and you surely should find the answer
Box: XBOX ver 1.1
Mod: Xecutor 2.3 lite+
Hdd: WD 80GB
Dash: Evox, Ava, XBMC
Linux: Gentoox Pro 4.2

kaos_engr
Novice
Posts: 22
Joined: Sun Apr 25, 2004 10:41 pm

Stop Xserver from starting on bootup

Post by kaos_engr » Sun Feb 26, 2006 1:42 am

Edit /etc/conf.d/local.start

At the end of local.start locate and comment out the lines as shown below
use nano editor, or vi whatever you like. To comment out a line in this file add a # as the first character in that line. There are 6 lines to add the '#' as the lead character then save and reboot.

===Following taken from /etc/conf.d/local.start===

echo -e " Your network settings are as follows:\n \033[01;31meth0:\033[01;34m" > /tmp/eth0.addr && ifconfig | grep inet -m1 >> /tmp/eth0.addr && cat /tmp/eth0.addr
echo -en "\033[00m\n"

#if [ -f /usr/bin/gdm ]; then
# echo -n "Starting X" && sleep 1 && echo -n "." && sleep 1 && echo -n "." && sleep 1 && echo -n "." && sleep 1 && echo -n "." && sleep 1 && echo -n "."
#fi

/bin/led gggg
#if [ -f /usr/bin/gdm ]; then
# /usr/bin/gdm 1> /dev/null 2> /dev/null
#fi
chmod 777 /dev/dsp
rm -rf /root/.runningmagic 1> /dev/null 2> /dev/null

===End of /etc/conf.d/local.start===

kaos_engr

User avatar
BigBowser
Novice
Posts: 20
Joined: Wed Jan 12, 2005 2:35 pm
Location: France
Contact:

Post by BigBowser » Mon Feb 27, 2006 7:59 am

Just move default init from 5 to 3 :) -> /etc/inittab

Bye
Modérateur Forum Ominfo.com
Image

tt67s
Newbie
Posts: 3
Joined: Sat Feb 25, 2006 10:15 pm

Default init was still 3

Post by tt67s » Mon Feb 27, 2006 10:04 am

The default init still was 3.
The tip Before with the # before the lines worked very well, thanks.

But i still with "Search words" didnt find the answer on another topic in this forum.

User avatar
ShALLaX
Site Admin
Posts: 1973
Joined: Sun Aug 10, 2003 9:25 pm
Location: England
Contact:

Post by ShALLaX » Fri Mar 03, 2006 1:48 am

Changing inits wont work, for future reference.
The original Xbox adaptation of Gentoo

kaos_engr
Novice
Posts: 22
Joined: Sun Apr 25, 2004 10:41 pm

Post by kaos_engr » Sat Mar 04, 2006 12:15 am

Gentoo(X) doesn't use runlevels like other other Linux Distributions.

You setup /etc/runlevels/<name e.g. default>/<with links to scripts in /etc/init.d to startup>. You can add your own named runlevel and configure your startup requirements. Next, set the runlevel name for the startup level (lN) in /etc/inittab Levels l0-l7 are available, some have a specific function like l0 for shutdown, l1 single user and l6 for reboot. You can configure the others l3-l5

and set the defaultrunlevel in /etc/inittab

Pieces cut from /etc/inittab
======================================

id:3:initdefault:

# Further system initialization, brings up the boot runlevel.
rc::bootwait:/sbin/rc boot

l0:0:wait:/sbin/rc shutdown
l1:S1:wait:/sbin/rc single
l2:2:wait:/sbin/rc nonetwork
l3:3:wait:/sbin/rc default
l4:4:wait:/sbin/rc default
l5:5:wait:/sbin/rc default
l6:6:wait:/sbin/rc reboot
#z6:6:respawn:/sbin/sulogin
===========================================
l3-l5 are all set the same in GentooX. To configure different levels setup a new /etc/runlevel directory and add the startup items you want for that level and adjust the lN entry to call that new runlevel configuration.

--
kaos_engr

Post Reply

Who is online

Users browsing this forum: No registered users and 8 guests