Fanctl ignores /etc/config.d/fanctl

Ask questions regarding Gentoox, Gentoo and Linux in general in these forums and we'll do our best to help you!
Post Reply
Elect
Newbie
Posts: 3
Joined: Wed Nov 30, 2005 12:34 pm
Contact:

Fanctl ignores /etc/config.d/fanctl

Post by Elect » Wed Nov 30, 2005 10:20 pm

Waited quite some time in the IRC channel. Had to go, sorry bout that...

My question;

I don't think fanctl uses the config file in /etc/config.d/fanctl. I started fanctl as a deamon by 'rc-update add fanctl'. I have the config rewritten so I should see some difference. When I reboot my xbox 'xboxtemp' gives me the following:

CPU temperature: 38 °C - 100 °F
Board temperature: 43 °C - 109 °F
Fan speed: 20%

And 'rc-update show' says that the fanctl deamon should run..
fanctl | default nonetwork

Couple of minutes later, xboxtemp gives me the following:

CPU temperature: 37 °C - 98 °F
Board temperature: 43 °C - 109 °F
Fan speed: 36%

A lower cpu temp, but higher fanspeed? Don't get it. The poll interval is the same for fanspeed and temperature, isn't it?

My fanctl config
###
# Idle system temperature (°C/°F):
# DreamX: Set to 60
# Default: 45
###
IDLE_TEMP=60

###
# Critical CPU temperature at which the Xbox should power off (°C/°F):
# DreamX: Set to 80
# Default: 70
###
CPU_SHUTDOWN=75

###
# Critical board temperature at which the Xbox should power off (°C/°F):
# DreamX: Set to 65
# Default: 60
###
BOARD_SHUTDOWN=60

###
# Verbosity level:
# Default: 0
# Allowed values: 0, 1, 2
# 0 = no syslogging except on startup and when -f is used
# 1 = Initial settings output on run.
# 2 = As above + syslog entries each time the fan speed changes by + 3% from
# last poll.
###
VERBOSITY=0

###
# Temperature scale:
# Default: C
# Allowed values: C, F
###
TEMP_SCALE=C

###
# How often the temperature is checked (seconds):
# Default: 60
# Allowed values: 5 -> 300
###
POLL_INTERVAL=30

###
# Do you want quiet mode (allows setting of speed down to 10% rather than the
# 20% limit)?
# Default: 0
# (no)
# Allowed values: 0 (No), 1 (Yes)
###
QUIET=1
How can I get this as silently as possible to work?

Elect
Newbie
Posts: 3
Joined: Wed Nov 30, 2005 12:34 pm
Contact:

Post by Elect » Fri Dec 02, 2005 4:02 pm

Noone can really answer this question? Tried mostly anything and read the --help too many times. Anyone?

orochi
Gentoox Guru!
Posts: 606
Joined: Sun Oct 24, 2004 8:11 am

Post by orochi » Sat Dec 03, 2005 9:04 am

i think your file should be /etc/conf.d/fanctl and not /etc/config.d/fanctl

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests