Magic isn't being so magical...

Ask questions regarding Gentoox, Gentoo and Linux in general in these forums and we'll do our best to help you!
Post Reply
DancingTofu
Linux User
Posts: 14
Joined: Tue Jul 05, 2005 5:53 am
Location: Alabama, USA
Contact:

Magic isn't being so magical...

Post by DancingTofu » Fri Nov 25, 2005 12:28 am

I am having problems getting updates via Magic. My install is full native (via Cheesyboofs tutorial, with the only exception being I used the Home 4.0 rootfs instead of Pro 2.0) and I keep getting this error when I run Magic:

This will install tools to let you change your fan speed and
check system temperatures

The config file for fanctl is /etc/conf.d/fanctl
/bin/loadmonitor controls led patterns (check inside for
configuration)
--18:24:11-- http://shallax.com:2000/patch-files/monitors.tbz2
=> `monitors.tbz2.10'
Resolving shallax.com... 86.16.44.230
Connecting to shallax.com[86.16.44.230]:2000... connected.
HTTP request sent, awaiting response... 200 OK
Length: 518,003 [application/x-bzip-compressed-tar]

100%[====================================>] 518,003 3.20K/s ETA 00:00

18:26:19 (3.98 KB/s) - `monitors.tbz2.10' saved [518,003/518,003]

./fanctl
./loadmonitor
./testi2c

bzip2: Data integrity error when decompressing.
Input file = (stdin), output file = (stdout)

It is possible that the compressed file(s) have become corrupted.
You can use the -tvv option to test integrity of such files.

You can use the `bzip2recover' program to attempt to recover
data from undamaged sections of corrupted files.

tar: Unexpected EOF in archive
tar: Unexpected EOF in archive
tar: Error is not recoverable: exiting now

!! Decompression failed.

!! monitors patch failed.
!! Check your network settings and try again.

I have another box with the same installation type (fully native with Home 4.0) and it has no problems at all. I have tried running magic remotely via SSH and locally, with sync and without sync, and I still recieve the error. What should I do? :(
1.4 Xbox
Xecuter 3.0 Modchip with Gentoox BIOS
40 GB HDD Full Native

The search tool is your best friend! :D

orochi
Gentoox Guru!
Posts: 606
Joined: Sun Oct 24, 2004 8:11 am

Post by orochi » Fri Nov 25, 2005 9:19 pm

i just downloaded the file and opened it ok, on my windows box, maybe a corrupt download?

User avatar
ShALLaX
Site Admin
Posts: 1973
Joined: Sun Aug 10, 2003 9:25 pm
Location: England
Contact:

Post by ShALLaX » Sat Nov 26, 2005 1:49 am

The key here is:

"18:26:19 (3.98 KB/s) - `monitors.tbz2.10' saved [518,003/518,003] "

Notice the .10, this means I made a mistake in the script... the script doesnt delete the original (partially downloaded file first), instead of clobbering the file, it makes a new one .1, .2, .3...

I've fixed it, so run magic and it should work now!
The original Xbox adaptation of Gentoo

User avatar
cheesyboofs
Power user
Posts: 239
Joined: Wed Jan 26, 2005 1:32 pm
Location: Luton UK
Contact:

Post by cheesyboofs » Sat Nov 26, 2005 4:42 pm

Ahh bless, does that mean he's tried ten times....
Go fully native, it's the destiny of all Mk1 XboxesImage
The needs of the many out way the needs of the few or the one ...

orochi
Gentoox Guru!
Posts: 606
Joined: Sun Oct 24, 2004 8:11 am

Post by orochi » Sat Nov 26, 2005 9:36 pm

would be 11 if its .10 :D

Post Reply

Who is online

Users browsing this forum: No registered users and 10 guests