Page 1 of 1

Unstable pixels with component cable and Focus encoder

Posted: Wed Nov 23, 2005 8:32 am
by splurt
First of all, Gentoox is great, it's been my reason to learn linux.

I have a v1.4 xbox with Focus encoder, using xecuter 2 pro modchip with gentoox bios, 128MiB ram, SDG-605, W.D. 120G HD.

I run it at 720p with component cable, and 640x480 (so I can play games or xmess without running them at (1.333*720) x 720)

I figured out how to do the overscan compensation by way of reducing resolution, so now I default it to 1152x648. This was a pain since only certain resolutions work without jumbling the display. By the way, if you're reading this Shallax, I would recommend adding a "overscan compensation" mode like this to xbvset. This was a major frustration to me when first installing gentoox, and would probably be for most new users also since most TV's overscan analog component inputs also. I can't guarantee this mode will work on the Conexant chip, but I see no reason why it wouldn't:

mode "720p-compensated"
geometry 1152 648 1152 648 8
timings 13468 228 103 60 37 167 5

This mode works in X also (fbset -x)

My problem is that I see wandering pixels in the middle of the screen. The majority of the pixels in a given horizontal line will jump back and forth quickly making the picture look almost "noisy". It's odd because the jitter is more pronounced in the center of the screen than on the sides. This jitter happens at ALL resolutions too, 720p, 480p, 640x480. The only way to get rid of it is to use the composite video instead of the component cable, which leaves me at 640x480. I've tried playing with all the extra settings described in the fbset man page and changing the length of the sync pulses, but the problem persists. I'm thinking its an issue with the video driver and/or the focus chip. It seems like the input resolution to the encoder may be slightly different than the output resolution, causing a bit of uncertainty between pixels. But then again, the input is digital I believe. I have the same issue with xDSL as well. I would like to know if anyone's experienced this and/or overcome it. Is it a problem with xbox-linux, the focus chip, or just my particular setup? Thanks and any help is greatly appreciated.

By the way, I tried installing the Conexant chip I had from an old v1.0 motherboard on the v1.4 motherboard and it simply FRAGs using any bios. I thought they were pin compatible, but couldn't verify without the FS454 datasheet. It could've been a bad chip also since it came off a dead board... Countless hours of soldering for nothing..... :(

Posted: Sat Nov 26, 2005 5:58 am
by splurt
Just wanted to add that this problem is visible as soon as the bios screen loads, with gentoox bios OR cromwell bios, so it should be fairly widespread unless I have bad hardware (however, retail 720p xbox games like MVP 2004 do not have this problem).

If anyone runs an xbox at 720p, can you please simply reply and say "I have a conexant chip and see no visible artifacts" or "I have a focus chip and see subtle pixel instability as well" or "I don't know what you're talking about because I have a focus chip and don't see the jittery lines"

I ask because I am considering buying a used box with a conexant chip if it will clean up my video quality. Thanks...

I think i have the same problem.

Posted: Sun Jan 08, 2006 7:09 pm
by ritalin
I have a focus chip as well. but when i run 720p i seem to have pixel problems all over the screen. Not so much like noise, more like the pixels move back and forth horizontaly across the screen. Like its wobbleing.

I have a question fro yu though. Where did you set the custom resolution at... Id like to try to run 1280x768 as this is the native res of my screen.