Mounting a usb Hard Drive on gentoox 4.0 Home

Ask questions regarding Gentoox, Gentoo and Linux in general in these forums and we'll do our best to help you!
Post Reply
nasdak
Newbie
Posts: 5
Joined: Thu Aug 11, 2005 5:49 pm

Mounting a usb Hard Drive on gentoox 4.0 Home

Post by nasdak » Thu Aug 11, 2005 5:51 pm

Hy,

i've made a serach but couldn't find how to mount a usb hard drive with gentoox home 4.0
has the kernel to be recompiled? does anyone know what to do?

Thanks

and btw gentoox rulez :)

vplayer
1337
Posts: 442
Joined: Thu Oct 07, 2004 11:06 pm
Location: USA

Post by vplayer » Thu Aug 11, 2005 10:11 pm

you need to search a little bit more..

viewtopic.php?t=14&highlight=usb+drive

:) it doesnt say gentoox 4.0, but you get the idea.
Box: XBOX ver 1.1
Mod: Xecutor 2.3 lite+
Hdd: WD 80GB
Dash: Evox, Ava, XBMC
Linux: Gentoox Pro 4.2

nasdak
Newbie
Posts: 5
Joined: Thu Aug 11, 2005 5:49 pm

Post by nasdak » Fri Aug 12, 2005 6:40 am

hy,
i read this post. i tried what's in it:

Code: Select all

modprobe usb-storage 
modprobe scsi_mod 
modprobe ide-scsi 
modprobe sg 
modprobe sr_mod 
mkdir /mnt/usb 
mount /dev/sda1 /mnt/usb

modprobe ... works but i get no sda* in /dev directory :( so there's something wrong

shallax says "SCSI, IDE-SCSI emulation, SCSI-Generic, SCSI-Drive must be compiled into the kernel to allow USB HDDs to function."
is it done with home 4.0 ? or do you have to recompile the kernel?

orochi
Gentoox Guru!
Posts: 606
Joined: Sun Oct 24, 2004 8:11 am

Post by orochi » Sat Aug 13, 2005 6:52 am

check your kernel config

cd /usr/src/linux
make menuconfig

nasdak
Newbie
Posts: 5
Joined: Thu Aug 11, 2005 5:49 pm

Post by nasdak » Sat Aug 13, 2005 12:18 pm

Thanks
i enabled all with 'SCSI' and am compiling the kernel
hope this will work :)

nasdak
Newbie
Posts: 5
Joined: Thu Aug 11, 2005 5:49 pm

Post by nasdak » Sat Aug 13, 2005 1:01 pm

well i compiled the kernel with all scsi things on

now all the modprobes won't work (may be normal because it's ine the kernel now?)

but still no sda in /dev :(

orochi
Gentoox Guru!
Posts: 606
Joined: Sun Oct 24, 2004 8:11 am

Post by orochi » Sun Aug 14, 2005 8:00 am

did you compile in SCSI as a module or into the kernel?

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests