HOWTO: Fully Native

Ask questions regarding Gentoox, Gentoo and Linux in general in these forums and we'll do our best to help you!
Post Reply
User avatar
cheesyboofs
Power user
Posts: 239
Joined: Wed Jan 26, 2005 1:32 pm
Location: Luton UK
Contact:

Post by cheesyboofs » Thu Dec 08, 2005 8:08 pm

This is what I get now :cry:

-------------------------------------------------------------------------------
title Gentoox
kernel /boot/vmlinuz
initrd no
*SPACE*dontdeleteme video=xbox:640x480,nohwcursor,hoc=13,voc=13
title Sparkle
kernel vmlinuz
initrd sprkrd.gz
append load_ramdisk=1 prompt_ramdisk=0 ramdisk_size=26215 rw root=/dev/ram kbd-reset
-------------------------------------------------------------------------------

Still booted though, f*ck knows how! I think the xvbset thing that runs after the new kernel is installed is the thing fucking it up. It shuts down after running magic, reboots 'orange' then reboots by its self and comes up with this config. Although the change had been made before it shut down, I had a quick look...
Go fully native, it's the destiny of all Mk1 XboxesImage
The needs of the many out way the needs of the few or the one ...

User avatar
ShALLaX
Site Admin
Posts: 1973
Joined: Sun Aug 10, 2003 9:25 pm
Location: England
Contact:

Post by ShALLaX » Fri Dec 09, 2005 4:05 pm

Make sure you are fully updated with magic, delete everything inside your linuxboot.cfg file... run xbvset. Hit ctrl-c when its counting down to reboot. Open linuxboot.cfg, add the "dontdeleteme" part to the append line.. re-run xbvset.

Ive tried it many times here and it works fine!
The original Xbox adaptation of Gentoo

User avatar
cheesyboofs
Power user
Posts: 239
Joined: Wed Jan 26, 2005 1:32 pm
Location: Luton UK
Contact:

Post by cheesyboofs » Sat Dec 10, 2005 12:16 pm

I'm sorry, I thought the idear was if some one was running a native install they would still be able to run magic and then it would update without any user intervention.
I think I will continue to update via magic then reboot off restoox and repair the linuxboot.cfg.
I'm confused why you keep saying;
Make sure you are fully updated with magic,
When it is running magic that is causing the problem!, could you not just get magic/xbvset to ignore the linuxboot.cfg altogeather as it should not need to change at all and is 'created' during the tut anyway?
Or could they not output to a dummy file?

Regards
Go fully native, it's the destiny of all Mk1 XboxesImage
The needs of the many out way the needs of the few or the one ...

User avatar
ShALLaX
Site Admin
Posts: 1973
Joined: Sun Aug 10, 2003 9:25 pm
Location: England
Contact:

Post by ShALLaX » Sat Dec 10, 2005 1:41 pm

It should work fine from a clean installation. I have tested it with no problems.
The original Xbox adaptation of Gentoo

User avatar
cheesyboofs
Power user
Posts: 239
Joined: Wed Jan 26, 2005 1:32 pm
Location: Luton UK
Contact:

Post by cheesyboofs » Sun Dec 11, 2005 10:41 pm

Cool, just to confirm do we still apend dontdeleteme?
Go fully native, it's the destiny of all Mk1 XboxesImage
The needs of the many out way the needs of the few or the one ...

User avatar
ShALLaX
Site Admin
Posts: 1973
Joined: Sun Aug 10, 2003 9:25 pm
Location: England
Contact:

Post by ShALLaX » Mon Dec 12, 2005 3:36 am

Yes.
The original Xbox adaptation of Gentoo

User avatar
cheesyboofs
Power user
Posts: 239
Joined: Wed Jan 26, 2005 1:32 pm
Location: Luton UK
Contact:

Post by cheesyboofs » Thu Jan 12, 2006 6:22 pm

Just thought I’d show you how easy it is to make a two disk NAS now that you can install and repair via the Resctoox web,

First remove the front bezel from the front of the DVD and screw it from underneath of the Xbox front bezel,
Image

Then mount the second hard drive in a 5 ¼ Hard drive bracket (I used a ZIP drive bracket from http://www.lindy.co.uk no screws needed) then mount that in the Xbox DVD bracket,
Image

Set one drive to master and one drive to slave and put Xbox back together, Hay presto a 200Gb NAS becomes a 400Gb NAS, sweet!
Image

Excuse the quality of the pictures they where taken with my PDA.
Go fully native, it's the destiny of all Mk1 XboxesImage
The needs of the many out way the needs of the few or the one ...

orochi
Gentoox Guru!
Posts: 606
Joined: Sun Oct 24, 2004 8:11 am

Post by orochi » Sat Jan 14, 2006 2:29 am

I like the USB external hdd approach too :)


btw, the links are broken on your pics maybe its the site http://www.cheesyboofs.co.uk/ or just me, didnt resolve :D

User avatar
cheesyboofs
Power user
Posts: 239
Joined: Wed Jan 26, 2005 1:32 pm
Location: Luton UK
Contact:

Post by cheesyboofs » Sat Jan 14, 2006 9:08 am

It was me, lol, I think that maybe two HDD's are a little much for the PSU and the server went down. I've rebooted and we will see if it was just a one off, fingers crossed!

UPDATE 17/01/06 Looks like the PSU can run two HDD's just fine, must have been summet else...
Go fully native, it's the destiny of all Mk1 XboxesImage
The needs of the many out way the needs of the few or the one ...

User avatar
cheesyboofs
Power user
Posts: 239
Joined: Wed Jan 26, 2005 1:32 pm
Location: Luton UK
Contact:

Post by cheesyboofs » Sun Jan 22, 2006 6:41 pm

It would appear that magic IS now Native aware, well, on a fresh install. It seemed to behave it’s self during the kernel update with the dontdeleteme addition to the linuxboot.cfg file.
Go fully native, it's the destiny of all Mk1 XboxesImage
The needs of the many out way the needs of the few or the one ...

User avatar
ShALLaX
Site Admin
Posts: 1973
Joined: Sun Aug 10, 2003 9:25 pm
Location: England
Contact:

Post by ShALLaX » Sun Jan 22, 2006 8:40 pm

*Thumbs up*
The original Xbox adaptation of Gentoo

hammy
Newbie
Posts: 4
Joined: Fri Mar 10, 2006 9:18 am

Post by hammy » Fri Mar 10, 2006 9:23 am

Ok, what the crap.

Well, my current config is gentoox bios on a xecuter 2.

And after following the instructions to the letter, the loader doesn't see any sort of install on my hard disk. The normal install works just fine, I just can't get this native install to do what it's supposed to.

Can you give me a clue.

User avatar
cheesyboofs
Power user
Posts: 239
Joined: Wed Jan 26, 2005 1:32 pm
Location: Luton UK
Contact:

Post by cheesyboofs » Fri Mar 10, 2006 10:39 pm

That would be the illusive v6.-> loader bug and NOT this tutorial. Ask shallax for v5.11 of the loader, but be nicer and use the search.
viewtopic.php?t=3356
Go fully native, it's the destiny of all Mk1 XboxesImage
The needs of the many out way the needs of the few or the one ...

hammy
Newbie
Posts: 4
Joined: Fri Mar 10, 2006 9:18 am

Post by hammy » Sun Mar 12, 2006 1:13 am

Sorry if I sounded inconsiderate, it was more of frustration talking. I do greatly appreciate all the hard work people have put in to this. I did search by the way, but thanks for the link. Again, thank you for the help.

User avatar
ShALLaX
Site Admin
Posts: 1973
Joined: Sun Aug 10, 2003 9:25 pm
Location: England
Contact:

Post by ShALLaX » Sun Mar 12, 2006 2:11 am

The original Xbox adaptation of Gentoo

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests