Page 3 of 13

Posted: Wed Oct 05, 2005 2:42 am
by ShALLaX
Tada, new Resctoox out with working large file support (LFS)... tried and tested myself! Sorry for the wait!

Posted: Wed Oct 05, 2005 8:00 pm
by cheesyboofs

I thought I’d try this on my 1.6 Xbox that had the Gentoox loader already on it, but this wouldn’t boot off the Resctoox CD only Sparkle so I thought I’d try re-flashing a newer bios via Gentoox bios flash option, but I ended up nuking my Xecuter 2.6 mod chip. I’ve now got a programmer on order so I won’t be able to test this new version of resctoox till at least the middle of next week.

You know when you start those 10 minuet jobs and you really wish you had'nt!!!! :cry:

Posted: Thu Oct 06, 2005 6:30 am
by atariman486
woo hoo! thanks for this tutorial. I searched for a loooonnnng time looking for how to do a fully native install with gentoox! I used the the new resctoox CD and the LFS worked fine. I also used reiserfs for /dev/hda2 and it worked great. Now I've got apache up and running. Again thanks for the tutorial... and thanks for your great work ShALLaX.

Posted: Thu Oct 06, 2005 10:22 am
by ShALLaX
Excellent! Good to hear it works now :)

Posted: Sun Oct 09, 2005 5:53 pm
by Bucko
nice tutorial 8) 8) :lol: :wink:

Posted: Tue Oct 11, 2005 7:37 am
by cheesyboofs
Programmer arrived yesterday and was up and running again last night, I’m happy to also report that Restoox 2.2 is working a treat. I will update the tutorial as soon as I get a chance.
Nice one!

Posted: Tue Oct 11, 2005 12:32 pm
by ShALLaX
Excellent, thanks!

Posted: Wed Oct 12, 2005 9:12 pm
by cheesyboofs
There we go all updated, now lets never mention the 'X' word again. :wink:

Posted: Wed Oct 12, 2005 9:23 pm
by ShALLaX
Hehe, great job! You get the reboot request because Resctoox auto mounts your E: drive. Repartitioning while any partition is mounted means that the OS will continue using the old partition table, therefore a reboot is required (unless you unmount everything first).

Posted: Sun Oct 16, 2005 10:57 am
by cheesyboofs
New feature: XboxIR auto-repeat patch

There’s a new kernel patch which enables auto-repeat of keypresses on the Xbox remote. Run magic to update!
Will this involve downloading a new vmlinuz and there for test my/our little /boot patch?
Also I never did ask, what does initrd do? And why don’t we need it?

Posted: Sun Oct 16, 2005 3:01 pm
by ShALLaX
It involves a new kernel patch (i.e. recompiling).

The initrd's primary function is to mount the rootfs and pivot to it then run init.

Posted: Tue Oct 18, 2005 10:36 pm
by teitoku

Code: Select all

Resctoox:> ls -l /mnt
drwxr-xr-x    2 root     root         1024 Aug  3  2003 e
drwxr-xr-x    3 root     root           72 Oct 18 22:11 hda2
drwxr-xr-x    2 root     root         1024 Oct 18 22:33 loopback
drwxr-xr-x    2 root     root         1024 Aug  3  2003 swap
drwxr-xr-x    2 root     root         1024 Aug  3  2003 temp
Resctoox:> mount -o loop /mnt/hda2/rootfs /mnt/loopback
mount: Mounting /mnt/hda2/rootfs on /mnt/loopback failed: Not a directory

Posted: Wed Oct 19, 2005 10:26 am
by cheesyboofs
Can I just make sure you didn’t copy and paste the

Code: Select all

mkdir /mnt/loopback && mount –o loop /mnt/hda2/rootfs /mnt/loopback
command in to putty, for some reason it substitutes the ‘–o’ for ‘.o’ you must follow the tutorial word for word!

Posted: Thu Oct 20, 2005 1:34 pm
by teitoku
Well, I got the mounting sorted out now. I got to the bit of your tutorial where you copy over vmlinuz, create linuxboot.cfg, and re-write the contents of fstab. Done, done, and done. Flashed loader 5.11 to my chip. Boot up and see CD/DVD and Advanced. No hard drive option. What's left to do?

Posted: Thu Oct 20, 2005 7:35 pm
by teitoku
Oops, forgot to mark partitions as active/bootable when running cfdisk earlier. I went and ran it now, and I get this "cannot find reiserfs on ramdisk(1,0)" error. Should I just wipe it clean and start over?