Page 12 of 13

Posted: Sun May 20, 2007 3:49 pm
by clpalmer
I'll try to run it again here. I put pro on the new box that I'm gonna replace my server with. I still have to redo the old server with home or MCE so I'll try again once I put the new Loader on the old box.

Still not sure if I want to run MCE or Home + additions. I want to run the old box as a front end so I can play DVD's and divx/avi/mpeg/etc files across the network. Wanted a nice shiny new release, and there's no new MCE one, but I don't know what features MCE has that Home doesn't and if it's much work to build them on top of the latest Home release. Clearly I have some research to do =)

Posted: Thu May 24, 2007 11:51 pm
by clpalmer
Suggestion cheesyboofs: Might be helpful to those that want to run Home instead of Pro to mention that this is possible with Home release as well, but that there are a couple different things to do (such as running firstboot/xbvset and such).

Posted: Fri May 25, 2007 10:33 am
by cheesyboofs
I have never run 'Home' I wouldn't know what to add!

Posted: Fri May 25, 2007 2:11 pm
by clpalmer
Well I suppose it does make sense not to write a tutorial on something you've never done =)

Maybe just a warning in there somewhere when you say to use Pro, mention that if you want to use Home that you can, and that it works up to the point of installing and booting natively, but there are additional configuration steps after that that aren't covered in the tutorial.

Just to make sure that people who follow it blindly and grab Home instead know that there is some other stuff they should probably read up on =)

Posted: Sat May 26, 2007 12:35 pm
by blighty
Been trying to get home 6.2 to run as per this tut on a stock 10GB seagate ( the larger sized one without the rubber thing round it ) but get this error every time, I`ve tried re downloading the iso & tried 2 diffrent hdd`s ( identical model )

Sorry I`ve not got back earlier but i`ve been looking for a log file somewhere so I don`t have to type all this in manualy, no luck so hope i don`t get any typo`s.

at this point " Then copy all the files from the rootfs to the new drive;
# cp -a /mnt/loopback/* /mnt/hda2 " i get the error

this is what appears on the xbox, putty on my pc locks up & does nothing

Code: Select all

Locking console...    Hit ctrl-C to login locally.journal-601, buffer writ
e failed
kernel BUG at prints.c:341!
invalid operand: 0000
CPU:      0
EIP:       0010:[<c02033a6>]    Not tainted
EFLAGS: 00010282
eax:  00000038   ebx:  c18fc800   ecx:  c108c000   edx:  c108dfa8
esi:   c5eb3110    edi:  00000012 ebp:  000000d0  esp:  c124de20
ds:  0018   es:  0018  ss:  0018
process kupdated (pid: 7, stackpage=c124d000)
stack: c0439023 c05a9d40 c059bf40 000000c8 c020f707 c18fc800 c0447360 c124de50
00001000 00000000 000000ce 00000000 c0be0ba0 c18fc800 0000003d 00000001
00000004 c0214278 c18fc800 c5eb3110 00000001 00000006 276a296f c020edf4
Call Trace:    [<c020f707>] [<c0214278>] [<c020edf4>] [<c0213093>] [<c01fffb9>]
[<c01404e5>] [<c013f8ea>] [<c013fbc2>] [<c0108dd2>] [<c013fae0>] [<c0105000>]
[<c01074de>] [<c013fae0>]

Code: 0f 0b 55 01 36 90 43 c0 85 db b8 3f 90 43 c0 74 0c 0f b7 43

any idea`s?


Posted: Sat May 26, 2007 4:31 pm
by clpalmer
Same problem's been posted in a couple other threads. Basically, the only solution so far is to copy over the rootfs file system piece by piece. Create /usr in the target, go into /usr on the rootfs mount and copy each individual directory. If/when it fails, reboot, delete that directory and try again.

Some directories might be too big to copy in their entirety (for example /usr/share) so you might have to again create /usr/share in the target and copy /usr/share/* one by one.

It's a pain in the ass process, and much worse with Home than Pro, but I did it with both and since the install they're both running fine with no issues.

Posted: Sat May 26, 2007 4:41 pm
by blighty
hadn`t noticed the other threads, sorry.

sounds a little over my head i`m affraid, I used to be able to do it with the other builds no prob just following this tut, rootfs always copied fine.


Posted: Thu Jun 14, 2007 4:17 pm
by annerajb
hello i been having a problem following this tutorial i do everything exactly as you told except the files i copied wasnt from the distro.rar were from my existing installation of gentoox on e i decided to change from e to native to get more space i did everything copied my old vmlinuz rootfs and linuxboot.cfg and started the xbox. everything works fine i select my boot option but it halts at starting gentoox. the only thing i havent try its netboot loading the vmlinuz and initrd but i quess that wouldnt help. any help will be gladly appreciated and gj on this tutorial :)

Posted: Thu Jun 14, 2007 4:38 pm
by annerajb
used net boot and uploaded my vmlinuz and used the appen that appears on netboot webpage didnt work same thing it halt on the starting linux window. i was using /dev/ram0 nor /dev/hda2 maybe my vmlinuz its corrupt or something similar going to upload a new one to the xbox if anybody have any suggestion of what maybe the cause i will gladly hear it :)

Posted: Thu Jun 14, 2007 10:52 pm
by annerajb
uploaded a new vmlinuz and deleted from the linuxboot.cfg the dondeleteme piece of the append it pass starting gentoox but stops and displays a shell says
and if i disconnect or connect the controller it displays it on screen. any idea why the shell?

Posted: Sat Jul 28, 2007 5:06 am
by heatvent
How long is this step supposed to take:

Then copy all the files from the rootfs to the new drive;
# cp -a /mnt/loopback/* /mnt/hda2

It's just been sitting there for half an hour.

Posted: Wed Nov 14, 2007 10:24 pm
by blighty
heatvent wrote:How long is this step supposed to take:

Then copy all the files from the rootfs to the new drive;
# cp -a /mnt/loopback/* /mnt/hda2

It's just been sitting there for half an hour.
I always walk off & comeback after an hour at that stage but only with older builds, thats a 4GB file that your box has to unpack btw.


Posted: Fri Nov 16, 2007 4:47 pm
by cheesyboofs
Its a sad day but I am officially dropping any support for native installs as I have moved over to a QNAP raid one box that meets all of the needs of the two Xboxes I was running with RAID support. ... S-209+Pro/
All the best to Shallax and the forum members.

Posted: Sun Dec 16, 2007 6:31 am
by toru73
Hi all

I am having difficulty with the instructions in this thread. I am attempting to install the MCE version completely natively, following these instructions. However, I'm stumped at the "copy rootfs over" part. I can't find the rootfs file within the MCE iso. Am I just being stupid, or should I be looking for something else?

Thanks in advance

A solution : HOWTO: Fully Native

Posted: Sat Feb 16, 2008 4:31 pm
by kickinz1
If you have a pc with a linux on it:

(works at least on a debian etch)

You extract distro.rar on it,
you create a mount point:
mkdir /mnt/gentoox
you mount the rootfs:
mount -o loop rootfs /mnt/gentoox
you cd to the directory:
cd /mnt/gentoox
you do a
tar cvzf ../rootfs.tar.gz *
you upload by ftp rootfs.tar.gz to /mnt/hda2

Keep the rootfs.tar.gz somewhere as it can be usefull to re-install.

On the xbox now:
cd /mnt/hda2
tar xvzf rootfs.tar.gz
rm rootfs.tar.gz

It worked at my home, was lot of more quicker than th cp -a step by step.

If possible, maybe we can upload this file to the gentoox site?