Page 9 of 13

Posted: Mon Jan 01, 2007 12:42 pm
by Ianh

Do you know if there is any sort of capacity limitation ?


Posted: Sun Jan 07, 2007 10:53 am
by Ianh
answer: probably not as far as disk size.

I had trouble formating a whole 400G drive as one partition (reiserfs). But then why would you want one 400G partition ? I had no problems with partitions up 250G but I didn't go higher so I don't know what the prtition size limit is.

Posted: Sun Jan 07, 2007 2:17 pm
by Pyrite
Hey guys,

Can't believe I didn't see this before, I had been using Xebian (uck). So glad a full native is possible. I believe this is really the only xbox distro that is kept up to date and has a community, so I really wanted to use GentooX (although I've been using Slackware for the past 10 years and no nothing whatsoever about Gentoo).

So did the install, etc etc. Only thing that isn't working (oh and btw, the full native with Loader 6.05 doesn't work, 5.11 does, however, funny thing is, when I loaded the loader 6.05 and still had my old Xebian native install, it recognized it fine and booted it) .... ok, back to where I was, only thing that isn't working is DHCP. It boots, waits, waits some more, and then defaults to the .1.13 address. I tried running `dhcpcd eth0` through ssh and it just waits too and fails. Any ideas? DHCP was working just cherry with Xebian, also works with Net Boot, Web Boot, Net Flash etc through the bios, just not when it boots GentooX.

Anyways, BIG SHOUT OUT TO SHALLAX for this wonderful BIOS! Please somehow make 6.05 (rather 6.06 ;)) work with this native booting, would love you for it ;)

Posted: Sun Jan 07, 2007 2:49 pm
by Ianh

Someones got to say it but re: ".....oh and btw, the full native with Loader 6.05 doesn't work, 5.11 does......."

The 9th line of Cheesey's tutorial says "Gentoox BIOS (Only 5.11 seems to work fully at the moment) ". BTW I did the same thing myself :-)

Anyway have you tried editing
with the line
config_eth0=( "dhcp" )


Posted: Mon Jan 08, 2007 1:16 am
by Pyrite
My point was that my previous native xebian install works with 6.05.

Anyway, the content of my /etc/conf.d/net is:

Code: Select all

config_eth0=( "dhcp" )
fallback_eth0=( " netmask broadcast" )
fallback_route_eth0=( "default via" )
Btw, I haven't changed anything at all, this is a 100% default Pro 4.1 install using Cheesy's tutorial.

Posted: Mon Jan 08, 2007 12:53 pm
by cheesyboofs
Ianh wrote:hehe

Someones got to say it but re: ".....oh and btw, the full native with Loader 6.05 doesn't work, 5.11 does......."

The 9th line of Cheesey's tutorial says "Gentoox BIOS (Only 5.11 seems to work fully at the moment) ". BTW I did the same thing myself :-)



Half way down ;0)

Posted: Mon Jan 08, 2007 6:40 pm
by Ianh
Pyrite wrote:My point was that my previous native xebian install works with 6.05.......
OK understood.

Sorry I don't understand your DHCP problem. That's the same text as my /etc/conf.d/net.

It probably doesn't help but I had the oposite problem I couldn't get a static IP working. I could communicate via the computers on the network but my xbox wouldn't communicate with the Internet. So I defaulted to DHCP which works perfectly.

Is it a firewall issue ? Sounds like your xbox waits ofr a reply to its DCHP request but doesn't get one.

I'm sorry if that doesn't help (it probably doesn't) but at least I tried !!!

Posted: Tue Jan 09, 2007 2:05 am
by Pyrite
I know the problem must be with GentooX.

DHCP works fine on the same XBOX with the Loader bios (Net Boot etc), works fine with Xebian, etc etc etc.

It is only when booting the GentooX Pro 4.1 Native Install that DHCP times out. Perhaps I can set the parameters for dhcpcd somewhere? I am sorry I am not familuar with GentooX to know where things are.

And any help is much appreciated.

I'm going to try to figure out what is different about my Xebian install with Loader 6.05, perhaps I can figure out why it works and the native gentoo install doesn't. I'll take a look.


Posted: Fri Feb 09, 2007 8:45 pm
by exboxxed
Gentoox loader v6.05 is great because you can use the "net boot" option to rescue a broken "headless" Xbox server.

With Xebian, I noticed that the first parition is FAT12 (type 1). When I changed this to type 82 (swap), then I lose the option for "native". On a gentoox install, perhaps changing your swap parition to type 1 will give you a "native" option using loader v6.05. Maybe someone with a spare xbox could test this.

I tried gentoox at first (and found it to be a good learning tool), but it was not practical as a server box (at least not for me). Emerge is a great tool, but it just took too long for things to compile.

My xbox runs Debian unstable with kernel 2.6.16-xbox. I'm also using shallax's binaries of fanctl, xboxtemp, and loadmonitor.

Credits to shallax for providing gentoox (and tools), and cheesyboofs for the native install guide. Thanks!

Posted: Wed Feb 14, 2007 4:19 pm
by cheesyboofs
This is fantastic and possibly the work around we need, what a fantastic 1st post. My two Xbox's are now in full service, can anyone try this? Perhaps move the swap partition to the end of the disk, or create a small boot one in-front of the swap partition.

Posted: Thu Feb 15, 2007 8:29 am
by exboxxed
I no longer have plans to use Gentoox on my Xbox, but I don't like loose ends, so I decided to figure out why v6.05 "native" works with my Debian install but not with my previous Gentoox.

I temporarily removed my Debian disk and swapped in an old hard drive from a spare PC I was in the process of upgrading.

It turns out that using a FAT12 (type 1) swap partition is not the key. I looked up more information about Cromwell, and its only requirements for offering a "native" boot option are to have either ext2/ext3 or reiserfs.

This got me thinking that perhaps reiserfs in v6.05 is either broken or missing. I went through your native install guide again, but this time I formatted /dev/hda2 as ext3 (mke2fs -j /dev/hda2). It also doesn't matter if you use type 1 or type 82 for the swap partition, so long as your root partition is ext3.

After rebooting, I was presented with the "native" boot option. Success!

I know this may not help your situation since you already have two fully working Xbox's, but perhaps it will help those just starting out. You may want to amend your guide to include this information, until shallax finds the time to release an updated loader with reiserfs support.

I'm still learning about Linux so this is just a thought. You could use parted to add a small ext2/ext3 "/boot" partition, and keep your existing root partition as reiserfs. Maybe this is all you need to see the "native" boot option. When I get the chance I'll test this out.

I hope you have success with this information. Cheers!

Posted: Thu Feb 15, 2007 8:44 am
by exboxxed
I almost forgot to mention you will need to edit fstab so it now includes this line

/dev/hda2 / ext3 defaults 0 1

instead of

/dev/hda2 / reiserfs notail 0 1

Also, just a small edit is required in your guide. There's a typo in this line

"Then when that's done copy over linuxboot.cfg and vmlinux via FTP again, also obtained from the distro.rar to /mnt/hda2/boot/"

You have vmlinux, when it should read vmlinuz.

Posted: Thu Feb 15, 2007 10:16 pm
by exboxxed
Here's an update.

I setup my spare drive exactly as outlined in your guide, with the exception that I'm using loader v6.05. As expected, after the first reboot I don't see the "native" boot option. I "net boot" again and used fdisk to remove the swap parition, added a small ext2 boot partition at the beginning, and finally created a type 82 swap partition at the end. So I end up with hda1 mounted as active /boot, hda2 as the existing reiserfs root partition, and hda3 as swap. I also copied the two files (linuxboot.cfg and vmlinuz) into the new /boot partition. I also edited the fstab file to reflect the new partition layout.

I did get this warning from fdisk - "Partition table entries are not in disk order" - but I just ignored it.

After rebooting, I get the "native" boot option, and it seems to work but then the process just hangs loading /boot/vmlinuz. Perhaps this is due to the table entries being out of order. Maybe there's a utility that can rearrange the partition table entries without wiping any data?

To undo this process, I "net boot" back into resctoox, undo the changes in fstab, and modify the partition table back to hda1 as swap and hda2 as active partition. I rebooted and reflashed with loader v5.11, and I'm back into Gentoox.

At this point, I have to stop since I don't know enough about the Linux boot process and exactly how the loader works. I also need to use my spare drive for my upgraded PC, and also put back my Xbox into working order with my Debian install.

I hope this gives you enough information to make this work for your existing installation. Best of luck.

Posted: Fri Feb 16, 2007 10:43 am
by cheesyboofs
Thanks for all your efforts, you have breathed a new life into this thread and if nothing else I thank you for that.

I did try using ext2/ext3 for the data partition but I found it a very noisy/clattery file system with the head flying about the disk all the time where as reiserfs seemed a lot quieter.
I defiantly think the trick will be to have a small /boot partition then a /swap then the data and this is the route I will go down this week with a spare HDD.
I'm not too worried if I have to backup / reformat / restore to get this working as it is good practice to test a DR procedure once in a while ;0)
Failing that I may decide to just format the data partition to ext3 and live with the noise as the prose of doing so out way the cons.

After doing all this I will update the tutorial to reflect my findings, also bin meaning to add mysql, apache, php support as well as nfs.

As for Shallax, I can't speak for him but I think he is rather tied up in his new job at the moment to help us bug fix this problem but I wish he had kept his web site running on an Xbox as it showed that there was a real point to all this now he has it running off an iMac mini.

Once again thanks for spending the extra time on this, its what its all about!

Posted: Sat Feb 17, 2007 7:20 am
by exboxxed
I'm glad I can give something back to this community. It was shallax's work on Gentoox (and loader), and your excellent native install guide that got me started on this project.

Before switching to Debian on the Xbox, I did manage to get Gentoox working with a complete LAMP stack, as well as NFS, NTP, and DNS services. I enjoyed very much working with Gentoox as it has taught me quite a bit about Linux. The only drawback for me with Gentoox is the often tedious compile time, especially if you're trying to keep to the latest packages.

I'm still very much attracted to the power of emerge, but I will most likely install Gentoo proper on my upgraded PC so I can continue to enjoy working with emerge and Gentoo in general. I think Gentoo provides excellent online documentation usable even for a noob such as myself. And, a majority of this documentation can be applied directly to Gentoox.

I know (for myself) that using an ext3 partition works to enable "native" using loader v6.05. This closed the chapter for me, but the better challenge would have been to make this work for an existing installation already using reiserfs. It's a shame I couldn't manage to get this to work while I had a spare drive to use.

I do hope you manage to make this work with a reiserfs data partition. Regardless of the solution you finally decide to take, I look forward to a successful post.