Page 1 of 1

Apache, mysql and databases...

Posted: Wed Jul 13, 2005 8:40 pm
by BigBowser
This morning, I booted up my XBox (Home 4.0, formated yesterday) and I wanted to install apache mysql and php, so I did:

emerge mysql mod_php

Apache2, MySQL and php are confgiured, I tried to install phpbb to test my TuxBox, the page loads but when I log in and try to go on the "Administration Control Panel" a pop-up appear with "Couldn't access to localhost, access denied" (I think). And nothing worked, authorisations, config files nothing...

Does someone know how to fix it?

Posted: Thu Jul 14, 2005 2:29 pm
by clpalmer
If the web page loads, I'd imagine it's a problem with sql, not apache. Have you tried other methods of accessing your sql database? Is there some sql setup that's required for phpbb that you haven't done? (been ages since I set up phpbb so I don't remember it much, but these are guesses). Don't remember the sql command line interface, but see if you can just access and query the sql database to make sure it's set up and running ok.

Posted: Thu Jul 14, 2005 3:31 pm
by BigBowser
I tried phpMyadmin and it worked without problem. On the pop-up it says it could'nt connect to database, but I entered all passwords... I don't understand, It isn't my first web server but actually I don't understand.

Posted: Fri Jul 15, 2005 2:29 pm
by clpalmer
It doesn't sound like there's a problem with the web server. It seems like there's a problem with your phpbb/sql setup. I don't know much about phpbb and what it requires so I can't help you much more =/ Maybe I'll install it today for $#!75 & giggles. If I do, I'll let you know how it goes and what I had to do.

Posted: Fri Jul 15, 2005 5:45 pm
by clpalmer
*sigh* at least you got that far. I can't even emerge mod_php. Seems php-4.4.0.tar.bz2 doesn't exist for download... They have php 3.x and 5.x but no 4.4.0. Anyone know if there is a way to tell emerge to grab it from a different place or to use a copy I downloaded myself?

>>> emerge (1 of 2) dev-php/mod_php-4.4.0 to /
>>> Downloading ... .0.tar.bz2
--10:31:42-- ... .0.tar.bz2
=> `/usr/portage/distfiles/php-4.4.0.tar.bz2'
Connecting to[]:21... connected.
Logging in as anonymous ... Logged in!
==> SYST ... done. ==> PWD ... done.
==> TYPE I ... done. ==> CWD /mirror/gentoo/distfiles ... done.
==> PASV ... done. ==> RETR php-4.4.0.tar.bz2 ...
No such file `php-4.4.0.tar.bz2'.

>>> Downloading
=> `/usr/portage/distfiles/php-4.4.0.tar.bz2'
Connecting to[]:80... connected.
HTTP request sent, awaiting response... 404 Not Found
10:31:46 ERROR 404: Not Found.

!!! Couldn't download php-4.4.0.tar.bz2. Aborting.

Posted: Fri Jul 15, 2005 9:39 pm
by vplayer
clpalmer... did u do emerge sync before u started the emerge for mod_php.

also... for both of you.. check whether this link would help you in anyways..

Posted: Mon Jul 18, 2005 5:41 pm
by clpalmer
Yup. Didn't help =/ For some reason, the latest package for php is 4.4.0 and the sites have 4.3.9 and 5.0.3 but no 4.4.0...

Posted: Tue Jul 19, 2005 2:29 pm
by rocketeer
clpalmer: try another mirror. The mirror I use (which is close to me) has 4.4.0.

In /etc/make.conf there is a quoted whitespace-separated list:

Code: Select all

GENTOO_MIRRORS=" http://mirror2 ftp://mirror3 etc"