DHCP not working?

Ask questions regarding Gentoox, Gentoo and Linux in general in these forums and we'll do our best to help you!
Post Reply
Scrufdog
Novice
Posts: 34
Joined: Sun Jun 05, 2005 9:04 pm

DHCP not working?

Post by Scrufdog » Wed Jun 08, 2005 3:11 am

so i checked /etc/conf.d/net and it is set for dhcp.

When I boot up EvoX gets a the proper dhcp IP of 192.168.1.101. I can ftp into the box no problem.

Problem is when I launch GentooX, it loads as 192.168.1.13. Whats going on?

vplayer
1337
Posts: 442
Joined: Thu Oct 07, 2004 11:06 pm
Location: USA

Post by vplayer » Wed Jun 08, 2005 11:26 am

can you ftp / ssh into 192.168.1.13 after gentoox boots up.
Box: XBOX ver 1.1
Mod: Xecutor 2.3 lite+
Hdd: WD 80GB
Dash: Evox, Ava, XBMC
Linux: Gentoox Pro 4.2

Scrufdog
Novice
Posts: 34
Joined: Sun Jun 05, 2005 9:04 pm

Post by Scrufdog » Wed Jun 08, 2005 2:03 pm

after several reboots it was still doing it. I then did a cold boot and now its working fine. So I dunno, but it seems to be ok now.

Trevante
Power user
Posts: 203
Joined: Mon Oct 11, 2004 10:21 pm

Post by Trevante » Wed Jun 08, 2005 6:36 pm

Try running dhcpcd after Gentoox boots up.

Scrufdog
Novice
Posts: 34
Joined: Sun Jun 05, 2005 9:04 pm

Post by Scrufdog » Wed Jun 08, 2005 6:40 pm

is that the same as the ipconfig -renew command in windows? cause thats what i was kinda looking for as well

User avatar
clpalmer
Power user
Posts: 288
Joined: Sat Jan 29, 2005 6:38 pm

Post by clpalmer » Thu Jun 09, 2005 2:17 pm

Yep, dhcpcd is the linux dhcp client. Instead of:

Code: Select all

ipconfig /renew
use

Code: Select all

dhcpcd <interface>
ie.

Code: Select all

dhcpcd eth0

Scrufdog
Novice
Posts: 34
Joined: Sun Jun 05, 2005 9:04 pm

Post by Scrufdog » Thu Jun 09, 2005 4:18 pm

good deal, thanks all

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests