Error while emerging mod_php

Ask questions regarding Gentoox, Gentoo and Linux in general in these forums and we'll do our best to help you!
Post Reply
cyesergio
Linux User
Posts: 18
Joined: Mon Feb 28, 2005 8:20 pm

Error while emerging mod_php

Post by cyesergio » Mon Mar 21, 2005 8:27 pm

I can't seem to emerge mod_php...have googled and searched in vain! These are the error messsages...

both can't be installed on the same system together.
dir! Error: the <x11-base/xorg-x11-6.8.0-r4 package conflicts with another package.! both can't be installed on the same system together.
> !!! Please use 'emerge --pretend' to determine blockers.


after using the pretend option...

Calculating dependencies ...done!
[blocks B ] <x11-base/xorg-x11-6.8.0-r4 (is blocking x11-base/opengl-update-2.1.1-r1)
[ebuild N ] dev-libs/libgpg-error-1.0-r1
[ebuild N ] dev-libs/libgcrypt-1.1.94
[ebuild N ] dev-libs/libxslt-1.1.12
[ebuild N ] app-crypt/mhash-0.9.2
[ebuild N ] media-libs/freetype-2.1.9-r1
[ebuild N ] x11-misc/ttmkfdir-3.0.9-r2
[ebuild N ] x11-base/opengl-update-2.1.1-r1
[ebuild N ] x11-base/xorg-x11-4.3.0-r6
[ebuild N ] media-libs/pdflib-5.0.4_p1-r1
[ebuild N ] dev-libs/libmcrypt-2.5.7
[ebuild N ] app-text/aspell-0.50.5-r4
[ebuild N ] app-text/sablotron-1.0
[ebuild N ] net-libs/libwww-5.4.0-r2
[ebuild N ] media-libs/freetype-1.3.1-r4
[ebuild N ] media-libs/t1lib-5.0.2
[ebuild N ] dev-php/mod_php-4.3.10
[ebuild N ] dev-php/php-4.3.10

So what to do about these so called blockers?!

Thnx in advance!

Cye


[/b]

cyesergio
Linux User
Posts: 18
Joined: Mon Feb 28, 2005 8:20 pm

Post by cyesergio » Tue Mar 22, 2005 10:05 am

no replies :(

cyesergio
Linux User
Posts: 18
Joined: Mon Feb 28, 2005 8:20 pm

Post by cyesergio » Tue Mar 22, 2005 10:26 am

I'm slowly getting a hang of this...
In the make config, I had to disable X (e.g. -X)...That stopped it from compiling the xfree dependancy! I thought I already did that (I followed nobspangles tut!); guess I forgot...
Oh well it's emerging now...

User avatar
Schultz
Novice
Posts: 40
Joined: Wed Mar 31, 2004 1:58 am

Post by Schultz » Tue Mar 22, 2005 10:48 pm

editing your make.conf file does global changes.. if you only wish to change it for mod_php or when you are emerge'ing you can do stuff like this
USE="-x" emerge -av mod_php

the -a has it ask you if you wish to emerge so you can check everything out.. Also the -v shows info about all the flags that are used.. I just got into the habit of doing that..

also if you wish to make custom packages with there own use flags you edit i *think* the file
/etc/portage/packages.use or something of that.. which then you can tell only flags that affect PHP .. this is better approach since it doesn't affect system wide.. unless you don't plan on using X at all or have anything support it..

Also i am slowly learning emerge too.

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests