Page 2 of 3

Posted: Mon Mar 21, 2005 11:18 am
by britishseapower
thanks for this good info. Bit scared by the switch installation and physical modding requirements so I think im gonna retreat for now and concentrate on getting the USB option working. I'll keep my box in pristine condition, and i already have the kit. Tsuro - would the limit to 137GB patition size be true for usb devices also...?

Posted: Mon Mar 21, 2005 9:51 pm
by Trevante
Well the Xbox's IDE controller is limited to 137GB, but for USB storage devices, it may not have that same limit.

Posted: Fri Jun 03, 2005 9:34 pm
by britishseapower
I'm now well and truly cromwell'ed

I have 10 gig hdd running gentoo in and the dvd (both stock).

If I plug a slave hdd in instead of the DVD drive (and power it, clearly - i used a splitter off the power to the 1st) - should i see it as /dev/hdb...i dont for some reason?

not sure what i've missed.

Posted: Mon Jun 06, 2005 2:01 am
by Trevante
Hmm... check your jumpers maybe?

Posted: Mon Jun 06, 2005 11:34 am
by britishseapower
hi trevante, maybe you can help me out, again! :-)....

Here's the latest and greatest, yes checked and rechecked jumpers...the last post on here tells me it's not possible to connect up 2 IDE devices, I'm not sure that's true? ... ml#2471801



Posted: Mon Jun 06, 2005 3:53 pm
by britishseapower
its a power problem.

For some reason my 120 gig hdd doesnt get enough power from the xbox psu to be recognised at boot time. wierd.

Posted: Mon Jun 06, 2005 8:28 pm
by Trevante
Hmm... that's strange. Is the DVD drive also plugged in? Try unplugging it and see if that makes a difference.

Posted: Wed Jun 15, 2005 8:58 am
by britishseapower
in case anyone interested, I've got it working with a horrible hack...I've actually put a 2nd psu into the xbox case for my 2nd HDD (it really did come to this). works a treat though!


Posted: Wed Jul 06, 2005 5:26 pm
by souteneur3190
R0Bzombie wrote:
Trevante wrote:Btw, how much faster does Gentoox run with 128MB of RAM? I'm thinking of buying an old 1.0/1.1 and getting more RAM put in it for Linux, but I'm not sure if it's worth it.
On bootup it's amazing. It's booting lightning speed. I didn't try to emerge anything with 128mb because I've put the ram 2 days ago :D
And don't buy an old xbox, it's too expensive. Buy an old grafix card LEADTEK - WINFAST GeForce 2 Pro 64MB AGP 4x and the ram chips are the same as an xbox :)
Yes what about the proccessor? Does that increase speed too? Which one is more worth it?

Posted: Tue Apr 25, 2006 10:07 pm
by blighty
what would the correct entrys into fstab be btw?

2 the fella that added a extra psu, Did you try using the other psu before adding the two together? heard a tale or 2 about some psu`s having less beef than others.

Posted: Wed Apr 26, 2006 11:21 am
by blighty
I`ve edited my fstab and now my hdb shows on the storage media page but says it`s unmounted & if i click on it it says that hda is already mounted??

this is for a native install & i have only created 1 primary part on hdb.

I`d be real gratfull to anyone that can help, I was sat in front of this computer till 3;00 a.m last night looking at other peoples fstab entrys
, but I can`t find an example to copy from a native install.

# /etc/fstab: static file system information.
# <file system> <mount point> <type> <options> <dump> <pass>
/dev/hda1 none swap sw 0 0
/dev/hda2 / reiserfs defaults,errors=remount-ro 0 1
/dev/hdb / reiserfs defaults 0 0
proc /proc proc defaults 0 0

many thanks for taking a look.


Posted: Wed Apr 26, 2006 1:32 pm
by zlasher
This should probably be in another thread - Blighty..

First off .. you've partitioned the drive with fdisk /dev/hdb ??
have you formatted the partition with reiserfs ??`

# mkreiserfs /dev/hdb1

then.. As the computer may only have one root - try mounting your second drive as a volume in ie /mnt

# mkdir /mnt/disk2

then add this to fstab :
/dev/hdb1 /mnt/disk2 reiserfs defaults 0 0

then mount it

# mount /mnt/disk2

I haven't replaced the dvdrom in my xbox - but this should work..

I think what you did wrong was trying to mount two roots..

Steinar T

Posted: Wed Apr 26, 2006 3:02 pm
by blighty
:D thank you so much.

works perfectly now.

This has given me a huge boost now, My aim is to one day
learn how to use linux so I can kick that other sh*t of my pc
& be happy that I can mantain & look after my system.

I`ve been teaching myself ( learning from kind people like you ) how to use a pc for about 2 years now. I was never intrested untill all maner of good things started to happen on the xbox.

I keep trying to read through the manual at gentoo but it always gives me a headache & never really sinks in.

well anyway, between this thread and the native install thread, there is enough info for a complete noob like myself
to make a fully native gentoox xbox with 2 stock 10GB hdd`s.

thanks again.


200GB Support

Posted: Fri May 19, 2006 6:23 am
by ZhivaRebirth
I followed the cheesyboofs guide by the rule


and got a 200gb hard drive working... Everything fine (well except for the classic emerge sync problem that made me put xebian on it)

Then removed the stock dvdrom unit and tried to boot... Failed, even with cromwell BIOS, it does not boot if it doesnt has the Slave IDE unit.

Then put a LITE-ON DVDRW unit on it and tried... it boots! And better, linux can see it as a DVDRW unit.

Then removed the DVDRW and put an old CreativeLabs CDROM... it boots!

So, if you have both ide (master and slave units it boots). Im gonna try with a 400gb ide hard disk, so my XNas will manage 600GB total :)

Unit details
Xbox 1.0 With Cromwell BIOS (flashed with resctoolbox from here)

Re: 200GB Support

Posted: Mon May 22, 2006 12:20 pm
by zlasher
ZhivaRebirth wrote:I followed the cheesyboofs guide by the rule


and got a 200gb hard drive working... Everything fine (well except for the classic emerge sync problem that made me put xebian on it)
Did you abandon GentooX?? :shock:

I've tried to suggest this workaround/fix for the emerge sync problem - the problem as I've experienced is that the symlink points to the wrong version of linux.. (kernel 2.5 - something)

Code: Select all

xbox etc # ln -sf /usr/portage/profiles/default-linux/x86/no-nptl/2.4 /etc/make.profile 
xbox etc #
After "solving" it - I've only had the chance to try this out once - so if anyone got any extra time on their hands - try it and give me some feedback..

Any linux guru's should've solved this long ago! :lol:

Steinar T