Page 1 of 1

fsck on root: umount - device is busy problem

Posted: Wed Mar 09, 2005 12:56 am
by digitalbanana
I am trying to get mldonkey to work, and to stop pausing my downloads...
Some posts on another site reccoment fsck'ing the drive, so I have followed the instructions with no success.

I have tried to umount /dev/loop/0 (as this is the one to be checked, but is writable). and it just repeats 'device is busy' i have tried killing all the processes on the drive, but i get kicked off ssh because ssh is killed along with init!

and i cannot run fsck on a ritable drive as it says the drive has writable how can i fsck the drive?

any commands im missing here?

cheers for any help.

Posted: Wed Mar 09, 2005 1:47 am
by ShALLaX
How in the hell do you expect to unmount your filesystem whilst youre running the operating system? o.O

This is exactly what "Sparkle" was invented for - it fscks your filesystem safely. Also.... fscking isnt going to make mldonkey download quicker (or stop pausing) --- not sure what people's logic for that one is.

Posted: Wed Mar 09, 2005 3:18 pm
by digitalbanana
ooo....sorry! I assumed it unmounted the root from linux in a way, but obviously the HD could be accessed.

Just following advice, dont flame me for it, after all i am a n00b to all this stuff.

Posted: Fri Mar 11, 2005 2:35 am
by iccaros
apart from not posting in the Noobe section where we will not flame questions that a little reasearch will find the answer before you ask..

but here is some new person help!!!
try the command man man.. linux has a great thing called a man file

Running fsck : fsck should always be run in a single user mode which ensures proper repair of file system . If it is run in a busy system where the file system is changing constantly fsck may see the changes as inconsistencies and may corrupt the file system .

if the system can not be brought in a single user mode fsck should be run on the partitions ,other than root & usr , after unmounting them . Root & usr partitions can not be unmounted . If the system fails to come up due to root/usr files system corruption the system can booted with CD and root/usr partitions can be repaired using fsck.