Raid software

Ask questions regarding Gentoox, Gentoo and Linux in general in these forums and we'll do our best to help you!
Post Reply
lollo78
Newbie
Posts: 5
Joined: Wed Feb 23, 2005 5:52 pm

Raid software

Post by lollo78 » Thu Feb 24, 2005 9:54 am

Hi, i'm an italian noob.
I'm trying to create a linear array of /dev/loop1 /dev/loop2(i need it to overcome fatx name limitation without native install and use it as a partition for bittorrent).
I searched in this forum, linux-sotware-raid-HOW-TO and google but no luck.
My kernel is 2.4.22-xbox-Gentoox i don't know if it support raid(i haven't
this file /proc/mdstat) do i need a patch for kernel ? Which one ?
I already merged mdadm and raidtools.
I set up a etc/raidtab for two disks in linear mode, and the file looked like this:
raiddev /dev/md0
raid-level linear
nr-raid-disks 2
chunk-size 32
persistent-superblock 1
device /dev/loop1
raid-disk 0
device /dev/loop2
raid-disk 1

then i run mkraid /dev/md0 and get this:
"cannot determine md version :6"
I found on a forum that one solved this recompiling the kernel without RAID6 (how ?)

If i run this:
"mdadm --create --verbose /dev/md0 --level=linear --raid-devices=2 /dev/loop1 /dev/loop2"
I get this error: "mdadm: error opening /dev/md0: no such device or address"

using: "modprobe raid0"
i get : "can't locate module raid0"

Help
Thanx

User avatar
nobspangle
Gentoox Guru!
Posts: 1681
Joined: Sun Sep 28, 2003 11:59 am
Location: Manchester, UK

Post by nobspangle » Fri Feb 25, 2005 9:29 pm

I had a really quick play with this a while back, as far as I can tell it's not possible to create RAID arrays with loop back file systems. I only tried with mdadm so it might be possible with raid tools but I doubt it. In any case you will need to recompile the kernel with support for RAID. Also for linear RAID I think the module is linear, raid0 is for RAID0 arrays.
If you keep an open mind, will your brain fall out?

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests