Write permissions on fatx as ordinary user

Ask questions regarding Gentoox, Gentoo and Linux in general in these forums and we'll do our best to help you!
Post Reply
MetalMickey
Newbie
Posts: 6
Joined: Thu Jan 27, 2005 12:28 am

Write permissions on fatx as ordinary user

Post by MetalMickey » Thu Jan 27, 2005 12:33 am

I cant seem to see a manual, FAQ or previous post with a clear answer on this one.

I cant write to my f drive as an ordinary user. How do I change the permissions so that its possible? Ive tried chmoding the directories and the mount point as root but I get the error "operation not permitted".

Any help would be appreciated, as i dont want to be running p2p apps as root.

User avatar
ShALLaX
Site Admin
Posts: 1973
Joined: Sun Aug 10, 2003 9:25 pm
Location: England
Contact:

Post by ShALLaX » Thu Jan 27, 2005 12:36 am

Definitely in the Home manual (/etc/fstab) see the UMASK settings.
The original Xbox adaptation of Gentoo

MetalMickey
Newbie
Posts: 6
Joined: Thu Jan 27, 2005 12:28 am

Post by MetalMickey » Thu Jan 27, 2005 12:48 am

I must be blind, its right there. Thanks mate.

MetalMickey
Newbie
Posts: 6
Joined: Thu Jan 27, 2005 12:28 am

Post by MetalMickey » Thu Jan 27, 2005 1:26 am

Ok, I found the info in an old news post of yours, but it says that I should have the line in fstab set up as follows, which I have.

/dev/hda50 /mnt/fatx/e fatx defaults,umask=0000 0 0
/dev/hda55 /mnt/fatx/f fatx defaults,umask=0000 0 0

Funnily enough, the line is the same for /mnt/fatx/e, and i have full permissions there as a user:-

drwxrwxrwx 7 root root 16384 Jan 1 1970 e
drwxr-xr-x 9 root root 16384 Jan 1 1970 f

I cant see the manual entry you referred to either :(

User avatar
nobspangle
Gentoox Guru!
Posts: 1681
Joined: Sun Sep 28, 2003 11:59 am
Location: Manchester, UK

Post by nobspangle » Thu Jan 27, 2005 8:21 am

try doing

Code: Select all

chmod 777 /mnt/fatx/f
If you keep an open mind, will your brain fall out?

MetalMickey
Newbie
Posts: 6
Joined: Thu Jan 27, 2005 12:28 am

Post by MetalMickey » Thu Jan 27, 2005 1:10 pm

Xbox root # ls -l /mnt/fatx/
...
drwxr-xr-x 9 root root 16384 Jan 1 1970 f

Xbox root # chmod 777 /mnt/fatx/f

Seems to work, but then if i do
Xbox root # ls -l /mnt/fatx/

Permissions are exactly the same:
drwxr-xr-x 9 root root 16384 Jan 1 1970 f

Tried removing the umask altogether and rebooting, same result.

vplayer
1337
Posts: 442
Joined: Thu Oct 07, 2004 11:06 pm
Location: USA

Post by vplayer » Thu Jan 27, 2005 3:44 pm

Hi,

where in the f drive are you trying to write. What does you ls -l /mnt/fatx/ look like. Does both e and f show 755 permisisons.
Box: XBOX ver 1.1
Mod: Xecutor 2.3 lite+
Hdd: WD 80GB
Dash: Evox, Ava, XBMC
Linux: Gentoox Pro 4.2

MetalMickey
Newbie
Posts: 6
Joined: Thu Jan 27, 2005 12:28 am

Post by MetalMickey » Thu Jan 27, 2005 4:25 pm

where in the f drive are you trying to write.
Tried to write in the root, and in a nested folder in the root. Also tried to create directories in the root.
What does you ls -l /mnt/fatx/ look like. Does both e and f show 755 permisisons.
drwxrwxrwx 7 root root 16384 Jan 1 1970 e
drwxr-xr-x 9 root root 16384 Jan 1 1970 f

E shows 777 permission, f does not even after chmoding the directory 777 as root. Same UMASK settings, as posted above.

User avatar
ShALLaX
Site Admin
Posts: 1973
Joined: Sun Aug 10, 2003 9:25 pm
Location: England
Contact:

Post by ShALLaX » Thu Jan 27, 2005 5:08 pm

Did you read that you cannot give user write permission to the partition in which Gentoox is installed to.

I.e. if you have Gentoox installed to E:, ONLY root can write to E... if you have Gentoox on F:.. ONLY root can write to F:. This is for safety reasons (so users cant delete your rootfs), if you want to change it edit the initrd.gz/linuxrc file and add the appropriate umask where it mounts the rootfs.
The original Xbox adaptation of Gentoo

MetalMickey
Newbie
Posts: 6
Joined: Thu Jan 27, 2005 12:28 am

Post by MetalMickey » Thu Jan 27, 2005 8:22 pm

Ah, that makes sense.

Think ill just use my apps with sudo in that case.

User avatar
speedfrenzy
Newbie
Posts: 5
Joined: Tue Jan 23, 2007 9:56 pm
Location: Kassel, Germany
Contact:

Post by speedfrenzy » Tue Jan 23, 2007 10:19 pm

hi!

i got the same problem like MetalMickey, my rootfs is on partition f and i want to have write access on f as normal user........

i edit the linuxrc in this section

Code: Select all

if [ $INSTALLTYPE = "f-drive" ]; then
   mount -n -t fatx /dev/ide/host0/bus0/target0/lun0/part55 /newroot
   swapon /newroot/swap
   mount -n -o loop,notail /newroot/rootfs /rootfs
   if [ $? -ne 0 ]; then
      echo "Looks like you're not using reiserfs - removing notail"
      mount -n -o loop /newroot/rootfs /rootfs
   fi
fi
to

Code: Select all

mount -n -o loop,notail,umask=000 /newroot/rootfs /rootfs
and

Code: Select all

mount -n -o loop,umask=000 /newroot/rootfs /rootfs
, but that ends up in "invalid option -> kernel panic". also

Code: Select all

mount -n -o loop,notail,rw /newroot/rootfs /rootfs
and

Code: Select all

mount -n -o loop,rw /newroot/rootfs /rootfs
works, but does not have the effect, i want.

does anyone know, how to edit the linuxrc file right???
Image

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests