Page 1 of 1

Patitions F+G and native install on extra partition?

Posted: Fri Nov 05, 2004 9:03 am
by vale

i had installed a home edition on e. But i have noticed that i dont need all the things coming with it. So i want now to install the pro Version. I use gentoo since one year ago on my pc, so i think i have got experience to get it working. But for perfomanc issues i would like to do nativ install. I have a 200GB hdd and F+G activated. For now i only see native support on F. But that would mean it takes 120GB of my space for gentoo which i cant use for anything else with the xbox (for example Videos with XBMC).

So my question is if there is a possibility to only format about 20GB of my hdd with reiserfs for a native gentoox install. And all the rest should be accessible by XBMC, Evo and the other xbox stuff?
For example that i only resize my G from about 80 GB to 60GB and take the rest for Gentoox?

I would really apreciate if someone can give me a hint how to do that. I have read about the format of the xbox hdd with all that hda50-hda54 but i dont really come behind it, if it is possible to change somthing there with fdisk or not.

thx and excuse for bad english



Posted: Sat Nov 06, 2004 6:37 pm
by vale
ok ive read more and more. I come to the conclusion that this wont work. Cause xbox linux has the partitions fixed, because the xbox doesn't handle partiontables. There is some work done by paulb on xbox-scene, he has defined a new format for a partitiontable which is now supported by the new bioses and also by the homebrew tool xbpartitioner. This partitiontable is written to the harddisk not hardcoded in the bios. Now it would be necessary that the xbox linux supports this format too, then it would be possible to have the normal c+e+f+x+y+z and native partitions for linux for root and swap on every hdd. But it seems that nobody of the xbox linux people have interest in that. Instead they go on with the loopback device which in my opinion is no solution cause its way to slow.

At the moment the only way to go seems f as 137GB fatx partition and the rest with reiserfs as native G partition. But that is overkill for many people who only need perhaps 20GB for linux, just to run some small appls.


vale :cry:

Posted: Sun Nov 07, 2004 9:57 am
by nobspangle
provided you don't want to access your G or F drives from Linux. You should be able to resize the fatx partitions and install linux in the remaining space. Linux will only not understand the changes to the fatx partitions. The native partitions are standard linux ones so there are no problems there.

Posted: Sun Nov 07, 2004 10:18 am
by vale
thx for the hint i will try. I hadn't thought about that but sounds clever.



Posted: Sun Nov 07, 2004 3:45 pm
by vale
Ok finally i have what i wanted.

What i did:
with xbpartitioner started from an bios that supports the new LBA48, i made my G Drive smaller. So that at the end of the hdd there is aprox 25GB free. There one have to note the start sector and the length of the G partition to calculate on which sector one can make the linuxpartitions later. The start of the linux partition has to be +1 sector later then the end of G.

Then i made a ftp install of gentoox to e. I logged in via ssh and mainly proceeded like it is described here viewtopic.php?t=2006&highlight=native

Only one has to adapt with the right START Sector so that F & G stay how they are and can be accessed with xbox tools.

Now i have on a 200GB hdd:
-normal C+D+E Partitions
-Standard F Partition to the 136GB Limit
-G Partition which goes from end of F and is 40GB
- Swap+reiserfs for native gentoox from the end of G to the end of the drive
256Mb Swap & 25 GB reiserfs for root

The only thing which now doesnt work is access to G from within Linux. But I think one can live with that :lol:

I just write this here to help other people which perhaps want a similar setup!



Posted: Wed Nov 10, 2004 10:14 pm
by bisch79
Hi vale , I think what you have pulled off is what a lot of us were wondering was possible before. My question is, I only have an 80 Gig hard drive, and won't be switching it now due to the new xbox live banning system implemented nov 8th. So I'd like to basically format the 80 gig drive again, but onlyl the F partition if possiblet, and just take the last 10 gigs or so and format it so it's a native linux filesystem. This is basically what your doing with the additional space on G I take it.

How is this working out so far for you? Have you tried to pull off any magic updates yet, and if so does the install still work? I'm very interested in trying this if you think it's feasable and if you can post any additional steps taken that'd great.


Posted: Fri Nov 12, 2004 5:14 pm
by vale
hey sorry i didn`t remember to look in the forum earlier.

Here all goes fine, magic working and so on ...

Ok what you want to do is very similar to my config. You want a customized size of F, and extra partitions for native gentoox. on the end of the hdd. And also C,D,E should stay standard for being possible to use xbox live.

Ok so would do I: Backup your C,E data and F if you need. Get yourself a bios thats support the new lba48 with partition table. I dont know which all do, but evo M8 works fine here. Get xbpartitioner from the place you should know... and run it from your dashboard. There you should resize F so that there is enough Space left at the end of the hdd for later making your swap partition (256MB) and your rootfs the size you want. You have to write down the beginning of your F Partition and the length which are both shown on xbpartitioner. You have to sum the length to the startsector so that you get the endingsector. Convert to dezimal for later use. Write the partitiontable and format within xbpartitioner.

Then you do a normal ftp of gentoox to E. From gentoox console you can then make your partitions with fdisk. For that you should use the scripts mentioned above but setting your startsector to the endingsector of F +1.

Thats all! The scripts should do all for you.Creating swap and rootfs partitions. Moving rootfs to the new partition and also adapting your fstab and initrd.gz for booting from then on to the native partitions. And also If you want to understand what they do just do all the steps manually ...



Posted: Sat Nov 27, 2004 8:42 am
by bisch79
Hello again Vale, I've finally got around to trying your method, but I'm having a few problems. I'm quite confident I understand how everything works.
The problem I have is whenever anything is written to the hard disk for when partitions are concerned the other is messed up. I'll try to explain, I have a 160 gb hard drive i'm using for a test right now, I'm trying to install linux natively on the G partion, specifically the last 10 gigs. So I edit the G partition via xbpartitioner it saves, all is good it's 10 gigs smaller in avalaunch/evox dash. Then I go into linux and zero the disk via the DD method, then create the two now partitions for swap and root, via hda1 and hda2 and write with w.

It'll give me a message that the kernel will continue to use the previous table, but my changes will take place after reboot. Sure enough they do take place in linux and the native drives are present, /hda1 &2, but now my G drive has been reformated and is picked up as the full size, not reduced by 10 gigs in ava/evox dash.

So if I change XBpartioner back to the right size sans 10 gigs I want for linux, then the linux drives created are gone, How do I rectify this cycle?

Posted: Sun Nov 28, 2004 12:47 pm
by vale

for me it seems that you dont write the partition table to the hdd with xbpartitioner. What happens if you make your partitions in xbpartitioner like you did and then reboot directly to evo again. Does it show the right size or not?

So if it shows the original size again then that is the problem. Read the instructions from xbpartitioner to learn how to write a persistant partitiontable to the hdd. I dont know from memory which buttons you have to press.

Also dont forget to start the fdisk in gentoox via fdisk -u /dev/hda
the -u parameter forces to show all positions in sectors which is what you see in xbpartitioner too except conversion from hex to decimal system!

hope that helps, let me know if there is something i can help you with! If i forget to look here write a pm, that remembers me via email!



Posted: Sun Nov 28, 2004 6:01 pm
by bisch79
hey this is what I do step by step.

Run xbpartitioner I resize the G (part 7) partition , by changing the end sector, it starts at 0fffffff (268435455) is + 0165a0c1 for the end which is aproximately 1165a0c0 = 291872960. I then hit start, which writes the partition table and formats the G drive changes. I exit XBpartitioner to avalaunch and I have the appropriate size show remaining for G, aproximately 12gigs left. All looks good at this point.

So I fire up stardust, and ctrl-c to break to terminal. I therefore do a fdisk /dev/hda and the p, noticing htere are no other partitions shown.
now I do the dd if=/dev/zero of=/dev/hda seek=291872961 bs=512 count=1 to remove the fatx info from the part table.
next I do a fdisk -u /dev/hda and do the following
enter (take it to the end space of the drive)
p (to verify, prints out what's there and it is exactly what I want)
w (now it says error 16 file in use, but then says changes will not take place until reboot, writing to table, syncing disks etc)
so now I reboot

get into avalaunch i notice my G drive is now 23gigs again, bummer
go into linux, the two drives are now created and mountable, and the right size. Not sure what to do
I've tried resizing making changes in xbpartitioner again, and it'll bomb the linux drives, just seems to not be possible to me
I'm using an evox m8 with part6 goes to 137gb, part 7 takes the rest along with xbpartitioner 1.0 (the latest)

other attempts include using the evox bios to resize with xbpartitioner, then making the changes in lnux with a cromwell bios and an x2 bios, no difference.
making my F drive larger and no G drive, now when I write teh tables in linux, I boot back up to find a formated to 137 gig F drive and a 23 gig G drive, back to default, just crazy.

It seems to me that XBpartitioner and linux fdisk are writing changing the same file each time, so whoever writes last , screws the other

So if you have any idea's where I'm going wrong here please let me know,
Thanks again,

Posted: Sun Nov 28, 2004 8:31 pm
by vale
ok seems that it doesnt work like i thought. I looked again at the sizes on evo. And it is like you said. G shows up the entire space from 137GB to the end. So it seems that this extended partition table on hdd is not read correct. So to do it the way i did it is dangerous cause you can overwrite easily your linux just by putting enough stuff on G.

Im sorry for having you made so much thinking about that bisch79! It seems that i was so convinced it would work that way that i didnt checked the size after a reboot on the evox dash.

excuse me! It works this way but it is dangerous to write to G !



Posted: Sun Dec 19, 2004 5:50 am
by shedt
can someone break this down a bit more for someone who is new to linux ? i'm not stupid, but i like to understand what i am doing, not guess that i am following instructions correctly.

Posted: Tue Apr 25, 2006 7:47 am
by StickyIckyBud
I am at exactly the same point in this problem as bisch79!

and those three posts are his only three posts in the forum, too funny....

Posted: Sun Jun 25, 2006 10:00 pm
by flipdee
I am having exactly the same problem also.
I have a v1.4 Xbox, X3CE chip, X3 3294 Bios with "Use saved Partitions" enabled.
It seems that once I do a native "F" install on my 320GB HD the partition table is ignored so G ends up defaulting back to "taking rest of drive after F" i.e. 120GB
I had thought it was a 256GB partition problem but resized F to 56GB and left G as 255GB.
Maybe it's because I used XBPartitioner. Is it possible to use an alternative to get the same result but let it work?
My ultimate aim would be to have (inc. normal stock partitions c,e,xyz of course) 10GB native F partition for gentoox and approx 300GB fatx G partition so both gentoox and other dashboard/mediaplayers can access a common repository.

This has been driving me bonkers, maybe i'm asking too much but I have been blaming the X3 bios and the LBA48 options somehow taking over and ignoring the saved partition table but if anyone can give an insight into what is happening, please do.

Many thanks,