must include --passive-ftp when downloading in .b0x files

Post information here about bugs - please remember to provide an accurate and detailed description and, if possible, steps on how to replicate the issue.
Locked
epoch
Newbie
Posts: 2
Joined: Sat Dec 06, 2003 8:40 pm

must include --passive-ftp when downloading in .b0x files

Post by epoch » Sat Dec 06, 2003 8:46 pm

When a .b0x update script needs to download from an ftp site (most noteably the alsa update), its important to include --passive-ftp in the wget command. Otherwise on address translated networks, you'll have the very annoying result of

Code: Select all

This will enable ALSA sound and 5.1 optical audio output (ALSA 0.9.2)
Getting ALSA source
--21:35:52--  ftp://ftp.alsa-project.org/pub/driver/alsa-driver-0.9.2.tar.bz2
           => `alsa-driver-0.9.2.tar.bz2'
Resolving ftp.alsa-project.org... done.
Connecting to ftp.alsa-project.org[160.217.9.25]:21... connected.
Logging in as anonymous ... Logged in!
==> SYST ... done.    ==> PWD ... done.
==> TYPE I ... done.  ==> CWD /pub/driver ... done.
==> PORT ...
Invalid PORT.
Retrying.


I'm going to write a wrapper around wget to take care of this automatically for now, but it would be nice to see fixed in a later revision

/Matt/

User avatar
ShALLaX
Site Admin
Posts: 1973
Joined: Sun Aug 10, 2003 9:25 pm
Location: England
Contact:

Post by ShALLaX » Thu Dec 11, 2003 1:51 pm

This has been fixed.
The original Xbox adaptation of Gentoo

Locked

Who is online

Users browsing this forum: No registered users and 1 guest