Page 1 of 1

Kernel upgrade did not work with pro

Posted: Sat Oct 25, 2003 2:05 am
by boss302
System is pro without xfree or kde.
Up to date to last friday with emerge sync. and emerge -u world --deep

Ran magic, detected that new kernel was needed.
Left system alone, after some time (around an hour maybe more) I found the system had rebooted and was back to my dashboard. I booted linux again, got a message about something that needed to run once, (I also noticed that the eth0 was not up) I get a message
An error occurred
Retrying in 10 seconds
Which repeats over and over.
------ Update 1
Eventually the system reboots to the old kernel, but nvnet does not load, I have console access but when I try to load nvnet it complains about being compiled with gcc version 2.

So magic does not work (no network)
I will keep plugging away.
------ Update 2 (almost completly recovered!)
Apparently what happened, was the kernel upgrade seemed to think I had pro installed on e when it's installed on f.

I fixed the system, by manually putting the 2 updated modules in initrd.gz, moving the linuxboot.cfg file and kernel from e to f. The system then booted with the new kernel, and when I ran magic it is now fixing alsa.
------ Update 3 (fully recovered)
Magic fixed alsa, updated the modules script network driver and a bunch of other stuff. I ran xbvset, set to 800x600 and rebooted.
All is well, I'm running a emerge sync now to get any other gentoo updates that are available.

Posted: Sun Oct 26, 2003 11:33 am
by ShALLaX
Yes, youre never meant to put the initrd files and vmlinuz files on F:, they should always go in the root of E:. The only files that should be put to F: with an F: installation are "swap" and "rootfs".

Posted: Mon Oct 27, 2003 2:10 am
by boss302
Ahh, I didn't know that, I thought after moving to f it all went over there.
No matter, I'm fixed again ....
I seem to remember having similar problems during the last kernel upgrade from drive f also. I will move the files to e.

Posted: Mon Oct 27, 2003 6:15 pm
by ShALLaX