ctrl-alt-backspace

Post information here about bugs - please remember to provide an accurate and detailed description and, if possible, steps on how to replicate the issue.
Post Reply
StickyIckyBud
Novice
Posts: 27
Joined: Mon Mar 20, 2006 6:20 am

ctrl-alt-backspace

Post by StickyIckyBud » Wed Mar 22, 2006 3:17 am

this is a relatively clean install. f drive. xfce.

when I hit ctrl-alt-backspace X reboots, but when it comes back up to what should be the login screen the colors are all orange and screwy looking. I *think* this is a bug, but maybe I messed something up. Can anyone duplicate this for me?

As much as I would like ctrl-alt-backspace to work, I would also like to know if there is an easier way to update changes made to:
$HOME/.themes/xfwm4/custom.keys/foo

...aside from restarting X?

StickyIckyBud
Novice
Posts: 27
Joined: Mon Mar 20, 2006 6:20 am

*BUMP*

Post by StickyIckyBud » Thu Mar 23, 2006 1:35 am

a simple, "no Sticky, this is not a bug - my ctrl-alt-backspace works just fine" would really help me get motivated to track this down.

anyone?

vplayer
1337
Posts: 442
Joined: Thu Oct 07, 2004 11:06 pm
Location: USA

Post by vplayer » Thu Mar 23, 2006 1:40 am

but where do you hit ctrl+alt+backspace. I dont have a keyboard hooked to the xbox..
Box: XBOX ver 1.1
Mod: Xecutor 2.3 lite+
Hdd: WD 80GB
Dash: Evox, Ava, XBMC
Linux: Gentoox Pro 4.2

StickyIckyBud
Novice
Posts: 27
Joined: Mon Mar 20, 2006 6:20 am

Post by StickyIckyBud » Thu Mar 23, 2006 4:53 am

well at least you're trying!

i HIGHLY recommend a USB mod - mine took all day one saturday, and I used nothing but spare PC parts. I have TONS of pics but I never got around to doing a proper tutorial... There's lots of other guides on xbox-scene, but I don't think any had enough PICTURES. If you'd be interested in seeing it all dolled up let me know, maybe I'll take an hour and draft a proper manual. My wireless keyboard and mouse combo works GREAT in linux - $34 on newegg, and they're probably cheaper now.

One would hit CTRL-ALT-BACKSPACE while in X windows. Or at least I think its an X11 thing because its not specific to any one WM as far as I know - maybe its gdm... Anyway, the purpose of the command is to restart X. I'm not sure if you could issue the command on the onscreen keyboard. kvgdm? (I'm lost w/o tab complete)

Anyway. Still waiting for someone with a keyboard to try hitting CTRL-ALT-BACKSPACE while in XFCE (or even KDE).

orochi
Gentoox Guru!
Posts: 606
Joined: Sun Oct 24, 2004 8:11 am

Post by orochi » Thu Mar 23, 2006 7:35 am

ctrl alt backspace will kill your x session, why not just close it normally? does it still have weird colors then?

StickyIckyBud
Novice
Posts: 27
Joined: Mon Mar 20, 2006 6:20 am

Post by StickyIckyBud » Thu Mar 23, 2006 8:03 am

you mean like

Code: Select all

Xbox root # ps aux | grep X 
root 1584  0.4  6.5 9496  3788 ?        S    Mar22   1:21 /usr/X11R6/bin/X :0 -nolisten tcp -auth /var/gdm/:0.Xauth -nolisten tcp vt7
root 3251  0.0  0.3   1292   232 pts/0    R+   01:56   0:00 grep X

Xbox root # kill -9 1584
???

cause I'm pretty sure gdm will restart it - and then yes I get the crazy colors. I'll try as soon as I post this and let you know.

Umm.. </begin caps>is anyone near an xbox running linux with a keyboard attached? please hit ctrl-alt-backspace and post the results</end caps>

I hate having to yell...

StickyIckyBud
Novice
Posts: 27
Joined: Mon Mar 20, 2006 6:20 am

YOU DA MAN

Post by StickyIckyBud » Thu Mar 23, 2006 8:36 am

Well, THAT WORKED!

I hit enter just *knowing* that I was going to have to restart my box - but instead I came up to the normal login screen!

I hit CTRL-ALT-BACKSPACE to see if I could still reproduce the hic-up, and it also returned me to the regular login screen.

I'm FIXED!

User avatar
ShALLaX
Site Admin
Posts: 1973
Joined: Sun Aug 10, 2003 9:25 pm
Location: England
Contact:

Post by ShALLaX » Thu Mar 23, 2006 12:55 pm

This is a known bug which is already reported in this very forum.
The original Xbox adaptation of Gentoo

StickyIckyBud
Novice
Posts: 27
Joined: Mon Mar 20, 2006 6:20 am

work around?

Post by StickyIckyBud » Tue Jun 13, 2006 4:49 am

This seems to "work"

ctrl-alt-backspace and gdm comes up all orange (is that just my tv?)
TO FIX W/O REBOOTING
switch to any other virtual terminal (Ctrl-Alt-F!) and log-in as root
# killall gdm
# startx&
*switch back to your vterm
# killall startx
# gdm start

seems to come back up all normal like, no idea why....

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest